source: projects/specs/trunk/p/perl-Parse-Yapp/perl-Parse-Yapp-vl.spec @ 12121

Revision 12121, 3.7 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: Perl extension for generating and using LALR parsers.
4Name: perl-Parse-Yapp
5Version: 1.21
6Release: 1%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/~fdesar/Parse-Yapp/
10
11Source0: http://search.cpan.org/CPAN/authors/id/F/FD/FDESAR/Parse-Yapp-%{version}.tar.gz
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16BuildArch: noarch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: perl(ExtUtils::MakeMaker)
19Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21
22%description
23Parse::Yapp (Yet Another Perl Parser compiler) is a collection of
24modules that let you generate and use yacc like thread safe
25(reentrant) parsers with perl object oriented interface.  The script
26yapp is a front-end to the Parse::Yapp module and let you easily
27create a Perl OO parser from an input grammar file.
28
29%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
30# Provide perl-specific find-{provides,requires}.
31%define __find_provides /usr/lib/rpm/find-provides.perl
32%define __find_requires /usr/lib/rpm/find-requires.perl
33%endif
34
35%prep
36%setup -q -n Parse-Yapp-%{version}
37## fix file permission
38%__chmod 0644 README
39find lib -type f | xargs chmod 0644
40
41%build
42CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
43make
44
45%install
46rm -rf $RPM_BUILD_ROOT
47mkdir -p $RPM_BUILD_ROOT%{_prefix}
48make install DESTDIR=$RPM_BUILD_ROOT
49
50[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
51
52find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
53
54find $RPM_BUILD_ROOT/usr -type f -print |
55        sed "s@^$RPM_BUILD_ROOT@@g" |
56        grep -v perllocal.pod |
57        grep -v "\.packlist" > Parse-Yapp-%{version}-filelist
58if [ "$(cat Parse-Yapp-%{version}-filelist)X" = "X" ] ; then
59    echo "ERROR: EMPTY FILE LIST"
60    exit -1
61fi
62
63%check
64make test
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%files -f Parse-Yapp-%{version}-filelist
71%defattr(-,root,root)
72%doc README Changes
73%dir %{perl_vendorlib}/Parse
74%dir %{perl_vendorlib}/Parse/Yapp
75
76%changelog
77* Mon May 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.21-1
78- new upstream release.
79- rebuilt with perl-5.26.
80
81* Wed Nov  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.05-34
82- rebuilt with perl 5.16.3
83- updated URL
84
85* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.05-33
86- fix file permission
87- add documents
88- add directories in files
89
90* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.05-32vl6
91- build with perl 5.12.3
92- defined __find_{provides,requires} with vl4 and vl5
93- add Vendor and Distribution tags
94
95* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.05-31vl5
96- applied new versioning policy
97
98* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.05-30vl6
99- installed files to vendor_perl
100- changed Group to Development/Libraries
101
102* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.05-30vl5
103- build on perl-5.8.6-0vl1
104
105* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl4
106- built on perl-5.8.2
107
108* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl3
109- built on perl-5.8.1
110
111* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl2
112- build on perl-5.8.0
113
114* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl1
115- Build for VineLinux
116
117* Mon Jan 27 2003 Chip Turner <cturner@redhat.com>
118- version bump and rebuild
119
120* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
121- automated release bump and build
122
123* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
124- properly claim directories owned by package so they are removed when package is removed
125
126* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
127- automated rebuild
128
129* Fri Dec 7 2001 root <root@redhat.com>
130- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.