source: projects/specs/trunk/p/perl-Parse-RecDescent/perl-Parse-RecDescent-vl.spec @ 9143

Revision 9143, 6.1 KB checked in by inagaki, 9 years ago (diff)

2014-12-11 Ryoichi INAGAKI <ryo1@…>

  • perl-Apache-Htpasswd, perl-Cache-Cache, perl-MRO-Compat, perl-Parse-RecDescent?, perl-Pod-{Eventual, POM, Tests}, perl-Proc-{ProcessTable?, Simpler}: updated
  • perl-Parse-Nessus-NBE: rebuilt


Line 
1Name:           perl-Parse-RecDescent
2Version:        1.967009
3Release:        1%{?_dist_release}
4Summary:        Parse-RecDescent Perl module
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Parse-RecDescent/
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Parse-RecDescent-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12BuildRequires:  perl(Carp)
13BuildRequires:  perl(Data::Dumper)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Module::Build)
16BuildRequires:  perl(Text::Balanced)
17BuildRequires:  perl(Test::More)
18BuildRequires:  perl(Test::Pod)
19BuildRequires:  perl(Test::Warn)
20BuildRequires:  perl(version)
21Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
22
23Distribution:   Vine
24Vendor:         Project Vine
25Packager:       munepi, shaolin
26
27%{?perl_default_filter}
28
29%description
30Parse::RecDescent incrementally generates top-down recursive-descent
31text parsers from simple yacc-like grammar specifications. It
32provides:
33    * Regular expressions or literal strings as terminals (tokens),
34    * Multiple (non-contiguous) productions for any rule,
35    * Repeated and optional subrules within productions,
36    * Full access to Perl within actions specified as part of the
37      grammar,
38    * Simple automated error reporting during parser generation and
39      parsing,
40    * The ability to commit to, uncommit to, or reject particular
41      productions during a parse,
42    * The ability to pass data up and down the parse tree ("down" via
43      subrule argument lists, "up" via subrule return values)
44    * Incremental extension of the parsing grammar (even during a
45      parse),
46    * Precompilation of parser objects,
47
48User-definable reduce-reduce conflict resolution via "scoring" of
49matching productions.
50
51
52%prep
53%setup -q -n Parse-RecDescent-%{version}
54
55chmod a-x demo/* tutorial/*
56%{__perl} -pi -e 's|^#!\s?/usr/local/bin/perl\b|#!%{__perl}|' demo/*
57%{__perl} -pi -e 's|^#!\s?/opt/local/bin/perl5\.10\.0\b|#!%{__perl}|' demo/*
58for f in Changes demo/demo_dot.pl; do
59  iconv -f iso-8859-1 -t utf-8 < "$f" > "${f}_" && %__mv -f "${f}_" "$f"
60done
61
62
63%build
64%{__perl} Makefile.PL INSTALLDIRS=vendor
65%__make %{?_smp_mflags}
66
67
68%install
69%__rm -rf %{buildroot}
70%__make pure_install DESTDIR=%{buildroot}
71find %{buildroot} -type f -name .packlist -exec %__rm -f {} ';'
72find %{buildroot} -type d -depth -exec %__rmdir {} 2>/dev/null ';'
73%__chmod -R u+w %{buildroot}/*
74
75
76%check
77%__make test
78
79
80%clean
81%__rm -rf %{buildroot}
82
83
84%files
85%defattr(-,root,root,-)
86%{perl_vendorlib}/Parse/
87%{_mandir}/man3/*.3*
88%doc Changes README demo/ tutorial/
89
90
91%changelog
92* Wed Dec 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.967009-1
93- updated to 1.967009
94- built with perl 5.16.3
95
96* Mon Mar 12 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.964-2
97- rebuild
98
99* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.964-1
100- initial build
101
102* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.964-2
103- Mass rebuild with perl-5.12.0
104
105* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.964-1
106- update, fix previous issue and https://rt.cpan.org/Public/Bug/Display.html?id=53948
107
108* Tue Feb 16 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.963-2
109- apply upstream patch https://rt.cpan.org/Public/Bug/Display.html?id=54457
110  which should fix problems with rebuilds of other modules
111
112* Tue Feb  9 2010 Paul Howarth <paul@city-fan.org> 1.963-1
113- update to 1.963 (fix subtle bug in leftop and rightop due to removal of $&)
114- recode Changes as utf-8
115- more script interpreter fixes
116
117* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.962.2-1
118- updated for latest GA SQL::Translator
119- add default filtering
120- auto-update to 1.962.2 (by cpan-spec-update 0.01)
121- added a new br on perl(Text::Balanced) (version 0)
122
123* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-3
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
125
126* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-2
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
128
129* Mon Feb  2 2009 Stepan Kasal <skasal@redhat.com> - 1.96-1
130- new upstream version
131
132* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-5
133- Rebuild for perl 5.10 (again)
134
135* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-4
136- rebuild for new perl
137
138* Wed Nov 14 2007 Robin Norwood <rnorwood@redhat.com> - 1.95.1-3
139- Apply fixes from package review:
140  - Remove BR: perl
141  - Use iconv to convert file to utf-8
142  - Include BR: perl(Test::Pod)
143  - Fix old changelog entry
144- Resolves: bz#226274
145
146* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-2
147- add BR: perl(version), perl(Test::More)
148
149* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-1
150- bump to 1.95.1
151- correct license tag (now under perl license)
152- add BR: perl(ExtUtils::MakeMaker)
153
154* Fri Jul 20 2007 Robin Norwood <rnorwood@redhat.com> - 1.94-6.fc8
155- Bring fixes from EPEL build into F8
156- Fix minor specfile issues
157- Package the docs as well
158
159* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.94-5.2.1
160- rebuild
161
162* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.94-5.2
163- rebuild for new perl-5.8.8
164
165* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
166- rebuilt for new gcc
167
168* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
169- rebuilt for new gcj
170
171* Thu Apr 21 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.94-5
172- #155620
173- Bring up to date with current Fedora.Extras perl spec template.
174
175* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1.94-4
176- rebuild
177
178* Tue Feb 17 2004 Chip Turner <cturner@redhat.com> 1.94-2
179- fix rm to not be interactive (bz115997)
180
181* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 1.94-1
182- update to 1.94
183
184* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
185- automated release bump and build
186
187* Sat Jul 20 2002 Chip Turner <cturner@localhost.localdomain>
188- remove Text::Balanced modules since they are now in core perl
189
190* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
191- description update
192
193* Fri Jun 07 2002 cturner@redhat.com
194- Specfile autogenerated
Note: See TracBrowser for help on using the repository browser.