source: projects/specs/trunk/p/perl-Parse-RecDescent/perl-Parse-RecDescent-vl.spec @ 5890

Revision 5890, 6.0 KB checked in by shaolin, 12 years ago (diff)
Line 
1Name:           perl-Parse-RecDescent
2Version:        1.964
3Release:        1%{?_dist_release}
4Summary:        Parse-RecDescent Perl module
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Parse-RecDescent/
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Parse-RecDescent-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12BuildRequires:  perl(Carp)
13BuildRequires:  perl(Data::Dumper)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Module::Build)
16BuildRequires:  perl(Text::Balanced)
17BuildRequires:  perl(Test::More)
18BuildRequires:  perl(Test::Pod)
19BuildRequires:  perl(Test::Warn)
20BuildRequires:  perl(version)
21Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
22
23Distribution:   Vine
24Vendor:         Project Vine
25Packager:       munepi, shaolin
26
27%{?perl_default_filter}
28
29%description
30Parse::RecDescent incrementally generates top-down recursive-descent
31text parsers from simple yacc-like grammar specifications. It
32provides:
33    * Regular expressions or literal strings as terminals (tokens),
34    * Multiple (non-contiguous) productions for any rule,
35    * Repeated and optional subrules within productions,
36    * Full access to Perl within actions specified as part of the
37      grammar,
38    * Simple automated error reporting during parser generation and
39      parsing,
40    * The ability to commit to, uncommit to, or reject particular
41      productions during a parse,
42    * The ability to pass data up and down the parse tree ("down" via
43      subrule argument lists, "up" via subrule return values)
44    * Incremental extension of the parsing grammar (even during a
45      parse),
46    * Precompilation of parser objects,
47
48User-definable reduce-reduce conflict resolution via "scoring" of
49matching productions.
50
51
52%prep
53%setup -q -n Parse-RecDescent-%{version}
54
55chmod a-x demo/* tutorial/*
56%{__perl} -pi -e 's|^#!\s?/usr/local/bin/perl\b|#!%{__perl}|' demo/*
57%{__perl} -pi -e 's|^#!\s?/opt/local/bin/perl5\.10\.0\b|#!%{__perl}|' demo/*
58for f in Changes demo/demo_dot.pl; do
59  iconv -f iso-8859-1 -t utf-8 < "$f" > "${f}_" && %__mv -f "${f}_" "$f"
60done
61
62
63%build
64%{__perl} Makefile.PL INSTALLDIRS=vendor
65%__make %{?_smp_mflags}
66
67
68%install
69%__rm -rf %{buildroot}
70%__make pure_install DESTDIR=%{buildroot}
71find %{buildroot} -type f -name .packlist -exec %__rm -f {} ';'
72find %{buildroot} -type d -depth -exec %__rmdir {} 2>/dev/null ';'
73%__chmod -R u+w %{buildroot}/*
74
75
76%check
77%__make test
78
79
80%clean
81%__rm -rf %{buildroot}
82
83
84%files
85%defattr(-,root,root,-)
86%{perl_vendorlib}/Parse/
87%{_mandir}/man3/*.3*
88%doc Changes README demo/ tutorial/
89
90
91%changelog
92* Mon Mar 12 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.964-2
93- rebuild
94
95* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.964-1
96- initial build
97
98* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.964-2
99- Mass rebuild with perl-5.12.0
100
101* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.964-1
102- update, fix previous issue and https://rt.cpan.org/Public/Bug/Display.html?id=53948
103
104* Tue Feb 16 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.963-2
105- apply upstream patch https://rt.cpan.org/Public/Bug/Display.html?id=54457
106  which should fix problems with rebuilds of other modules
107
108* Tue Feb  9 2010 Paul Howarth <paul@city-fan.org> 1.963-1
109- update to 1.963 (fix subtle bug in leftop and rightop due to removal of $&)
110- recode Changes as utf-8
111- more script interpreter fixes
112
113* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.962.2-1
114- updated for latest GA SQL::Translator
115- add default filtering
116- auto-update to 1.962.2 (by cpan-spec-update 0.01)
117- added a new br on perl(Text::Balanced) (version 0)
118
119* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-3
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
121
122* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-2
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
124
125* Mon Feb  2 2009 Stepan Kasal <skasal@redhat.com> - 1.96-1
126- new upstream version
127
128* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-5
129- Rebuild for perl 5.10 (again)
130
131* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-4
132- rebuild for new perl
133
134* Wed Nov 14 2007 Robin Norwood <rnorwood@redhat.com> - 1.95.1-3
135- Apply fixes from package review:
136  - Remove BR: perl
137  - Use iconv to convert file to utf-8
138  - Include BR: perl(Test::Pod)
139  - Fix old changelog entry
140- Resolves: bz#226274
141
142* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-2
143- add BR: perl(version), perl(Test::More)
144
145* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-1
146- bump to 1.95.1
147- correct license tag (now under perl license)
148- add BR: perl(ExtUtils::MakeMaker)
149
150* Fri Jul 20 2007 Robin Norwood <rnorwood@redhat.com> - 1.94-6.fc8
151- Bring fixes from EPEL build into F8
152- Fix minor specfile issues
153- Package the docs as well
154
155* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.94-5.2.1
156- rebuild
157
158* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.94-5.2
159- rebuild for new perl-5.8.8
160
161* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
162- rebuilt for new gcc
163
164* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
165- rebuilt for new gcj
166
167* Thu Apr 21 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.94-5
168- #155620
169- Bring up to date with current Fedora.Extras perl spec template.
170
171* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1.94-4
172- rebuild
173
174* Tue Feb 17 2004 Chip Turner <cturner@redhat.com> 1.94-2
175- fix rm to not be interactive (bz115997)
176
177* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 1.94-1
178- update to 1.94
179
180* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
181- automated release bump and build
182
183* Sat Jul 20 2002 Chip Turner <cturner@localhost.localdomain>
184- remove Text::Balanced modules since they are now in core perl
185
186* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
187- description update
188
189* Fri Jun 07 2002 cturner@redhat.com
190- Specfile autogenerated
Note: See TracBrowser for help on using the repository browser.