source: projects/specs/trunk/p/perl-POE/perl-POE-vl.spec @ 12120

Revision 12120, 8.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:      perl-POE
2Version:   1.367
3Release:   1%{?_dist_release}
4Summary:   POE - portable multitasking and networking framework for Perl
5
6Group:     Development/Libraries
7License:   GPL+ or Artistic
8URL:       http://search.cpan.org/dist/POE/
9Source0:   http://search.cpan.org/CPAN/authors/id/R/RC/RCAPUTO/POE-%{version}.tar.gz
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14BuildArch: noarch
15Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
16
17BuildRequires:  perl(ExtUtils::MakeMaker)
18BuildRequires:  perl(Compress::Zlib)
19BuildRequires:  perl(Curses)
20BuildRequires:  perl(Data::Dumper)
21BuildRequires:  perl(Errno)
22BuildRequires:  perl(Exporter)
23BuildRequires:  perl(File::Spec)
24BuildRequires:  perl(IO)
25BuildRequires:  perl(IO::Handle)
26BuildRequires:  perl(IO::Pipely)
27BuildRequires:  perl(IO::Poll)
28BuildRequires:  perl(IO::Pty)
29BuildRequires:  perl(IO::Socket)
30BuildRequires:  perl(IO::Tty)
31BuildRequires:  perl(HTTP::Date)
32BuildRequires:  perl(HTTP::Request)
33BuildRequires:  perl(HTTP::Response)
34BuildRequires:  perl(HTTP::Status)
35#BuildRequires:  perl(POE::Test::Loops)
36BuildRequires:  perl(Socket)
37BuildRequires:  perl(Socket6)
38BuildRequires:  perl(Storable)
39BuildRequires:  perl(Term::Cap)
40BuildRequires:  perl(Term::ReadKey)
41BuildRequires:  perl(Time::HiRes)
42BuildRequires:  perl(URI)
43# test
44BuildRequires:  perl(Test::Harness)
45BuildRequires:  perl(Test::More)
46BuildRequires:  perl(Test::Pod)
47BuildRequires:  perl(Test::Pod::Coverage)
48
49Requires:       perl(Compress::Zlib)
50Requires:       perl(Data::Dumper)
51Requires:       perl(Errno)
52Requires:       perl(Exporter)
53Requires:       perl(File::Spec)
54Requires:       perl(IO::Handle)
55Requires:       perl(IO::Pty)
56Requires:       perl(IO::Tty)
57Requires:       perl(POSIX)
58Requires:       perl(Socket)
59Requires:       perl(Socket6)
60Requires:       perl(Storable)
61
62%{?perl_default_filter}
63
64%description
65POE is a framework for cooperative, event driven multitasking in Perl.
66Other languages have similar frameworks. Python has Twisted. TCL has "the
67event loop".
68
69POE originally was developed as the core of a persistent object server and
70runtime environment. It has evolved into a general purpose multitasking
71and networking framework, encompassing and providing a consistent interface
72to other event loops such as Event and the Tk and Gtk toolkits.
73
74POE is written in layers, each building upon the previous. It's therefore
75possible to use POE at varying levels of abstraction.
76
77
78%prep
79%setup -q -n POE-%{version}
80# make rpmlint happy...
81chmod -c -x examples/*
82find t/ -type f -exec chmod -c -x {} +
83find t/ -type f -name '*.t' -exec perl -pi -e 's|^#!perl|#!%{__perl}|' {} +
84
85%build
86%{__perl} Makefile.PL INSTALLDIRS=vendor --default
87# yah.  don't do the network tests
88%{?!_with_network_tests: rm run_network_tests }
89make %{?_smp_mflags}
90
91%install
92rm -rf %{buildroot}
93make pure_install PERL_INSTALL_ROOT=%{buildroot}
94find %{buildroot} -type f -name .packlist -exec rm -f {} +
95find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
96%{_fixperms} %{buildroot}/*
97
98%check
99# enable POD tests
100#export POE_TEST_POD=1
101# note that there are currently a number of tests that throw errors, but do
102# not fail nor cause the build/suite to fail.  For now just please be aware
103# that there will be some noisy output as the tests are run.
104# Reported upstream at http://rt.cpan.org/Public/Bug/Display.html?id=19878
105make test
106
107%files
108%doc CHANGES HISTORY README examples/ TODO t/
109%{perl_vendorlib}/*
110%{_mandir}/man3/*.3*
111
112%changelog
113* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.367-1
114- new upstream release.
115- rebuilt with perl-5.26.
116
117* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.350-2
118- build with Perl 5.16
119
120* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.350-1
121- initial build for Vine Linux
122
123* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.350-2
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
125
126* Wed Dec 21 2011 Petr Šabata <contyk@redhat.com> - 1.350-1
127- 1.350 bump
128- Remove Buildroot and defattr
129
130* Mon Aug 01 2011 Petr Sabata <contyk@redhat.com> - 1.312-1
131- 1.312 bump
132- Deps updated
133
134* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.289-5
135- Perl mass rebuild
136
137* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.289-4
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
139
140* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.289-3
141- 661697 rebuild for fixing problems with vendorach/lib
142
143* Sun Sep 12 2010 Iain Arnell <iarnell@gmail.com> 1.289-2
144- doesn't require POE::Test::Loops (RHBZ#632855)
145
146* Tue Jun  8 2010 Petr Pisar <ppisar@redhat.com> - 1.289-1
147- 1.289 bump
148- Reenable t/90_regression/rt1648-tied-stderr.t test
149
150* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.269-3
151- Mass rebuild with perl-5.12.0
152
153* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.269-2
154- rebuild against perl 5.10.1
155
156* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.269-1
157- update filtering...
158- auto-update to 1.269 (by cpan-spec-update 0.01)
159- added a new br on perl(Module::Build)
160- altered br on perl(POE::Test::Loops) (1.021 => 1.022)
161- altered req on perl(POE::Test::Loops) (1.021 => 1.022)
162
163* Tue Aug 25 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.007-1
164- auto-update to 1.007 (by cpan-spec-update 0.01)
165
166* Tue Aug 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.007-1
167- auto-update to 1.007 (by cpan-spec-update 0.01)
168- altered br on perl(POE::Test::Loops) (1.004 => 1.021)
169- added a new req on perl(Carp) (version 0)
170- added a new req on perl(Errno) (version 1.09)
171- added a new req on perl(Exporter) (version 0)
172- added a new req on perl(File::Spec) (version 0.87)
173- added a new req on perl(IO::Handle) (version 1.27)
174- added a new req on perl(IO::Tty) (version 1.08)
175- added a new req on perl(POE::Test::Loops) (version 1.021)
176- added a new req on perl(POSIX) (version 1.02)
177- added a new req on perl(Socket) (version 1.7)
178- added a new req on perl(Storable) (version 2.16)
179
180* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.006-2
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
182
183* Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.006-1
184- auto-update to 1.006 (by cpan-spec-update 0.01)
185
186* Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-1
187- auto-update to 1.005 (by cpan-spec-update 0.01)
188- added a new br on perl(Storable) (version 2.16)
189- added a new br on perl(Errno) (version 1.09)
190- added a new br on perl(IO::Handle) (version 1.27)
191- added a new br on perl(Socket) (version 1.7)
192- added a new br on perl(IO::Tty) (version 1.08)
193- added a new br on perl(POE::Test::Loops) (version 1.004)
194- added a new br on perl(POSIX) (version 1.02)
195- added a new br on perl(File::Spec) (version 0.87)
196- added a new br on perl(Exporter) (version 0)
197- added a new br on perl(Test::Harness) (version 2.26)
198- added a new br on perl(Carp) (version 0)
199
200* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.003-2
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
202
203* Sun Sep 07 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.003-1
204- update to 1.003
205- filter provides, too
206
207* Mon Jun 16 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.0002-1
208- update to 1.0002
209
210* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.9999-1
211- update to 0.9999
212- don't filter out POE::Kernel, POE::Loop::Tk (it actually is provided)
213
214* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.9989-2
215- rebuild for new perl
216
217* Sat May 19 2007 Chris Weyl <cweyl@alumni.drew.edu>
218- spec cleanups, tweaks
219- add t/ to doc
220- move away from macroized versioning system
221- no rebuild at this point
222
223* Fri Mar 23 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.9989-1
224- update to 0.9989
225
226* Wed Mar 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.9917-1
227- update to 0.9917.  0.3800-1, below, was never built/released to the wild.
228
229* Mon Sep 25 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3800-1
230- update to 0.38.  0.37-1, below, was never built/released to the wild.
231
232* Mon Sep 11 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3700-1
233- update to 0.37
234- samples/ is now examples/
235- add additional br's: perl(IO::Pty), perl(Test::Pod),
236  perl(Test::Pod::Coverage)
237
238* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3601-2
239- bump for mass rebuild
240
241* Sun Aug 13 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3601-1
242- update to cpan ver 0.3601
243
244* Thu Aug 10 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3600-1
245- update to cpan ver 0.36
246
247* Tue Jun 20 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3502-1
248- filter errant provides.  Also translate POE::Provides::foo modules to
249  POE::Provide::foo
250- Bump to latest version released
251
252* Thu Jun 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3501-2
253- Nix test that was causing build to fail in plague
254
255* Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3501-1
256- bump release, minor cleanups per review.
257
258* Fri Jun 09 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.3501-0
259- Initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.