source: projects/specs/trunk/p/perl-POE-Test-Loops/perl-POE-Test-Loops.spec @ 8667

Revision 8667, 4.6 KB checked in by iwaim, 10 years ago (diff)

perl-POE-Test-Loops 1.350-2

Line 
1Name:           perl-POE-Test-Loops
2Summary:        Reusable tests for POE::Loop authors
3Version:        1.350
4Release:        2%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/R/RC/RCAPUTO/POE-Test-Loops-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/POE-Test-Loops
9BuildArch:      noarch
10BuildRequires:  perl(constant)
11BuildRequires:  perl(ExtUtils::MakeMaker)
12BuildRequires:  perl(File::Path)
13BuildRequires:  perl(File::Spec)
14BuildRequires:  perl(File::Temp)
15BuildRequires:  perl(IO::Handle)
16BuildRequires:  perl(IO::Socket)
17BuildRequires:  perl(IO::Socket::INET)
18BuildRequires:  perl(POE)
19BuildRequires:  perl(Socket)
20BuildRequires:  perl(Test::More) >= 0.94
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23%if %{_dist_release} > "vl6"
24%global __provides_exclude %{?__provides_exclude:__requires_exclude|}^perl\\(POE::MySession\\)
25%global __provides_exclude %__provides_exclude|perl\\(POE::Kernel\\)
26%global __provides_exclude %__provides_exclude|perl\\(PoeTestWorker\\)
27%global __provides_exclude %__provides_exclude|perl\\([DIFMOSU].*\\)
28%global __provides_exclude %__provides_exclude|perl\\(Switch\\)
29%endif
30
31%description
32POE::Test::Loops contains one function, generate(), which will generate
33all the loop tests for one or more POE::Loop subclasses. The SYNOPSIS
34example is a version of poe-gen-tests, which is a stand-alone utility
35to generate the actual tests. The poe-gen-tests manual page also documents
36the POE::Test::Loops system in more detail.
37
38%prep
39%setup -q -n POE-Test-Loops-%{version}
40find . -type f -exec chmod -c -x {} ';'
41
42%if %{_dist_release} <= "vl6"
43cat << \EOF > %{name}-prov
44#!/bin/sh
45%{__perl_provides} $* |\
46 sed -e '/perl(POE::MySession)/d' |\
47 sed -e '/perl(POE::Kernel)/d' |\
48 sed -e '/perl(PoeTestWorker)/d' |\
49 sed -e '/perl([DIFMOSU].*)/d' |\
50 sed -e '/perl(Switch)/d'
51EOF
52
53%global __perl_provides %{_builddir}/POE-Test-Loops-%{version}/%{name}-prov
54chmod +x %{__perl_provides}
55%endif
56
57%build
58%{__perl} Makefile.PL INSTALLDIRS=vendor
59make %{?_smp_mflags}
60
61%install
62make pure_install DESTDIR=%{buildroot}
63find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
64find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
65%{_fixperms} %{buildroot}/*
66
67%check
68make test
69
70%files
71%doc CHANGES README
72%{perl_vendorlib}/*
73%{_mandir}/man3/*.3*
74%{_bindir}/poe-gen-tests
75%{_mandir}/man1/poe-gen-tests.1.gz
76
77%changelog
78* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.350-2
79- build with Perl 5.16
80
81* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.350-1
82- initial build for Vine Linux
83
84* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.350-2
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
86
87* Wed Dec 21 2011 Petr Šabata <contyk@redhat.com> - 1.350-1
88- 1.350 bump
89
90* Fri Aug  5 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.312-2
91- filter also Switch from provides, just to be sure
92
93* Wed Jul 27 2011 Petr Sabata <contyk@redhat.com> - 1.312-1
94- 1.312 bump (needed by current POE)
95- Drop Buildroot and defattr support
96- Fix dependencies a bit
97- Add RPM 4.9 style filters
98- Filter POE::Kernel and PoeTestWorker from Provides
99
100* Thu Jun 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.035-4
101- Perl mass rebuild
102
103* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.035-3
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
105
106* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.035-2
107- 661697 rebuild for fixing problems with vendorach/lib
108
109* Mon Jun  7 2010 Petr Pisar <ppisar@redhat.com> - 1.035-1
110- 1.035 bump
111- Orthography fix in description
112
113* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.033-2
114- Mass rebuild with perl-5.12.0
115
116* Sun Mar 14 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.033-1
117- update by Fedora::App::MaintainerTools 0.006
118- PERL_INSTALL_ROOT => DESTDIR
119- updating to latest GA CPAN version (1.033)
120
121* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.022-1
122- update filtering
123- auto-update to 1.022 (by cpan-spec-update 0.01)
124
125* Tue Aug 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.021-1
126- auto-update to 1.021 (by cpan-spec-update 0.01)
127
128* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.005-2
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
130
131* Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-1
132- update for submission
133
134* Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-0
135- initial RPM packaging
136- generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)
Note: See TracBrowser for help on using the repository browser.