source: projects/specs/trunk/p/perl-POE-Test-Loops/perl-POE-Test-Loops.spec @ 12120

Revision 12120, 4.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-POE-Test-Loops
2Summary:        Reusable tests for POE::Loop authors
3Version:        1.360
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/R/RC/RCAPUTO/POE-Test-Loops-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/POE-Test-Loops
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13BuildArch:      noarch
14BuildRequires:  perl(constant)
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(File::Path)
17BuildRequires:  perl(File::Spec)
18BuildRequires:  perl(File::Temp)
19BuildRequires:  perl(IO::Handle)
20BuildRequires:  perl(IO::Socket)
21BuildRequires:  perl(IO::Socket::INET)
22BuildRequires:  perl(POE)
23BuildRequires:  perl(Socket)
24BuildRequires:  perl(Test::More)
25Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
26
27%if %{_dist_release} > "vl6"
28%global __provides_exclude %{?__provides_exclude:__requires_exclude|}^perl\\(POE::MySession\\)
29%global __provides_exclude %__provides_exclude|perl\\(POE::Kernel\\)
30%global __provides_exclude %__provides_exclude|perl\\(PoeTestWorker\\)
31%global __provides_exclude %__provides_exclude|perl\\([DIFMOSU].*\\)
32%global __provides_exclude %__provides_exclude|perl\\(Switch\\)
33%endif
34
35%description
36POE::Test::Loops contains one function, generate(), which will generate
37all the loop tests for one or more POE::Loop subclasses. The SYNOPSIS
38example is a version of poe-gen-tests, which is a stand-alone utility
39to generate the actual tests. The poe-gen-tests manual page also documents
40the POE::Test::Loops system in more detail.
41
42%prep
43%setup -q -n POE-Test-Loops-%{version}
44find . -type f -exec chmod -c -x {} ';'
45
46%if %{_dist_release} <= "vl6"
47cat << \EOF > %{name}-prov
48#!/bin/sh
49%{__perl_provides} $* |\
50 sed -e '/perl(POE::MySession)/d' |\
51 sed -e '/perl(POE::Kernel)/d' |\
52 sed -e '/perl(PoeTestWorker)/d' |\
53 sed -e '/perl([DIFMOSU].*)/d' |\
54 sed -e '/perl(Switch)/d'
55EOF
56
57%global __perl_provides %{_builddir}/POE-Test-Loops-%{version}/%{name}-prov
58chmod +x %{__perl_provides}
59%endif
60
61%build
62%{__perl} Makefile.PL INSTALLDIRS=vendor
63make %{?_smp_mflags}
64
65%install
66make pure_install DESTDIR=%{buildroot}
67find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
68find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
69%{_fixperms} %{buildroot}/*
70
71%check
72make test
73
74%files
75%doc CHANGES README
76%{perl_vendorlib}/*
77%{_mandir}/man3/*.3*
78%{_bindir}/poe-gen-tests
79%{_mandir}/man1/poe-gen-tests.1.gz
80
81%changelog
82* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.360-1
83- new upstream release.
84- rebuilt with perl-5.26.
85
86* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.350-2
87- build with Perl 5.16
88
89* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.350-1
90- initial build for Vine Linux
91
92* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.350-2
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
94
95* Wed Dec 21 2011 Petr Šabata <contyk@redhat.com> - 1.350-1
96- 1.350 bump
97
98* Fri Aug  5 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.312-2
99- filter also Switch from provides, just to be sure
100
101* Wed Jul 27 2011 Petr Sabata <contyk@redhat.com> - 1.312-1
102- 1.312 bump (needed by current POE)
103- Drop Buildroot and defattr support
104- Fix dependencies a bit
105- Add RPM 4.9 style filters
106- Filter POE::Kernel and PoeTestWorker from Provides
107
108* Thu Jun 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.035-4
109- Perl mass rebuild
110
111* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.035-3
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
113
114* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.035-2
115- 661697 rebuild for fixing problems with vendorach/lib
116
117* Mon Jun  7 2010 Petr Pisar <ppisar@redhat.com> - 1.035-1
118- 1.035 bump
119- Orthography fix in description
120
121* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.033-2
122- Mass rebuild with perl-5.12.0
123
124* Sun Mar 14 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.033-1
125- update by Fedora::App::MaintainerTools 0.006
126- PERL_INSTALL_ROOT => DESTDIR
127- updating to latest GA CPAN version (1.033)
128
129* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.022-1
130- update filtering
131- auto-update to 1.022 (by cpan-spec-update 0.01)
132
133* Tue Aug 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.021-1
134- auto-update to 1.021 (by cpan-spec-update 0.01)
135
136* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.005-2
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-1
140- update for submission
141
142* Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-0
143- initial RPM packaging
144- generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)
Note: See TracBrowser for help on using the repository browser.