source: projects/specs/trunk/p/perl-Net-SSLeay/perl-Net-SSLeay-vl.spec @ 5767

Revision 5767, 2.6 KB checked in by yasumichi, 12 years ago (diff)

Initial build for Vine

Line 
1%define pkgname Net-SSLeay
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.42
6Release:        1%{?_dist_release}
7# COPYING  などを参照して License を修正してください。
8License:        Artistic or GPL
9# /usr/share/doc/rpm-4.9.1.2/GROUPS_for_vine.txt を参照して Group を修正してください。
10Group:          Development/Libraries
11Source0:        http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/%{pkgname}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16Packager:       yasumichi
17
18Summary:        Net::SSLeay - Perl extension for using OpenSSL
19Summary(ja):    Net::SSLeay - OpenSSL を利用するための Perl 拡張
20
21# Dependency
22Requires:       perl
23Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
24
25BuildRequires:  perl
26BuildRequires:  openssl-devel
27BuildRequires:  zlib-devel
28
29%description
30This module offers some high level convenience functions for accessing web
31pages on SSL servers (for symmetry, the same API is offered for accessing
32http servers, too), an sslcat() function for writing your own clients, and
33finally access to the SSL api of the SSLeay/OpenSSL package so you can write
34servers or clients for more complicated applications.
35
36%description -l ja
37このモジュールは、SSL サーバー上の web ページに接続するための高レベルで便利
38な関数を提供します。(調和のため、http サーバーに接続するのも同じ API を提供
39します。) あなたのクライアントで sslcat() 関数を使い、SSLay/OpenSSL パッケー
40ジの SSL API にアクセスすることでより複雑なアプリケーションでのためサーバーや
41クライアントを記述することができます。
42
43%prep
44%setup -q -n Net-SSLeay-1.42
45
46%build
47perl Makefile.PL << EOI
48n
49EOI
50%{__make}
51
52%install
53%{__rm} -rf ${RPM_BUILD_ROOT}
54%{__make} install DESTDIR=${RPM_BUILD_ROOT}
55
56find $RPM_BUILD_ROOT%{_prefix} -type f -print |
57        sed "s@^$RPM_BUILD_ROOT@@g" |
58        grep -v ^%{_mandir} |
59        grep -v perllocal.pod |
60        grep -v "\.packlist" > %{name}.files
61
62if [ "$(cat %{name}.files)X" = "X" ] ; then
63        echo "ERROR: EMPTY FILE LIST"
64        exit -1
65fi
66
67# remove unnecessary files.
68%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
69find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
70find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
71
72
73%clean
74%{__rm} -rf ${RPM_BUILD_ROOT}
75
76
77%files -f %{name}.files
78%defattr(-,root,root)
79%doc Changes README TODO
80
81%changelog
82* Sat Feb 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
83- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.