source: projects/specs/trunk/p/perl-Net-SSLeay/perl-Net-SSLeay-vl.spec @ 12120

Revision 12120, 6.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define real_name Net-SSLeay
2
3Summary: Perl module for using OpenSSL via Network
4Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
5Name: perl-Net-SSLeay
6Version: 1.88
7Release: 1%{?_dist_release}
8License: BSDish
9Group: Development/Libraries
10Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
11Source1: COPYRIGHT.SSLeay-0.9.0
12BuildRequires: perl, openssl-devel >= 1.1.1
13BuildRequires: zlib-devel
14Requires: perl, openssl >= 1.1.1
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16Vendor: Project Vine
17Distribution: Vine Linux
18
19Obsoletes: perl-Net_SSLeay < 1.64
20Provides: perl-Net_SSLeay = %{version}-%{release}
21
22%description
23Perl module for using OpenSSL via Network, Net::SSLeay.
24
25%description -l ja
26OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
27
28%prep
29%setup -q -n %{real_name}-%{version}
30cp -p %{SOURCE1} .
31
32# openssl_path is /usr here, therefore don't -I/usr/include and
33# especially don't (badly) hardcode standard library search path
34# /usr/lib
35if [[ "%{_prefix}" = "/usr" ]]; then
36  perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
37fi
38
39%build
40# note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
41perl Makefile.PL %{_prefix} INSTALLDIRS=vendor << EOI
42n
43EOI
44make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
45perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
46
47%install
48rm -rf %{buildroot}
49#mkdir -p %{buildroot}%{perl_archlib}
50#make install PREFIX=%{buildroot}%{_prefix} \
51#       SITEPREFIX=%{buildroot}%{_prefix} \
52#       VENDORPREFIX=%{buildroot}%{_prefix} \
53#       INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
54#       INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
55#       INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
56#       INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
57#       INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
58#       INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
59#       INSTALLBIN=%{buildroot}%{_bindir} \
60#       INSTALLSITEBIN=%{buildroot}%{_bindir} \
61#       INSTALLVENDORBIN=%{buildroot}%{_bindir} \
62#       INSTALLSCRIPT=%{buildroot}%{_bindir} \
63#       INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
64#       INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
65#       INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
66#       INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
67#       INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
68#       INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
69make install DESTDIR=%{buildroot}
70
71sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
72mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
73
74#if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
75#    mv %{buildroot}%{perl_archlib}/perllocal.pod .
76#else
77#    touch perllocal.pod
78#fi
79
80perllocalfile=`find %{buildroot} -name perllocal.pod`
81echo "mv $perllocalfile ."
82mv $perllocalfile .
83
84{
85find %{buildroot}  \
86  -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
87} > %{name}.files
88
89%clean
90rm -rf %{buildroot}
91
92#check
93#make test
94
95%files -f %{name}.files
96%defattr(-,root,root)
97%license COPYRIGHT.SSLeay-0.9.0
98%doc Changes Credits QuickRef README perllocal.pod
99#%dir %{perl_vendorarch}/auto/Net
100#%dir %{perl_vendorarch}/auto/Net/SSLeay
101#%dir %{perl_vendorarch}/Net
102#%dir %{perl_vendorarch}/Net/SSLeay
103
104%changelog
105* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.88-1
106- new upstream release.
107- rebuilt with perl-5.26.
108
109* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.85-1
110- new upstream release.
111
112* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.74-1
113- new upstream release.
114
115* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.64-1
116- new upstream release.
117- renamed from "perl-Net_SSLeay".
118- added "Obsoletes: perl-Net_SSLeay" and "Provides: perl-Net_SSLeay".
119
120* Sun Feb 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
121- new upstream release
122
123* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
124- rebuild with perl-5.12.3
125
126* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
127- new upstream release
128- change BuildRequires: openssl-devel instead of openssl
129- add BuildRequires: zlib-devel
130
131* Wed Jul  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
132- new upstream release
133
134* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
135- spec in utf-8
136
137* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
138- rebuilt with perl-5.10.0
139- applied new versioning policy
140
141* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
142- rebuilt with openssl-0.9.8e
143
144* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
145- updated to 1.30
146
147* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
148- installed files to vendor_perl
149- changed Group to Development/Libraries
150
151* Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
152- build on perl-5.8.6-0vl1
153
154* Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
155- build with perl-5.8.2
156- add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
157
158* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
159- new upstream version
160- built on perl-5.8.1
161
162* Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
163- fixed install man dir, again
164
165* Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
166- fixed install dir of perllocal.pod
167
168* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
169- fixed install man dir
170
171* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
172- comment out "make test"
173
174* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
175- updated to 1.22
176
177* Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
178- updated to 1.13
179- BuildPreReq/Requires: perl, openssl-0.9.6b
180- rewrite a better spec with License/Group
181
182* Mon Jul 16 2001 <sagami@vinelinux.org>
183- 1.07-0vl3: rebuilt with openssl-0.9.6b
184- erase unneeeded files from %%doc
185- use _prefix, not prefix
186
187* Thu Jul 05 2001 <sagami@vinelinux.org>
188- 1.07-0vl2: built with perl-5.6.1
189
190* Thu Jun  7 2001 Yasuhide OMORI <omori@m-t.com>
191- 1.07
192
193* Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
194- first version of rpm.
Note: See TracBrowser for help on using the repository browser.