source: projects/specs/trunk/p/perl-Net-Daemon/perl-Net-Daemon-vl.spec @ 5803

Revision 5803, 3.8 KB checked in by shaolin, 12 years ago (diff)
  • new packages (and a few updates)
Line 
1Name:           perl-Net-Daemon
2Version:        0.48
3Release:        2%{?_dist_release}
4Summary:        Perl extension for portable daemons
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Net-Daemon/
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MN/MNOONING/Net-Daemon/Net-Daemon-0.43.tar.gz
10#upstream report http://rt.cpan.org/Ticket/Display.html?id=39759
11Patch0:         Net-Daemon-only-ithreads.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires:  perl
16# for perldoc
17BuildRequires:  groff
18# Correct for lots of packages, other common choices include eg. Module::Build
19BuildRequires:  perl(ExtUtils::MakeMaker) perl(Pod::Perldoc) perl(Test::Simple)
20Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
21
22Vendor:        Project Vine
23Distribution:  Vine Linux
24
25%description
26Net::Daemon is an abstract base class for implementing portable server
27applications in a very simple way. The module is designed for Perl 5.006 and
28ithreads (and higher), but can work with fork() and Perl 5.004.
29
30The Net::Daemon class offers methods for the most common tasks a daemon
31needs: Starting up, logging, accepting clients, authorization, restricting
32its own environment for security and doing the true work. You only have to
33override those methods that aren't appropriate for you, but typically
34inheriting will safe you a lot of work anyways.
35
36
37%prep
38%setup -q -n Net-Daemon
39%patch0 -p1
40
41# generate our other two licenses...
42perldoc perlgpl > LICENSE.GPL
43perldoc perlartistic > LICENSE.Artistic
44
45
46%build
47%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
48make %{?_smp_mflags}
49
50
51%install
52rm -rf %{buildroot}
53make pure_install PERL_INSTALL_ROOT=%{buildroot}
54find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
55# Remove the next line from noarch packages (unneeded)
56find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
57find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
58chmod -R u+w %{buildroot}/*
59
60
61%check
62%{?!_with_network_tests:
63# Disable tests which will fail under mock
64  rm t/config*
65  rm t/fork*
66  rm t/ithread*
67  rm t/loop*
68  rm t/single.t
69  rm t/unix.t
70}
71
72make test
73
74
75%clean
76rm -rf %{buildroot}
77
78
79%files
80%defattr(-,root,root,-)
81%doc ChangeLog README LICENSE.*
82%{perl_vendorlib}/*
83%{_mandir}/man3/*.3*
84
85
86%changelog
87* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.48-2
88- rebuild; spec revamped
89
90* Fri Mar 25 2011 IWAI, Masaharu <iwai@alib.jp> 0.48-1
91- build for Vine Linux
92- new upstream release
93
94* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-11
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
96
97* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-10
98- 661697 rebuild for fixing problems with vendorach/lib
99
100* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-9
101- Mass rebuild with perl-5.12.0
102
103* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.44-8
104- rebuild against perl 5.10.1
105
106* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-7
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
108
109* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-6
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
111
112* Mon Oct 13 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-5
113- "--with network_tests" - don't remove network tests
114* Mon Oct  6 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-4
115- Description and License fixed
116- Patch without backup
117* Mon Oct  6 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-3
118- Requires: fixed
119* Fri Oct  3 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-2
120- only-ithreads patch added
121- disabled tests which fail under mock
122* Fri Sep 26 2008 Petr Lautrbach <lautrba@redhat.com>
123- initial rpm release
Note: See TracBrowser for help on using the repository browser.