source: projects/specs/trunk/p/perl-Net-Daemon/perl-Net-Daemon-vl.spec @ 12120

Revision 12120, 4.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Net-Daemon
2Version:        0.48
3Release:        4%{?_dist_release}
4Summary:        Perl extension for portable daemons
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Net-Daemon/
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MN/MNOONING/Net-Daemon/Net-Daemon-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11
12BuildArch:      noarch
13BuildRequires:  perl
14# for perldoc
15BuildRequires:  groff
16# Correct for lots of packages, other common choices include eg. Module::Build
17BuildRequires:  perl(ExtUtils::MakeMaker) perl(Pod::Perldoc) perl(Test::Simple)
18Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
19
20Vendor:        Project Vine
21Distribution:  Vine Linux
22
23%description
24Net::Daemon is an abstract base class for implementing portable server
25applications in a very simple way. The module is designed for Perl 5.006 and
26ithreads (and higher), but can work with fork() and Perl 5.004.
27
28The Net::Daemon class offers methods for the most common tasks a daemon
29needs: Starting up, logging, accepting clients, authorization, restricting
30its own environment for security and doing the true work. You only have to
31override those methods that aren't appropriate for you, but typically
32inheriting will safe you a lot of work anyways.
33
34
35%prep
36%setup -q -n Net-Daemon-%{version}
37
38# generate our other two licenses...
39perldoc perlgpl > LICENSE.GPL
40perldoc perlartistic > LICENSE.Artistic
41
42
43%build
44%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
45make %{?_smp_mflags}
46
47
48%install
49rm -rf %{buildroot}
50make pure_install PERL_INSTALL_ROOT=%{buildroot}
51find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
52# Remove the next line from noarch packages (unneeded)
53find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
54find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
55chmod -R u+w %{buildroot}/*
56
57
58%check
59%{?!_with_network_tests:
60# Disable tests which will fail under mock
61  rm t/config*
62  rm t/fork*
63  rm t/ithread*
64  rm t/loop*
65  rm t/single.t
66  rm t/unix.t
67}
68
69make test
70
71
72%clean
73rm -rf %{buildroot}
74
75
76%files
77%defattr(-,root,root,-)
78%license LICENSE.*
79%doc ChangeLog README
80%{perl_vendorlib}/*
81%{_mandir}/man3/*.3*
82
83
84%changelog
85* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48-4
86- rebuilt with perl-5.26.
87- dropped Patch0: fixed in upstream.
88
89* Wed Jun 04 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.48-3
90- build with Perl 5.16
91
92* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.48-2
93- rebuild; spec revamped
94
95* Fri Mar 25 2011 IWAI, Masaharu <iwai@alib.jp> 0.48-1
96- build for Vine Linux
97- new upstream release
98
99* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-11
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
101
102* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-10
103- 661697 rebuild for fixing problems with vendorach/lib
104
105* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-9
106- Mass rebuild with perl-5.12.0
107
108* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.44-8
109- rebuild against perl 5.10.1
110
111* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-7
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
113
114* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-6
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
116
117* Mon Oct 13 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-5
118- "--with network_tests" - don't remove network tests
119* Mon Oct  6 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-4
120- Description and License fixed
121- Patch without backup
122* Mon Oct  6 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-3
123- Requires: fixed
124* Fri Oct  3 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-2
125- only-ithreads patch added
126- disabled tests which fail under mock
127* Fri Sep 26 2008 Petr Lautrbach <lautrba@redhat.com>
128- initial rpm release
Note: See TracBrowser for help on using the repository browser.