source: projects/specs/trunk/p/perl-Net-Daemon/perl-Net-Daemon-vl.spec @ 3106

Revision 3106, 3.5 KB checked in by iwaim, 13 years ago (diff)

new: perl-Net-Daemon (Fedora)

Line 
1Name:           perl-Net-Daemon
2Version:        0.44
3Release:        11%{?dist}
4Summary:        Perl extension for portable daemons
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Net-Daemon/
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MN/MNOONING/Net-Daemon/Net-Daemon-0.43.tar.gz
10#upstream report http://rt.cpan.org/Ticket/Display.html?id=39759
11Patch0:         Net-Daemon-only-ithreads.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildArch:      noarch
15# Correct for lots of packages, other common choices include eg. Module::Build
16BuildRequires:  perl(ExtUtils::MakeMaker)
17Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18
19%description
20Net::Daemon is an abstract base class for implementing portable server
21applications in a very simple way. The module is designed for Perl 5.006 and
22ithreads (and higher), but can work with fork() and Perl 5.004.
23
24The Net::Daemon class offers methods for the most common tasks a daemon
25needs: Starting up, logging, accepting clients, authorization, restricting
26its own environment for security and doing the true work. You only have to
27override those methods that aren't appropriate for you, but typically
28inheriting will safe you a lot of work anyways.
29
30
31%prep
32%setup -q -n Net-Daemon
33%patch0 -p1
34
35# generate our other two licenses...
36perldoc perlgpl > LICENSE.GPL
37perldoc perlartistic > LICENSE.Artistic
38
39
40%build
41%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
42make %{?_smp_mflags}
43
44
45%install
46rm -rf $RPM_BUILD_ROOT
47make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
48find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
49# Remove the next line from noarch packages (unneeded)
50find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
51find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
52chmod -R u+w $RPM_BUILD_ROOT/*
53
54
55%check
56%{?!_with_network_tests:
57# Disable tests which will fail under mock
58  rm t/config*
59  rm t/fork*
60  rm t/ithread*
61  rm t/loop*
62  rm t/single.t
63  rm t/unix.t
64}
65
66make test
67
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72
73%files
74%defattr(-,root,root,-)
75%doc ChangeLog README LICENSE.*
76%{perl_vendorlib}/*
77%{_mandir}/man3/*.3*
78
79
80%changelog
81* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-11
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
83
84* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-10
85- 661697 rebuild for fixing problems with vendorach/lib
86
87* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.44-9
88- Mass rebuild with perl-5.12.0
89
90* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.44-8
91- rebuild against perl 5.10.1
92
93* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-7
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
95
96* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-6
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
98
99* Mon Oct 13 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-5
100- "--with network_tests" - don't remove network tests
101* Mon Oct  6 2008 Petr Lautrbach <plautrba@redhat.com> 0.44-4
102- Description and License fixed
103- Patch without backup
104* Mon Oct  6 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-3
105- Requires: fixed
106* Fri Oct  3 2008 Petr Lautrbach <lautrba@redhat.com> 0.44-2
107- only-ithreads patch added
108- disabled tests which fail under mock
109* Fri Sep 26 2008 Petr Lautrbach <lautrba@redhat.com>
110- initial rpm release
Note: See TracBrowser for help on using the repository browser.