source: projects/specs/trunk/p/perl-Module-Build-Tiny/perl-Module-Build-Tiny-vl.spec @ 12120

Revision 12120, 8.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Summary:        A tiny replacement for Module::Build
2Name:           perl-Module-Build-Tiny
3Version:        0.039
4Release:        13%{?_dist_release}
5License:        GPL+ or Artistic
6URL:            https://github.com/Leont/module-build-tiny
7Source0:        http://cpan.metacpan.org/authors/id/L/LE/LEONT/Module-Build-Tiny-%{version}.tar.gz
8
9Vendor:        Project Vine
10Distribution:  Vine Linux
11
12BuildArch:      noarch
13# Module Build
14BuildRequires:  perl >= 2:5.26.2
15# Module
16BuildRequires:  perl(CPAN::Meta)
17BuildRequires:  perl(DynaLoader)
18BuildRequires:  perl(Exporter)
19BuildRequires:  perl(ExtUtils::CBuilder)
20BuildRequires:  perl(ExtUtils::Config)
21BuildRequires:  perl(ExtUtils::Helpers)
22BuildRequires:  perl(ExtUtils::Install)
23BuildRequires:  perl(ExtUtils::InstallPaths)
24BuildRequires:  perl(ExtUtils::ParseXS)
25BuildRequires:  perl(File::Path)
26BuildRequires:  perl(File::Spec::Functions)
27BuildRequires:  perl(Getopt::Long)
28BuildRequires:  perl(JSON::PP)
29BuildRequires:  perl(Pod::Man)
30BuildRequires:  perl(TAP::Harness::Env)
31# Test
32BuildRequires:  perl(blib)
33BuildRequires:  perl(Carp)
34BuildRequires:  perl(Cwd)
35BuildRequires:  perl(Data::Dumper)
36BuildRequires:  perl(File::ShareDir)
37BuildRequires:  perl(File::Spec)
38BuildRequires:  perl(File::Temp)
39BuildRequires:  perl(IO::File)
40BuildRequires:  perl(IO::Handle)
41BuildRequires:  perl(IPC::Open2)
42BuildRequires:  perl(IPC::Open3)
43BuildRequires:  perl(Test::More)
44BuildRequires:  perl(Test::Pod)
45BuildRequires:  perl(XSLoader)
46# Runtime
47Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
48Requires:       perl(DynaLoader)
49Requires:       perl(ExtUtils::CBuilder)
50Requires:       perl(ExtUtils::ParseXS)
51Requires:       perl(Pod::Man)
52Requires:       perl(TAP::Harness::Env)
53
54%description
55Many Perl distributions use a Build.PL file instead of a Makefile.PL file to
56drive distribution configuration, build, test and installation. Traditionally,
57Build.PL uses Module::Build as the underlying build system. This module
58provides a simple, lightweight, drop-in replacement.
59
60Whereas Module::Build has over 6,700 lines of code; this module has less than
6170, yet supports the features needed by most pure-Perl distributions.
62
63%prep
64%setup -q -n Module-Build-Tiny-%{version}
65
66%build
67perl Build.PL --installdirs=vendor
68./Build
69
70%install
71./Build install --destdir=%{buildroot} --create_packlist=0
72
73%check
74AUTHOR_TESTING=1 RELEASE_TESTING=1 ./Build test
75
76%files
77%license LICENSE
78%doc Changes README Todo
79%{perl_vendorlib}/Module/
80%{_mandir}/man3/Module::Build::Tiny.3pm*
81
82%changelog
83* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.039-13
84- initial build for Vine Linux.
85
86* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.039-12
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
88
89* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.039-11
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
91
92* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.039-10
93- Perl 5.28 rebuild
94
95* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.039-9
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
97
98* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.039-8
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
100
101* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.039-7
102- Perl 5.26 rebuild
103
104* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.039-6
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
106
107* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.039-5
108- Perl 5.24 rebuild
109
110* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.039-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
112
113* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.039-3
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
115
116* Fri Jun 05 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.039-2
117- Perl 5.22 rebuild
118
119* Mon Oct 13 2014 Paul Howarth <paul@city-fan.org> - 0.039-1
120- Update to 0.039
121  - Supply basename to *.PL files as its args
122
123* Mon Sep 22 2014 Paul Howarth <paul@city-fan.org> - 0.038-1
124- Update to 0.038
125  - Scrub PERL_MB_OPT in tests too
126
127* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.037-2
128- Perl 5.20 rebuild
129
130* Mon Jul 28 2014 Paul Howarth <paul@city-fan.org> - 0.037-1
131- Update to 0.037
132  - Scrub environment variable in tests
133- Use %%license
134
135* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.036-2
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
137
138* Fri May  2 2014 Paul Howarth <paul@city-fan.org> - 0.036-1
139- Update to 0.036
140  - Add --jobs argument to MBT
141  - Add xs directory to include list
142
143* Tue Feb 18 2014 Paul Howarth <paul@city-fan.org> - 0.035-1
144- Update to 0.035
145  - Fix install test in absence of a compiler
146
147* Wed Jan 22 2014 Paul Howarth <paul@city-fan.org> - 0.034-1
148- Update to 0.034
149  - Make install tests more platform independent
150
151* Tue Jan 21 2014 Paul Howarth <paul@city-fan.org> - 0.033-1
152- Update to 0.033
153  - Require Getopt::Long 2.36
154  - Add install tests
155
156* Mon Jan 20 2014 Paul Howarth <paul@city-fan.org> - 0.032-1
157- Update to 0.032
158  - Process argument sources separately
159  - Use mod2fname appropriately
160- BR:/R: perl(DynaLoader)
161- BR: perl(GetOpt::Long) ≥ 2.36 for GetOptionsFromArray
162- Drop dependencies on TAP::Harness as we only use TAP::Harness::Env
163
164* Fri Oct 11 2013 Paul Howarth <paul@city-fan.org> - 0.030-1
165- Update to 0.030
166  - Respect harness environmental variables
167  - Add main dir to include path
168  - 'include_dirs' must be a list ref, not just a string (CPAN RT#54606)
169- BR:/R: perl(TAP::Harness) ≥ 3.29
170
171* Mon Sep 30 2013 Paul Howarth <paul@city-fan.org> - 0.028-1
172- Update to 0.028
173  - Revert "Removed clean and realclean actions"
174  - Build .c and .o in temp/ instead of lib
175  - Got rid of IO layers
176  - Separate libdoc and bindoc checks
177
178* Mon Sep  9 2013 Paul Howarth <paul@city-fan.org> - 0.027-1
179- Update to 0.027
180  - Various documentation updates
181
182* Tue Aug 20 2013 Paul Howarth <paul@city-fan.org> - 0.026-1
183- Update to 0.026
184  - Safe PERL_MB_OPT during configuration stage
185
186* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.025-3
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
188
189* Wed Jul 24 2013 Petr Pisar <ppisar@redhat.com> - 0.025-2
190- Perl 5.18 rebuild
191
192* Fri Jul 12 2013 Paul Howarth <paul@city-fan.org> - 0.025-1
193- Update to 0.025
194  - Use local tempdir
195
196* Sun Jun 30 2013 Paul Howarth <paul@city-fan.org> - 0.024-1
197- Update to 0.024
198  - Generate man pages in the correct section
199
200* Wed Jun 12 2013 Paul Howarth <paul@city-fan.org> - 0.023-1
201- Update to 0.023
202  - Implement --pureperl-only
203  - Skip compilation test when not having a compiler
204
205* Sat Jun  1 2013 Paul Howarth <paul@city-fan.org> - 0.022-1
206- Update to 0.022
207  - Fix dirname code for toplevel XS modules
208
209* Mon May 27 2013 Paul Howarth <paul@city-fan.org> - 0.021-1
210- Update to 0.021
211  - Add XS support
212  - Only manify if really installable
213- BR:/R: perl(ExtUtils::CBuilder) and perl(ExtUtils::ParseXS)
214- BR: perl(XSLoader) for the test suite
215
216* Mon May 20 2013 Paul Howarth <paul@city-fan.org> - 0.020-1
217- Update to 0.020
218  - Accept a --create_packlist argument
219
220* Tue Apr 30 2013 Paul Howarth <paul@city-fan.org> - 0.019-1
221- Update to 0.019
222  - Accept --pureperl-only
223- Bump perl(ExtUtils::Helpers) version requirement to 0.020
224
225* Thu Apr 25 2013 Paul Howarth <paul@city-fan.org> - 0.018-1
226- Update to 0.018
227  - Lazily load Pod::Man and TAP::Harness
228  - Don't manify unless necessary
229- Bump perl(ExtUtils::Helpers) version requirement to 0.019
230- Explicitly require perl(Pod::Man) and perl(TAP::Harness) ≥ 3.0
231
232* Tue Apr 23 2013 Paul Howarth <paul@city-fan.org> - 0.017-2
233- Updates following package review (#947455)
234  - BR: perl(ExtUtils::Config) for module
235  - BR: perl(File::ShareDir) for test suite
236  - Drop BR: perl(File::Basename) and perl(File::Find), not dual-lived
237
238* Mon Apr 15 2013 Paul Howarth <paul@city-fan.org> - 0.017-1
239- Update to 0.017
240  - Switched back from JSON to JSON::PP
241  - Remove dependency on File::Find::Rule
242  - Switched back to ExtUtils::Helpers for detildefy
243  - Drop .modulebuildrc support per Lancaster consensus
244  - Fix loading of File::Find
245  - Fix redefined warning for find
246- Drop BR: perl(ExtUtils::BuildRC), perl(File::Find::Rule), perl(File::HomeDir),
247  perl(File::pushd)
248- BR: perl(JSON::PP) rather than perl(JSON), and perl(Pod::Man)
249- Bump perl(ExtUtils::Helpers) version requirement to 0.017 to avoid the need
250  for a workaround for misplaced manpage
251
252* Thu Apr  4 2013 Paul Howarth <paul@city-fan.org> - 0.014-1
253- Update to 0.014
254  - Added sharedir support
255  - Fixed Synopsis
256  - Make blib/arch, to satisfy blib.pm
257  - Removed dependencies on Test::Exception, Capture::Tiny and File::Slurp
258
259* Mon Apr  1 2013 Paul Howarth <paul@city-fan.org> - 0.013-2
260- Sanitize for Fedora submission
261
262* Mon Apr  1 2013 Paul Howarth <paul@city-fan.org> - 0.013-1
263- Initial RPM version
Note: See TracBrowser for help on using the repository browser.