source: projects/specs/trunk/p/perl-Heap/perl-Heap-vl.spec @ 8684

Revision 8684, 3.1 KB checked in by iwaim, 10 years ago (diff)

perl-Heap 0.80-2

Line 
1Name:           perl-Heap
2Version:        0.80
3Release:        2%{?_dist_release}
4Summary:        Perl extension for keeping data partially sorted
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Heap
9Source0:        http://search.cpan.org/CPAN/authors/id/J/JM/JMM/Heap-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildArch:      noarch
13BuildRequires:  perl(ExtUtils::MakeMaker) perl(Test::More)
14Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
15
16%description
17The Heap collection of modules provide routines that manage a heap of
18elements. A heap is a partially sorted structure that is always able to
19easily extract the smallest of the elements in the structure (or the
20largest if a reversed compare routine is provided).
21
22If the collection of elements is changing dynamically, the heap has less
23overhead than keeping the collection fully sorted.
24
25The elements must be objects as described in "Heap::Elem" and all
26elements inserted into one heap must be mutually compatible - either
27the same class exactly or else classes that differ only in ways unrelated
28to the Heap::Elem interface.
29
30%prep
31%setup -q -n Heap-%{version}
32
33
34%build
35%{__perl} Makefile.PL INSTALLDIRS=vendor
36make %{?_smp_mflags}
37
38
39%install
40rm -rf %{buildroot}
41make pure_install PERL_INSTALL_ROOT=%{buildroot}
42find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
43find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
44chmod -R u+w %{buildroot}/*
45
46
47%check
48make test
49
50
51%clean
52rm -rf %{buildroot}
53
54
55%files
56%defattr(-,root,root,-)
57%doc Changes README
58%{perl_vendorlib}/*
59%{_mandir}/man3/*.3*
60
61
62%changelog
63* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.80-2
64- build with Perl 5.16
65
66* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.80-1
67- initial build for Vine Linux
68
69* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-10
70- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
71
72* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.80-9
73- Perl mass rebuild
74
75* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-8
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
77
78* Fri Dec 17 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.80-7
79- 661697 rebuild for fixing problems with vendorach/lib
80
81* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.80-6
82- Mass rebuild with perl-5.12.0
83
84* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.80-5
85- rebuild against perl 5.10.1
86
87* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-4
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
89
90* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-3
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
92
93* Fri Feb  8 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.80-2
94- rebuild for new perl
95
96* Wed Aug  8 2007 Patrice Dumas <pertusus@free.fr> 0.80-1
97- update to 0.80
98
99* Tue Jul 18 2006 Patrice Dumas <pertusus@free.fr> 0.71-2
100- Initial packaging
Note: See TracBrowser for help on using the repository browser.