source: projects/specs/trunk/p/perl-Heap/perl-Heap-vl.spec @ 12120

Revision 12120, 3.3 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Heap
2Version:        0.80
3Release:        3%{?_dist_release}
4Summary:        Perl extension for keeping data partially sorted
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Heap
9Source0:        http://search.cpan.org/CPAN/authors/id/J/JM/JMM/Heap-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15BuildArch:      noarch
16BuildRequires:  perl(ExtUtils::MakeMaker) perl(Test::More)
17Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18
19%description
20The Heap collection of modules provide routines that manage a heap of
21elements. A heap is a partially sorted structure that is always able to
22easily extract the smallest of the elements in the structure (or the
23largest if a reversed compare routine is provided).
24
25If the collection of elements is changing dynamically, the heap has less
26overhead than keeping the collection fully sorted.
27
28The elements must be objects as described in "Heap::Elem" and all
29elements inserted into one heap must be mutually compatible - either
30the same class exactly or else classes that differ only in ways unrelated
31to the Heap::Elem interface.
32
33%prep
34%setup -q -n Heap-%{version}
35
36
37%build
38%{__perl} Makefile.PL INSTALLDIRS=vendor
39make %{?_smp_mflags}
40
41
42%install
43rm -rf %{buildroot}
44make pure_install PERL_INSTALL_ROOT=%{buildroot}
45find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
46find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
47chmod -R u+w %{buildroot}/*
48
49
50%check
51make test
52
53
54%clean
55rm -rf %{buildroot}
56
57
58%files
59%defattr(-,root,root,-)
60%doc Changes README
61%{perl_vendorlib}/*
62%{_mandir}/man3/*.3*
63
64
65%changelog
66* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.80-3
67- rebuilt with perl-5.26.
68
69* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.80-2
70- build with Perl 5.16
71
72* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.80-1
73- initial build for Vine Linux
74
75* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-10
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
77
78* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.80-9
79- Perl mass rebuild
80
81* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-8
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
83
84* Fri Dec 17 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.80-7
85- 661697 rebuild for fixing problems with vendorach/lib
86
87* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.80-6
88- Mass rebuild with perl-5.12.0
89
90* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.80-5
91- rebuild against perl 5.10.1
92
93* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-4
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
95
96* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.80-3
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
98
99* Fri Feb  8 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.80-2
100- rebuild for new perl
101
102* Wed Aug  8 2007 Patrice Dumas <pertusus@free.fr> 0.80-1
103- update to 0.80
104
105* Tue Jul 18 2006 Patrice Dumas <pertusus@free.fr> 0.71-2
106- Initial packaging
Note: See TracBrowser for help on using the repository browser.