source: projects/specs/trunk/p/perl-HTML-Parser/perl-HTML-Parser-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name perl-HTML-Parser
2%define real_name HTML-Parser
3%define __find_provides /usr/lib/rpm/find-provides.perl
4%define __find_requires /usr/lib/rpm/find-requires.perl
5
6%define rel 2
7
8Summary: A Perl module for parsing HTML.
9Name: %{name}
10Version: 3.56
11Release: %{rel}%{?_dist_release}
12License: GPL or Artistic
13Group: Development/Libraries
14Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
15Url: http://search.cpan.org/~gaas/HTML-Parser/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Requires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
18BuildRequires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
19
20%description
21The HTML-Parser module for perl to parse and extract information from
22HTML documents, including the HTML::Entities, HTML::HeadParser,
23HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
24
25%prep
26%setup -q -n %{real_name}-%{version}
27
28%build
29CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
30make
31
32%install
33rm -rf $RPM_BUILD_ROOT
34# make install
35make DESTDIR=$RPM_BUILD_ROOT install
36
37[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
38
39find $RPM_BUILD_ROOT/usr -type f -print |
40        sed "s@^$RPM_BUILD_ROOT@@g" |
41        grep -v perllocal.pod |
42        grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
43if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
44    echo "ERROR: EMPTY FILE LIST"
45    exit -1
46fi
47
48%check
49make test
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files -f perl-HTML-Parser-%{version}-filelist
55%defattr(-,root,root)
56%dir %{perl_vendorarch}/HTML
57%dir %{perl_vendorarch}/auto/HTML
58
59%changelog
60* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
61- build on perl-5.10.0-1vl5
62
63* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com>  3.56-0vl1
64- new upstream release
65- changed Group to Development/Libraries
66
67* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp>  3.41-0vl1
68- new upstream release
69- build on perl-5.8.6-0vl1
70- fix typo changelog: 3.34-0vl1 and 3.34-0vl2
71- update Url value
72- using perl_sitearch macro
73
74* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
75- built on perl-5.8.2
76
77* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
78- new upstream version
79- built on perl-5.8.1
80
81* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
82- New upstream version
83- build on perl-5.8.0
84        -- changed Requires, Buildrequires
85 
86* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
87- 3.26-14vl2
88- Fix Requires, Buildrequires
89
90* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
91- 3.26-14vl1
92- first build for Vine Linux
93- add define __find_provides / __find_requires
94- modefy files list (dir)
95
96* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
97- automated release bump and build
98
99* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
100- properly claim directories owned by package so they are removed when package is removed
101
102* Mon Jun  3 2002 Chip Turner <cturner@redhat.com>
103- fix for Makefile.PL sometimes prompting for input
104
105* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
106- update to 3.26, move to vendor_perl
107
108* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
109- automated rebuild
110
111* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
112- imported from mandrake. tweaked man path.
113
114* Tue Jul 03 2001 FraníÐis Pons <fpons@mandrakesoft.com> 3.25-1mdk
115- 3.25.
116
117* Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
118- Fixed distribution tag.
119- Updated Requires.
120- Added an option to %makeinstall.
121
122* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
123- Rebuild against the latest perl.
124
125* Tue Feb 27 2001 FraníÐis Pons <fpons@mandrakesoft.com> 3.18-1mdk
126- 3.18.
127
128* Tue Jan 30 2001 FraníÐis Pons <fpons@mandrakesoft.com> 3.15-1mdk
129- 3.15.
130
131* Tue Dec 05 2000 FraníÐis Pons <fpons@mandrakesoft.com> 3.14-1mdk
132- 3.14.
133
134* Thu Oct 12 2000 FraníÐis Pons <fpons@mandrakesoft.com> 3.13-1mdk
135- 3.13.
136
137* Tue Aug 29 2000 FraníÐis Pons <fpons@mandrakesoft.com> 3.11-1mdk
138- 3.11.
139
140* Thu Aug 03 2000 FraníÐis Pons <fpons@mandrakesoft.com> 3.10-2mdk
141- macroszifications.
142- add doc.
143
144* Tue Jul 18 2000 FraníÐis Pons <fpons@mandrakesoft.com> 3.10-1mdk
145- removed perllocal.pod from files.
146- 3.10.
147
148* Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
149- update to 3.08
150
151* Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
152- Fix build for i486
153- Use %%{_tmppath} for BuildRoot
154
155* Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
156- rebuild, new group, cleanup
157
158* Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
159- upgrade to 3.05
160
161* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
162- final cleanup for Mandrake 7
163
164* Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
165-updated to 3.02
166
167* Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
168- bzip2'd sources
169- updated to 2.23
170
171* Tue May 11 1999 root <root@alien.devel.redhat.com>
172- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.