source: projects/specs/trunk/p/perl-HTML-Parser/perl-HTML-Parser-vl.spec @ 12120

Revision 12120, 6.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define name perl-HTML-Parser
2%define real_name HTML-Parser
3%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
4%define __find_provides /usr/lib/rpm/find-provides.perl
5%define __find_requires /usr/lib/rpm/find-requires.perl
6%endif
7
8%define rel 1
9
10Summary: A Perl module for parsing HTML.
11Summary(ja): HTML を解析するための Perl モジュール
12Name: %{name}
13Version: 3.72
14Release: %{rel}%{?_dist_release}
15License: GPL or Artistic
16Group: Development/Libraries
17Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
18Url: http://search.cpan.org/~gaas/HTML-Parser/
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl >= 5.26.0, perl-HTML-Tagset >= 3.03
21BuildRequires: perl >= 5.26.0, perl-HTML-Tagset >= 3.03
22Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28The HTML-Parser module for perl to parse and extract information from
29HTML documents, including the HTML::Entities, HTML::HeadParser,
30HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
31
32%prep
33%setup -q -n %{real_name}-%{version}
34
35%build
36CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41# make install
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT/usr -type f -print |
47        sed "s@^$RPM_BUILD_ROOT@@g" |
48        grep -v perllocal.pod |
49        grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
50if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
51    echo "ERROR: EMPTY FILE LIST"
52    exit -1
53fi
54
55find $RPM_BUILD_ROOT/usr -type f -print | \
56        grep -e perllocal.pod -e "\.packlist" | xargs rm
57
58%check
59make test
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files -f perl-HTML-Parser-%{version}-filelist
65%defattr(-,root,root)
66%dir %{perl_vendorarch}/HTML
67%dir %{perl_vendorarch}/auto/HTML
68%dir %{perl_vendorarch}/auto/HTML/Parser
69
70%changelog
71* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.72-1
72- new upstream release.
73- rebuilt with perl-5.26.
74
75* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 3.68-3
76- build with Perl 5.16
77
78* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-2
79- add directory in files
80
81* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-1
82- new upstream release
83- add Requires: perl(:MODULE_COMPAT_...)
84- defined __find_{provides,requires} with vl4 and vl5 (updated 3.64-2)
85- add Vendor and Distribution tags
86
87* Tue Apr 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.64-2
88- undefine __find_provides and __find_requires at VineSeed
89- added Japanese summary
90
91* Sun Nov  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.64-1
92- new upstream release with security fix (CVE-2009-3627)
93
94* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
95- build on perl-5.10.0-1vl5
96
97* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com>  3.56-0vl1
98- new upstream release
99- changed Group to Development/Libraries
100
101* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp>  3.41-0vl1
102- new upstream release
103- build on perl-5.8.6-0vl1
104- fix typo changelog: 3.34-0vl1 and 3.34-0vl2
105- update Url value
106- using perl_sitearch macro
107
108* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
109- built on perl-5.8.2
110
111* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
112- new upstream version
113- built on perl-5.8.1
114
115* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
116- New upstream version
117- build on perl-5.8.0
118        -- changed Requires, Buildrequires
119 
120* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
121- 3.26-14vl2
122- Fix Requires, Buildrequires
123
124* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
125- 3.26-14vl1
126- first build for Vine Linux
127- add define __find_provides / __find_requires
128- modefy files list (dir)
129
130* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
131- automated release bump and build
132
133* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
134- properly claim directories owned by package so they are removed when package is removed
135
136* Mon Jun  3 2002 Chip Turner <cturner@redhat.com>
137- fix for Makefile.PL sometimes prompting for input
138
139* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
140- update to 3.26, move to vendor_perl
141
142* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
143- automated rebuild
144
145* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
146- imported from mandrake. tweaked man path.
147
148* Tue Jul 03 2001 Fran輟is Pons <fpons@mandrakesoft.com> 3.25-1mdk
149- 3.25.
150
151* Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
152- Fixed distribution tag.
153- Updated Requires.
154- Added an option to %makeinstall.
155
156* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
157- Rebuild against the latest perl.
158
159* Tue Feb 27 2001 François Pons <fpons@mandrakesoft.com> 3.18-1mdk
160- 3.18.
161
162* Tue Jan 30 2001 François Pons <fpons@mandrakesoft.com> 3.15-1mdk
163- 3.15.
164
165* Tue Dec 05 2000 François Pons <fpons@mandrakesoft.com> 3.14-1mdk
166- 3.14.
167
168* Thu Oct 12 2000 François Pons <fpons@mandrakesoft.com> 3.13-1mdk
169- 3.13.
170
171* Tue Aug 29 2000 François Pons <fpons@mandrakesoft.com> 3.11-1mdk
172- 3.11.
173
174* Thu Aug 03 2000 François Pons <fpons@mandrakesoft.com> 3.10-2mdk
175- macroszifications.
176- add doc.
177
178* Tue Jul 18 2000 François Pons <fpons@mandrakesoft.com> 3.10-1mdk
179- removed perllocal.pod from files.
180- 3.10.
181
182* Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
183- update to 3.08
184
185* Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
186- Fix build for i486
187- Use %%{_tmppath} for BuildRoot
188
189* Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
190- rebuild, new group, cleanup
191
192* Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
193- upgrade to 3.05
194
195* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
196- final cleanup for Mandrake 7
197
198* Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
199-updated to 3.02
200
201* Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
202- bzip2'd sources
203- updated to 2.23
204
205* Tue May 11 1999 root <root@alien.devel.redhat.com>
206- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.