source: projects/specs/trunk/p/perl-HTML-Parser/perl-HTML-Parser-vl.spec @ 821

Revision 821, 5.2 KB checked in by inagaki, 14 years ago (diff)

updated: perl-Tk, perl-HTML-Parser

Line 
1%define name perl-HTML-Parser
2%define real_name HTML-Parser
3%if %{?_dist_release} != "vl6"
4%define __find_provides /usr/lib/rpm/find-provides.perl
5%define __find_requires /usr/lib/rpm/find-requires.perl
6%endif
7
8%define rel 2
9
10Summary: A Perl module for parsing HTML.
11Summary(ja): HTML を解析するための Perl モジュール
12Name: %{name}
13Version: 3.64
14Release: %{rel}%{?_dist_release}
15License: GPL or Artistic
16Group: Development/Libraries
17Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
18Url: http://search.cpan.org/~gaas/HTML-Parser/
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
21BuildRequires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
22
23%description
24The HTML-Parser module for perl to parse and extract information from
25HTML documents, including the HTML::Entities, HTML::HeadParser,
26HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
27
28%prep
29%setup -q -n %{real_name}-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
33make
34
35%install
36rm -rf $RPM_BUILD_ROOT
37# make install
38make DESTDIR=$RPM_BUILD_ROOT install
39
40[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
41
42find $RPM_BUILD_ROOT/usr -type f -print |
43        sed "s@^$RPM_BUILD_ROOT@@g" |
44        grep -v perllocal.pod |
45        grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
46if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51%check
52make test
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files -f perl-HTML-Parser-%{version}-filelist
58%defattr(-,root,root)
59%dir %{perl_vendorarch}/HTML
60%dir %{perl_vendorarch}/auto/HTML
61
62%changelog
63* Tue Apr 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.64-2
64- undefine __find_provides and __find_requires at VineSeed
65- added Japanese summary
66
67* Sun Nov  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.64-1
68- new upstream release with security fix (CVE-2009-3627)
69
70* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
71- build on perl-5.10.0-1vl5
72
73* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com>  3.56-0vl1
74- new upstream release
75- changed Group to Development/Libraries
76
77* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp>  3.41-0vl1
78- new upstream release
79- build on perl-5.8.6-0vl1
80- fix typo changelog: 3.34-0vl1 and 3.34-0vl2
81- update Url value
82- using perl_sitearch macro
83
84* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
85- built on perl-5.8.2
86
87* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
88- new upstream version
89- built on perl-5.8.1
90
91* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
92- New upstream version
93- build on perl-5.8.0
94        -- changed Requires, Buildrequires
95 
96* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
97- 3.26-14vl2
98- Fix Requires, Buildrequires
99
100* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
101- 3.26-14vl1
102- first build for Vine Linux
103- add define __find_provides / __find_requires
104- modefy files list (dir)
105
106* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
107- automated release bump and build
108
109* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
110- properly claim directories owned by package so they are removed when package is removed
111
112* Mon Jun  3 2002 Chip Turner <cturner@redhat.com>
113- fix for Makefile.PL sometimes prompting for input
114
115* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
116- update to 3.26, move to vendor_perl
117
118* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
119- automated rebuild
120
121* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
122- imported from mandrake. tweaked man path.
123
124* Tue Jul 03 2001 Fran輟is Pons <fpons@mandrakesoft.com> 3.25-1mdk
125- 3.25.
126
127* Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
128- Fixed distribution tag.
129- Updated Requires.
130- Added an option to %makeinstall.
131
132* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
133- Rebuild against the latest perl.
134
135* Tue Feb 27 2001 François Pons <fpons@mandrakesoft.com> 3.18-1mdk
136- 3.18.
137
138* Tue Jan 30 2001 François Pons <fpons@mandrakesoft.com> 3.15-1mdk
139- 3.15.
140
141* Tue Dec 05 2000 François Pons <fpons@mandrakesoft.com> 3.14-1mdk
142- 3.14.
143
144* Thu Oct 12 2000 François Pons <fpons@mandrakesoft.com> 3.13-1mdk
145- 3.13.
146
147* Tue Aug 29 2000 François Pons <fpons@mandrakesoft.com> 3.11-1mdk
148- 3.11.
149
150* Thu Aug 03 2000 François Pons <fpons@mandrakesoft.com> 3.10-2mdk
151- macroszifications.
152- add doc.
153
154* Tue Jul 18 2000 François Pons <fpons@mandrakesoft.com> 3.10-1mdk
155- removed perllocal.pod from files.
156- 3.10.
157
158* Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
159- update to 3.08
160
161* Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
162- Fix build for i486
163- Use %%{_tmppath} for BuildRoot
164
165* Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
166- rebuild, new group, cleanup
167
168* Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
169- upgrade to 3.05
170
171* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
172- final cleanup for Mandrake 7
173
174* Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
175-updated to 3.02
176
177* Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
178- bzip2'd sources
179- updated to 2.23
180
181* Tue May 11 1999 root <root@alien.devel.redhat.com>
182- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.