source: projects/specs/trunk/p/perl-HTML-Parser/perl-HTML-Parser-vl.spec @ 3124

Revision 3124, 5.6 KB checked in by iwaim, 13 years ago (diff)

perl-HTML-Parser-3.68-1

Line 
1%define name perl-HTML-Parser
2%define real_name HTML-Parser
3%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
4%define __find_provides /usr/lib/rpm/find-provides.perl
5%define __find_requires /usr/lib/rpm/find-requires.perl
6%endif
7
8%define rel 1
9
10Summary: A Perl module for parsing HTML.
11Summary(ja): HTML を解析するための Perl モジュール
12Name: %{name}
13Version: 3.68
14Release: %{rel}%{?_dist_release}
15License: GPL or Artistic
16Group: Development/Libraries
17Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
18Url: http://search.cpan.org/~gaas/HTML-Parser/
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
21BuildRequires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
22Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28The HTML-Parser module for perl to parse and extract information from
29HTML documents, including the HTML::Entities, HTML::HeadParser,
30HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
31
32%prep
33%setup -q -n %{real_name}-%{version}
34
35%build
36CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41# make install
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT/usr -type f -print |
47        sed "s@^$RPM_BUILD_ROOT@@g" |
48        grep -v perllocal.pod |
49        grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
50if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
51    echo "ERROR: EMPTY FILE LIST"
52    exit -1
53fi
54
55%check
56make test
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files -f perl-HTML-Parser-%{version}-filelist
62%defattr(-,root,root)
63%dir %{perl_vendorarch}/HTML
64%dir %{perl_vendorarch}/auto/HTML
65
66%changelog
67* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-1
68- new upstream release
69- add Requires: perl(:MODULE_COMPAT_...)
70- defined __find_{provides,requires} with vl4 and vl5 (updated 3.64-2)
71- add Vendor and Distribution tags
72
73* Tue Apr 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.64-2
74- undefine __find_provides and __find_requires at VineSeed
75- added Japanese summary
76
77* Sun Nov  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.64-1
78- new upstream release with security fix (CVE-2009-3627)
79
80* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
81- build on perl-5.10.0-1vl5
82
83* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com>  3.56-0vl1
84- new upstream release
85- changed Group to Development/Libraries
86
87* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp>  3.41-0vl1
88- new upstream release
89- build on perl-5.8.6-0vl1
90- fix typo changelog: 3.34-0vl1 and 3.34-0vl2
91- update Url value
92- using perl_sitearch macro
93
94* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
95- built on perl-5.8.2
96
97* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
98- new upstream version
99- built on perl-5.8.1
100
101* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
102- New upstream version
103- build on perl-5.8.0
104        -- changed Requires, Buildrequires
105 
106* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
107- 3.26-14vl2
108- Fix Requires, Buildrequires
109
110* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
111- 3.26-14vl1
112- first build for Vine Linux
113- add define __find_provides / __find_requires
114- modefy files list (dir)
115
116* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
117- automated release bump and build
118
119* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
120- properly claim directories owned by package so they are removed when package is removed
121
122* Mon Jun  3 2002 Chip Turner <cturner@redhat.com>
123- fix for Makefile.PL sometimes prompting for input
124
125* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
126- update to 3.26, move to vendor_perl
127
128* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
129- automated rebuild
130
131* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
132- imported from mandrake. tweaked man path.
133
134* Tue Jul 03 2001 Fran輟is Pons <fpons@mandrakesoft.com> 3.25-1mdk
135- 3.25.
136
137* Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
138- Fixed distribution tag.
139- Updated Requires.
140- Added an option to %makeinstall.
141
142* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
143- Rebuild against the latest perl.
144
145* Tue Feb 27 2001 François Pons <fpons@mandrakesoft.com> 3.18-1mdk
146- 3.18.
147
148* Tue Jan 30 2001 François Pons <fpons@mandrakesoft.com> 3.15-1mdk
149- 3.15.
150
151* Tue Dec 05 2000 François Pons <fpons@mandrakesoft.com> 3.14-1mdk
152- 3.14.
153
154* Thu Oct 12 2000 François Pons <fpons@mandrakesoft.com> 3.13-1mdk
155- 3.13.
156
157* Tue Aug 29 2000 François Pons <fpons@mandrakesoft.com> 3.11-1mdk
158- 3.11.
159
160* Thu Aug 03 2000 François Pons <fpons@mandrakesoft.com> 3.10-2mdk
161- macroszifications.
162- add doc.
163
164* Tue Jul 18 2000 François Pons <fpons@mandrakesoft.com> 3.10-1mdk
165- removed perllocal.pod from files.
166- 3.10.
167
168* Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
169- update to 3.08
170
171* Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
172- Fix build for i486
173- Use %%{_tmppath} for BuildRoot
174
175* Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
176- rebuild, new group, cleanup
177
178* Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
179- upgrade to 3.05
180
181* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
182- final cleanup for Mandrake 7
183
184* Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
185-updated to 3.02
186
187* Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
188- bzip2'd sources
189- updated to 2.23
190
191* Tue May 11 1999 root <root@alien.devel.redhat.com>
192- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.