source: projects/specs/trunk/p/perl-File-HomeDir/perl-File-HomeDir-vl.spec @ 5796

Revision 5796, 5.2 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1Name:           perl-File-HomeDir
2Version:        0.99
3Release:        2%{?_dist_release}
4Summary:        Find your home and other directories on any platform
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/File-HomeDir/
9Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/File-HomeDir-%{version}.tar.gz
10
11BuildArch:      noarch
12BuildRequires:  perl(Carp)
13BuildRequires:  perl(Cwd) >= 3.12
14BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.42
15BuildRequires:  perl(File::Path) >= 2.01
16BuildRequires:  perl(File::Spec) >= 3.12
17BuildRequires:  perl(File::Temp) >= 0.19
18BuildRequires:  perl(File::Which) >= 0.05
19%if !%{defined perl_bootstrap}
20BuildRequires:  perl(Test::Pod)
21BuildRequires:  perl(Test::MinimumVersion)
22BuildRequires:  perl(Test::More) >= 0.47
23%endif
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25Requires:       perl(Cwd) >= 3.12
26Requires:       perl(File::Path) >= 2.01
27Requires:       perl(File::Spec) >= 3.12
28Requires:       perl(File::Temp) >= 0.19
29Requires:       perl(File::Which) >= 0.05
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       shaolin
34
35%description
36File::HomeDir is a module for locating the directories that are "owned"
37by a user (typically your user) and to solve the various issues that
38arise trying to find them consistently across a wide variety of
39platforms.
40
41
42%prep
43%setup -q -n File-HomeDir-%{version}
44
45%if %{_dist_release} > "vl6"
46%{?perl_default_filter}
47%global __requires_exclude %{?__requires_exclude}|perl\\(Cwd\\)|perl\\(File::Path\\)|perl\\(File::Spec\\)|perl\\(File::Temp\\)|perl\\(File::Which\\)|perl\\(Mac::
48%else
49cat << \EOF > %{name}-req
50#!/bin/sh
51%{__perl_requires} $* |\
52sed -e '/perl(Cwd\|File::Path\|File::Spec\|File::Temp\|File::Which)/d' |\
53sed -e '/perl(Mac::/d'
54EOF
55
56%global __perl_requires %{_builddir}/File-HomeDir-%{version}/%{name}-req
57chmod +x %{__perl_requires}
58%endif
59
60
61%build
62%{__perl} Makefile.PL INSTALLDIRS=vendor
63make %{?_smp_mflags}
64
65
66%install
67make pure_install PERL_INSTALL_ROOT=%{buildroot}
68find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
69find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
70chmod -R u+w %{buildroot}/*
71
72
73%check
74# These tests don't do anything really useful. Also, they are broken.
75# AUTOMATED_TESTING=1 make test
76
77
78
79%files
80%doc Changes LICENSE README
81%{perl_vendorlib}/File/
82%{_mandir}/man3/*.3pm*
83
84
85%changelog
86* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-2
87- rebuild
88
89* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-1
90- initial build for Vine Linux
91
92* Tue Jan 31 2012 Tom Callaway <spot@fedoraproject.org> - 0.99-1
93- Update to 0.99
94
95* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-3
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
97
98* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.98-2
99- Perl mass rebuild
100
101* Tue Jul 12 2011 Tom Callaway <spot@fedoraproject.org> - 0.98-1
102- update to 0.98
103
104* Fri Jun 24 2011 Marcela Maslanova <mmaslano@redhat.com> - 0.97-2
105- fix filters for future rebuild
106- add perl_bootstrap macro
107- rebuild for perl 5.14.1
108
109* Mon Feb 21 2011 Tom Callaway <spot@fedoraproject.org> - 0.97-1
110- update to 0.97
111
112* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
114
115* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.93-2
116- 661697 rebuild for fixing problems with vendorach/lib
117
118* Wed Sep 22 2010 Petr Pisar <ppisar@redhat.com> - 0.93-1
119- 0.93 bump
120- Consolidate dependencies
121- Remove unversioned Requires
122- Update Summary and Description
123- Remove unneded file permission fixes
124
125* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.86-4
126- Mass rebuild with perl-5.12.0
127
128* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.86-3
129- rebuild against perl 5.10.1
130
131* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.86-2
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
133
134* Mon Jun  1 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.86-1
135- update for Padre
136
137* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.84-1
138- update to 0.84
139
140* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-2
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
142
143* Tue Dec 16 2008 Marcela Mašláňová <mmaslano@redhat.com> - 0.82-1
144- update to the latest version for Padre editor
145
146* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-3
147- Rebuild for perl 5.10 (again)
148
149* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-2
150- rebuild for new perl
151
152* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-1
153- 0.67
154
155* Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.66-1
156- 0.66
157
158* Wed May 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.65-1
159- Update to 0.65.
160
161* Sat Feb 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.64-1
162- Update to 0.64.
163
164* Thu Jan 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.63-1
165- Update to 0.63.
166
167* Thu Jan  4 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.62-1
168- Update to 0.62.
169
170* Thu Aug 03 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.58-1
171- First build.
Note: See TracBrowser for help on using the repository browser.