source: projects/specs/trunk/p/perl-File-HomeDir/perl-File-HomeDir-vl.spec @ 12120

Revision 12120, 5.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-File-HomeDir
2Version:        1.004
3Release:        1%{?_dist_release}
4Summary:        Find your home and other directories on any platform
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/File-HomeDir/
9Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/File-HomeDir-%{version}.tar.gz
10
11BuildArch:      noarch
12BuildRequires:  perl(Carp)
13BuildRequires:  perl(Cwd)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(File::Path)
16BuildRequires:  perl(File::Spec)
17BuildRequires:  perl(File::Temp)
18BuildRequires:  perl(File::Which)
19#%if !%{defined perl_bootstrap}
20#BuildRequires:  perl(Test::Pod)
21#BuildRequires:  perl(Test::MinimumVersion)
22#BuildRequires:  perl(Test::More) >= 0.47
23#%endif
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25Requires:       perl(Cwd)
26Requires:       perl(File::Path)
27Requires:       perl(File::Spec)
28Requires:       perl(File::Temp)
29Requires:       perl(File::Which)
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       shaolin
34
35%description
36File::HomeDir is a module for locating the directories that are "owned"
37by a user (typically your user) and to solve the various issues that
38arise trying to find them consistently across a wide variety of
39platforms.
40
41
42%prep
43%setup -q -n File-HomeDir-%{version}
44
45%if %{_dist_release} > "vl6"
46%{?perl_default_filter}
47%global __requires_exclude %{?__requires_exclude}|perl\\(Cwd\\)|perl\\(File::Path\\)|perl\\(File::Spec\\)|perl\\(File::Temp\\)|perl\\(File::Which\\)|perl\\(Mac::
48%else
49cat << \EOF > %{name}-req
50#!/bin/sh
51%{__perl_requires} $* |\
52sed -e '/perl(Cwd\|File::Path\|File::Spec\|File::Temp\|File::Which)/d' |\
53sed -e '/perl(Mac::/d'
54EOF
55
56%global __perl_requires %{_builddir}/File-HomeDir-%{version}/%{name}-req
57chmod +x %{__perl_requires}
58%endif
59
60
61%build
62%{__perl} Makefile.PL INSTALLDIRS=vendor
63make %{?_smp_mflags}
64
65
66%install
67make pure_install PERL_INSTALL_ROOT=%{buildroot}
68find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
69find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
70chmod -R u+w %{buildroot}/*
71
72
73%check
74# These tests don't do anything really useful. Also, they are broken.
75# AUTOMATED_TESTING=1 make test
76
77
78
79%files
80%license LICENSE
81%doc Changes README
82%{perl_vendorlib}/File/
83%{_mandir}/man3/*.3pm*
84
85
86%changelog
87* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.004-1
88- new upstream release.
89- rebuilt with perl-5.26.
90
91* Thu Nov  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.00-1
92- updated to 1.00
93- comment out some BR (because "make test" is commented out)
94- built with perl 5.16.3
95
96* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-2
97- rebuild
98
99* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-1
100- initial build for Vine Linux
101
102* Tue Jan 31 2012 Tom Callaway <spot@fedoraproject.org> - 0.99-1
103- Update to 0.99
104
105* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-3
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
107
108* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.98-2
109- Perl mass rebuild
110
111* Tue Jul 12 2011 Tom Callaway <spot@fedoraproject.org> - 0.98-1
112- update to 0.98
113
114* Fri Jun 24 2011 Marcela Maslanova <mmaslano@redhat.com> - 0.97-2
115- fix filters for future rebuild
116- add perl_bootstrap macro
117- rebuild for perl 5.14.1
118
119* Mon Feb 21 2011 Tom Callaway <spot@fedoraproject.org> - 0.97-1
120- update to 0.97
121
122* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
124
125* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.93-2
126- 661697 rebuild for fixing problems with vendorach/lib
127
128* Wed Sep 22 2010 Petr Pisar <ppisar@redhat.com> - 0.93-1
129- 0.93 bump
130- Consolidate dependencies
131- Remove unversioned Requires
132- Update Summary and Description
133- Remove unneded file permission fixes
134
135* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.86-4
136- Mass rebuild with perl-5.12.0
137
138* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.86-3
139- rebuild against perl 5.10.1
140
141* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.86-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
143
144* Mon Jun  1 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.86-1
145- update for Padre
146
147* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.84-1
148- update to 0.84
149
150* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
152
153* Tue Dec 16 2008 Marcela Mašláňová <mmaslano@redhat.com> - 0.82-1
154- update to the latest version for Padre editor
155
156* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-3
157- Rebuild for perl 5.10 (again)
158
159* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-2
160- rebuild for new perl
161
162* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-1
163- 0.67
164
165* Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.66-1
166- 0.66
167
168* Wed May 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.65-1
169- Update to 0.65.
170
171* Sat Feb 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.64-1
172- Update to 0.64.
173
174* Thu Jan 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.63-1
175- Update to 0.63.
176
177* Thu Jan  4 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.62-1
178- Update to 0.62.
179
180* Thu Aug 03 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.58-1
181- First build.
Note: See TracBrowser for help on using the repository browser.