source: projects/specs/trunk/p/perl-Event/perl-Event-vl.spec @ 8647

Revision 8647, 5.3 KB checked in by iwaim, 10 years ago (diff)

perl-Event 1.20-2

Line 
1Name:           perl-Event
2Version:        1.20
3Release:        2%{?_dist_release}
4Summary:        Event loop processing
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Event/
8Source0:        http://search.cpan.org/CPAN/authors/id/J/JP/JPRIT/Event-%{version}.tar.gz
9Patch0:         Event-1.19-UTF8.patch
10BuildRequires:  perl(Carp)
11BuildRequires:  perl(Config)
12BuildRequires:  perl(Exporter)
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(Test) >= 1
15BuildRequires:  perl(Time::HiRes)
16Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
17Requires:       perl(Time::HiRes)
18
19%if %{_dist_release} > "vl6"
20%global __requires_exclude %{?__requires_exclude:__requires_exclude|}perl\\(attrs\\)
21%endif
22%{?perl_default_filter}
23
24
25%description
26The Event module provide a central facility to watch for various types of
27events and invoke a callback when these events occur. The idea is to delay the
28handling of events so that they may be dispatched in priority order when it is
29safe for callbacks to execute.
30
31
32%prep
33%setup -q -n Event-%{version}
34
35# Fix up permissions and shellbangs
36find ./ -type f -exec chmod -c -x {} \;
37perl -pi -e 's|#!./perl|#!/usr/bin/perl|' demo/*.t t/*.t util/bench.pl
38%{_fixperms} demo/ util/
39
40# Fix character encoding
41%patch0 -p1
42
43%if %{_dist_release} <= "vl6"
44cat << \EOF > %{name}-req
45#!/bin/sh
46%{__perl_requires} $* | sed -e '/perl(attrs)/d'
47EOF
48
49%global __perl_requires %{_builddir}/Event-%{version}/%{name}-req
50chmod +x %{__perl_requires}
51%endif
52
53
54%build
55perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
56make %{?_smp_mflags}
57
58
59%install
60make pure_install DESTDIR=%{buildroot}
61find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
62find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
63find %{buildroot} -depth -type d -exec rmdir --ignore-fail-on-non-empty {} ';'
64%{_fixperms} %{buildroot}
65
66
67%check
68make test
69
70
71%files
72%doc ANNOUNCE ChangeLog README README.EV TODO
73%doc Tutorial.pdf Tutorial.pdf-errata.txt demo/ t/ util/
74%doc %{perl_vendorarch}/Event.pod
75%{perl_vendorarch}/auto/Event/
76%{perl_vendorarch}/Event.pm
77%{perl_vendorarch}/Event/
78%{_mandir}/man3/Event.3pm*
79%{_mandir}/man3/Event::MakeMaker.3pm*
80%{_mandir}/man3/Event::generic.3pm*
81
82
83%changelog
84* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20-2
85- build with Perl 5.16
86
87* Fri Mar 02 2012 MATSUBAYASHi Kohji <shaolin@vinelinux.org> - 1.20-1
88- initial build for Vine Linux
89
90* Sun Jan 15 2012 Paul Howarth <paul@city-fan.org> 1.20-1
91- update to 1.20 (test suite fixes)
92- BR: perl(Carp), perl(Config), perl(Exporter)
93- since upstream doesn't ship license files, neither should we
94- make %%files list more explicit
95- use a patch to fix character encoding rather than scripted iconv
96- use DESTDIR rather than PERL_INSTALL_ROOT
97- no need for additional filtering on top of %%{?perl_default_filter}
98- don't package INSTALL file
99
100* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.15-3
101- rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
102
103* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> 1.15-2
104- perl mass rebuild
105
106* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 1.15-1
107- update to latest upstream version
108- clean up spec for modern rpmbuild
109- filter perl(attrs) from requires
110
111* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.12-6
112- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
113
114* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-5
115- rebuild to fix problems with vendorarch/lib (#661697)
116
117* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-4
118- mass rebuild with perl-5.12.0
119
120* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-3
121- mass rebuild with perl-5.12.0
122
123* Mon Dec 07 2009 Stepan Kasal <skasal@redhat.com> 1.12-2
124- rebuild against perl 5.10.1
125
126* Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
127- add perl_default_filter
128- auto-update to 1.12 (by cpan-spec-update 0.01)
129- added a new req on perl(Test) (version 1)
130
131* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-3
132- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
133
134* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-2
135- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
136
137* Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
138- update to 1.11
139
140* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-5
141- rebuild for perl 5.10 (again)
142
143* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> 1.09-4
144- autorebuild for GCC 4.3
145
146* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-3
147- rebuild for new perl
148
149* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-2
150- bump
151
152* Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-1
153- update to 1.09
154- add t/ to doc
155
156* Sat Nov 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.08-1
157- update to 1.08
158
159* Sun Oct 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.07-1
160- update to 1.07
161
162* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-2
163- bump for mass rebuild
164
165* Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-1
166- add explicit provides: perl(Event) = version...  wasn't being picked up
167  automagically for some reason
168- tweaked summary line
169- bumped release
170
171* Thu Jun 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-0
172- initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.