source: projects/specs/trunk/p/perl-Event/perl-Event-vl.spec @ 12120

Revision 12120, 5.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Event
2Version:        1.27
3Release:        1%{?_dist_release}
4Summary:        Event loop processing
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Event/
8Source0:        http://search.cpan.org/CPAN/authors/id/J/JP/JPRIT/Event-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildRequires:  perl(Carp)
12BuildRequires:  perl(Config)
13BuildRequires:  perl(Exporter)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Test)
16BuildRequires:  perl(Time::HiRes)
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18Requires:       perl(Time::HiRes)
19
20Vendor:       Project Vine
21Distribution: Vine Linux
22
23%if %{_dist_release} > "vl6"
24%global __requires_exclude %{?__requires_exclude:__requires_exclude|}perl\\(attrs\\)
25%endif
26%{?perl_default_filter}
27
28
29%description
30The Event module provide a central facility to watch for various types of
31events and invoke a callback when these events occur. The idea is to delay the
32handling of events so that they may be dispatched in priority order when it is
33safe for callbacks to execute.
34
35
36%prep
37%setup -q -n Event-%{version}
38
39# Fix up permissions and shellbangs
40find ./ -type f -exec chmod -c -x {} \;
41perl -pi -e 's|#!./perl|#!/usr/bin/perl|' demo/*.t t/*.t util/bench.pl
42%{_fixperms} demo/ util/
43
44# Fix character encoding
45#patch0 -p1
46
47%if %{_dist_release} <= "vl6"
48cat << \EOF > %{name}-req
49#!/bin/sh
50%{__perl_requires} $* | sed -e '/perl(attrs)/d'
51EOF
52
53%global __perl_requires %{_builddir}/Event-%{version}/%{name}-req
54chmod +x %{__perl_requires}
55%endif
56
57
58%build
59perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
60make %{?_smp_mflags}
61
62
63%install
64make pure_install DESTDIR=%{buildroot}
65find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
66find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
67find %{buildroot} -depth -type d -exec rmdir --ignore-fail-on-non-empty {} ';'
68%{_fixperms} %{buildroot}
69
70
71%check
72make test
73
74
75%files
76%doc ANNOUNCE ChangeLog README README.EV TODO
77%doc Tutorial.pdf Tutorial.pdf-errata.txt demo/ t/ util/
78%doc %{perl_vendorarch}/Event.pod
79%{perl_vendorarch}/auto/Event/
80%{perl_vendorarch}/Event.pm
81%{perl_vendorarch}/Event/
82%{_mandir}/man3/Event.3pm*
83%{_mandir}/man3/Event::MakeMaker.3pm*
84%{_mandir}/man3/Event::generic.3pm*
85
86
87%changelog
88* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.27-1
89- new upstream release.
90- rebuilt with perl-5.26.
91
92* Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.24-1
93- new upstream release
94- dropt Patch0 merged into upstream
95
96* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20-2
97- build with Perl 5.16
98
99* Fri Mar 02 2012 MATSUBAYASHi Kohji <shaolin@vinelinux.org> - 1.20-1
100- initial build for Vine Linux
101
102* Sun Jan 15 2012 Paul Howarth <paul@city-fan.org> 1.20-1
103- update to 1.20 (test suite fixes)
104- BR: perl(Carp), perl(Config), perl(Exporter)
105- since upstream doesn't ship license files, neither should we
106- make %%files list more explicit
107- use a patch to fix character encoding rather than scripted iconv
108- use DESTDIR rather than PERL_INSTALL_ROOT
109- no need for additional filtering on top of %%{?perl_default_filter}
110- don't package INSTALL file
111
112* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.15-3
113- rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
114
115* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> 1.15-2
116- perl mass rebuild
117
118* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 1.15-1
119- update to latest upstream version
120- clean up spec for modern rpmbuild
121- filter perl(attrs) from requires
122
123* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.12-6
124- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
125
126* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-5
127- rebuild to fix problems with vendorarch/lib (#661697)
128
129* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-4
130- mass rebuild with perl-5.12.0
131
132* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-3
133- mass rebuild with perl-5.12.0
134
135* Mon Dec 07 2009 Stepan Kasal <skasal@redhat.com> 1.12-2
136- rebuild against perl 5.10.1
137
138* Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
139- add perl_default_filter
140- auto-update to 1.12 (by cpan-spec-update 0.01)
141- added a new req on perl(Test) (version 1)
142
143* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-3
144- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
145
146* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-2
147- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
148
149* Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
150- update to 1.11
151
152* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-5
153- rebuild for perl 5.10 (again)
154
155* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> 1.09-4
156- autorebuild for GCC 4.3
157
158* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-3
159- rebuild for new perl
160
161* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-2
162- bump
163
164* Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-1
165- update to 1.09
166- add t/ to doc
167
168* Sat Nov 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.08-1
169- update to 1.08
170
171* Sun Oct 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.07-1
172- update to 1.07
173
174* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-2
175- bump for mass rebuild
176
177* Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-1
178- add explicit provides: perl(Event) = version...  wasn't being picked up
179  automagically for some reason
180- tweaked summary line
181- bumped release
182
183* Thu Jun 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-0
184- initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.