source: projects/specs/trunk/p/perl-Event/perl-Event-vl.spec @ 5803

Revision 5803, 5.2 KB checked in by shaolin, 12 years ago (diff)
  • new packages (and a few updates)
Line 
1Name:           perl-Event
2Version:        1.20
3Release:        1%{?_dist_release}
4Summary:        Event loop processing
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Event/
8Source0:        http://search.cpan.org/CPAN/authors/id/J/JP/JPRIT/Event-%{version}.tar.gz
9Patch0:         Event-1.19-UTF8.patch
10BuildRequires:  perl(Carp)
11BuildRequires:  perl(Config)
12BuildRequires:  perl(Exporter)
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(Test) >= 1
15BuildRequires:  perl(Time::HiRes)
16Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
17Requires:       perl(Time::HiRes)
18
19%if %{_dist_release} > "vl6"
20%global __requires_exclude %{?__requires_exclude:__requires_exclude|}perl\\(attrs\\)
21%endif
22%{?perl_default_filter}
23
24
25%description
26The Event module provide a central facility to watch for various types of
27events and invoke a callback when these events occur. The idea is to delay the
28handling of events so that they may be dispatched in priority order when it is
29safe for callbacks to execute.
30
31
32%prep
33%setup -q -n Event-%{version}
34
35# Fix up permissions and shellbangs
36find ./ -type f -exec chmod -c -x {} \;
37perl -pi -e 's|#!./perl|#!/usr/bin/perl|' demo/*.t t/*.t util/bench.pl
38%{_fixperms} demo/ util/
39
40# Fix character encoding
41%patch0 -p1
42
43%if %{_dist_release} <= "vl6"
44cat << \EOF > %{name}-req
45#!/bin/sh
46%{__perl_requires} $* | sed -e '/perl(attrs)/d'
47EOF
48
49%global __perl_requires %{_builddir}/Event-%{version}/%{name}-req
50chmod +x %{__perl_requires}
51%endif
52
53
54%build
55perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
56make %{?_smp_mflags}
57
58
59%install
60make pure_install DESTDIR=%{buildroot}
61find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
62find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
63find %{buildroot} -depth -type d -exec rmdir --ignore-fail-on-non-empty {} ';'
64%{_fixperms} %{buildroot}
65
66
67%check
68make test
69
70
71%files
72%doc ANNOUNCE ChangeLog README README.EV TODO
73%doc Tutorial.pdf Tutorial.pdf-errata.txt demo/ t/ util/
74%doc %{perl_vendorarch}/Event.pod
75%{perl_vendorarch}/auto/Event/
76%{perl_vendorarch}/Event.pm
77%{perl_vendorarch}/Event/
78%{_mandir}/man3/Event.3pm*
79%{_mandir}/man3/Event::MakeMaker.3pm*
80%{_mandir}/man3/Event::generic.3pm*
81
82
83%changelog
84* Fri Mar 02 2012 MATSUBAYASHi Kohji <shaolin@vinelinux.org> - 1.20-1
85- initial build for Vine Linux
86
87* Sun Jan 15 2012 Paul Howarth <paul@city-fan.org> 1.20-1
88- update to 1.20 (test suite fixes)
89- BR: perl(Carp), perl(Config), perl(Exporter)
90- since upstream doesn't ship license files, neither should we
91- make %%files list more explicit
92- use a patch to fix character encoding rather than scripted iconv
93- use DESTDIR rather than PERL_INSTALL_ROOT
94- no need for additional filtering on top of %%{?perl_default_filter}
95- don't package INSTALL file
96
97* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.15-3
98- rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
99
100* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> 1.15-2
101- perl mass rebuild
102
103* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 1.15-1
104- update to latest upstream version
105- clean up spec for modern rpmbuild
106- filter perl(attrs) from requires
107
108* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.12-6
109- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
110
111* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-5
112- rebuild to fix problems with vendorarch/lib (#661697)
113
114* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-4
115- mass rebuild with perl-5.12.0
116
117* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-3
118- mass rebuild with perl-5.12.0
119
120* Mon Dec 07 2009 Stepan Kasal <skasal@redhat.com> 1.12-2
121- rebuild against perl 5.10.1
122
123* Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
124- add perl_default_filter
125- auto-update to 1.12 (by cpan-spec-update 0.01)
126- added a new req on perl(Test) (version 1)
127
128* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-3
129- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
130
131* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-2
132- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
133
134* Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
135- update to 1.11
136
137* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-5
138- rebuild for perl 5.10 (again)
139
140* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> 1.09-4
141- autorebuild for GCC 4.3
142
143* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-3
144- rebuild for new perl
145
146* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-2
147- bump
148
149* Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-1
150- update to 1.09
151- add t/ to doc
152
153* Sat Nov 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.08-1
154- update to 1.08
155
156* Sun Oct 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.07-1
157- update to 1.07
158
159* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-2
160- bump for mass rebuild
161
162* Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-1
163- add explicit provides: perl(Event) = version...  wasn't being picked up
164  automagically for some reason
165- tweaked summary line
166- bumped release
167
168* Thu Jun 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-0
169- initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.