source: projects/specs/trunk/p/perl-Event/perl-Event-vl.spec @ 9512

Revision 9512, 5.4 KB checked in by inagaki, 9 years ago (diff)

2015-04-16 Ryoichi INAGAKI <ryo1@…>

  • perl-{Cairo, Clone, Curses, Event, Guard, IO-AIO,

IO-Socket-SSL, IPC-Run, Tk, URI}: updated


Line 
1Name:           perl-Event
2Version:        1.24
3Release:        1%{?_dist_release}
4Summary:        Event loop processing
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Event/
8Source0:        http://search.cpan.org/CPAN/authors/id/J/JP/JPRIT/Event-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildRequires:  perl(Carp)
12BuildRequires:  perl(Config)
13BuildRequires:  perl(Exporter)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Test) >= 1
16BuildRequires:  perl(Time::HiRes)
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18Requires:       perl(Time::HiRes)
19
20%if %{_dist_release} > "vl6"
21%global __requires_exclude %{?__requires_exclude:__requires_exclude|}perl\\(attrs\\)
22%endif
23%{?perl_default_filter}
24
25
26%description
27The Event module provide a central facility to watch for various types of
28events and invoke a callback when these events occur. The idea is to delay the
29handling of events so that they may be dispatched in priority order when it is
30safe for callbacks to execute.
31
32
33%prep
34%setup -q -n Event-%{version}
35
36# Fix up permissions and shellbangs
37find ./ -type f -exec chmod -c -x {} \;
38perl -pi -e 's|#!./perl|#!/usr/bin/perl|' demo/*.t t/*.t util/bench.pl
39%{_fixperms} demo/ util/
40
41# Fix character encoding
42#patch0 -p1
43
44%if %{_dist_release} <= "vl6"
45cat << \EOF > %{name}-req
46#!/bin/sh
47%{__perl_requires} $* | sed -e '/perl(attrs)/d'
48EOF
49
50%global __perl_requires %{_builddir}/Event-%{version}/%{name}-req
51chmod +x %{__perl_requires}
52%endif
53
54
55%build
56perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
57make %{?_smp_mflags}
58
59
60%install
61make pure_install DESTDIR=%{buildroot}
62find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
63find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
64find %{buildroot} -depth -type d -exec rmdir --ignore-fail-on-non-empty {} ';'
65%{_fixperms} %{buildroot}
66
67
68%check
69make test
70
71
72%files
73%doc ANNOUNCE ChangeLog README README.EV TODO
74%doc Tutorial.pdf Tutorial.pdf-errata.txt demo/ t/ util/
75%doc %{perl_vendorarch}/Event.pod
76%{perl_vendorarch}/auto/Event/
77%{perl_vendorarch}/Event.pm
78%{perl_vendorarch}/Event/
79%{_mandir}/man3/Event.3pm*
80%{_mandir}/man3/Event::MakeMaker.3pm*
81%{_mandir}/man3/Event::generic.3pm*
82
83
84%changelog
85* Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.24-1
86- new upstream release
87- dropt Patch0 merged into upstream
88
89* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20-2
90- build with Perl 5.16
91
92* Fri Mar 02 2012 MATSUBAYASHi Kohji <shaolin@vinelinux.org> - 1.20-1
93- initial build for Vine Linux
94
95* Sun Jan 15 2012 Paul Howarth <paul@city-fan.org> 1.20-1
96- update to 1.20 (test suite fixes)
97- BR: perl(Carp), perl(Config), perl(Exporter)
98- since upstream doesn't ship license files, neither should we
99- make %%files list more explicit
100- use a patch to fix character encoding rather than scripted iconv
101- use DESTDIR rather than PERL_INSTALL_ROOT
102- no need for additional filtering on top of %%{?perl_default_filter}
103- don't package INSTALL file
104
105* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.15-3
106- rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
107
108* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> 1.15-2
109- perl mass rebuild
110
111* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 1.15-1
112- update to latest upstream version
113- clean up spec for modern rpmbuild
114- filter perl(attrs) from requires
115
116* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.12-6
117- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
118
119* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-5
120- rebuild to fix problems with vendorarch/lib (#661697)
121
122* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-4
123- mass rebuild with perl-5.12.0
124
125* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-3
126- mass rebuild with perl-5.12.0
127
128* Mon Dec 07 2009 Stepan Kasal <skasal@redhat.com> 1.12-2
129- rebuild against perl 5.10.1
130
131* Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
132- add perl_default_filter
133- auto-update to 1.12 (by cpan-spec-update 0.01)
134- added a new req on perl(Test) (version 1)
135
136* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-3
137- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-2
140- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
141
142* Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
143- update to 1.11
144
145* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-5
146- rebuild for perl 5.10 (again)
147
148* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> 1.09-4
149- autorebuild for GCC 4.3
150
151* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-3
152- rebuild for new perl
153
154* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-2
155- bump
156
157* Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-1
158- update to 1.09
159- add t/ to doc
160
161* Sat Nov 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.08-1
162- update to 1.08
163
164* Sun Oct 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.07-1
165- update to 1.07
166
167* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-2
168- bump for mass rebuild
169
170* Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-1
171- add explicit provides: perl(Event) = version...  wasn't being picked up
172  automagically for some reason
173- tweaked summary line
174- bumped release
175
176* Thu Jun 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-0
177- initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.