source: projects/specs/trunk/p/perl-EV/perl-EV-vl.spec @ 5803

Revision 5803, 5.2 KB checked in by shaolin, 12 years ago (diff)
  • new packages (and a few updates)
Line 
1Name:           perl-EV
2Version:        4.03
3Release:        1%{?_dist_release}
4Summary:        Wrapper for the libev high-performance event loop library
5Summary(ja):    高性能イベントループライブラリ libev の Perl ラッパー
6
7Group:          Development/Libraries
8# Note: The source archive includes a libev/ folder which contents are licensed
9#       as "BSD or GPLv2+". However, those are removed at build-time and
10#       perl-EV is instead built against the system-provided libev.
11License:        GPL+ or Artistic
12URL:            http://search.cpan.org/dist/EV/
13Source0:        http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/EV-%{version}.tar.gz
14Patch0:         perl-EV-4.03-Don-t-ask-questions-at-build-time.patch
15
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(common::sense)
18BuildRequires:  gdbm-devel
19BuildRequires:  libev-source >= %{version}
20BuildRequires:  perl(AnyEvent) => 2.6
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23# As per review, a perl-EV-devel subpackage had at first been pushed to the
24# repositories. It now has broken deps if it's not properly obsoleted/provided.
25# TODO: Remove those two lines during the Fedora 17 development cycle.
26Provides:       %{name}-devel = %{version}-%{release}
27Obsoletes:      %{name}-devel < 4.03-5
28
29%{?perl_default_filter}
30
31
32%description
33This module provides an interface to libev
34(<http://software.schmorp.de/pkg/libev.html>). While the included documentation
35is comprehensive, one might also consult the documentation of libev itself
36(<http://cvs.schmorp.de/libev/ev.html>) for more subtle details on watcher
37semantics or some discussion on the available backends, or how to force a
38specific backend with "LIBEV_FLAGS", or just about in any case because it has
39much more detailed information.
40
41
42%prep
43%setup -q -n EV-%{version}
44
45# no questins during build
46%patch0 -p1
47
48# remove all traces of the bundled libev
49rm -fr libev/*
50
51# use the sources from the system libev
52mkdir -p ./libev
53cp -r /usr/share/libev-source/* ./libev/
54
55
56%build
57%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
58make %{?_smp_mflags}
59
60
61%install
62make pure_install PERL_INSTALL_ROOT=%{buildroot}
63find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
64find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
65find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
66chmod -R u+w %{buildroot}/*
67
68
69%check
70make test
71
72
73%clean
74rm -rf %{buildroot}
75
76
77%files
78%defattr(-,root,root,-)
79%doc Changes COPYING README
80%{perl_vendorarch}/auto/*
81%{perl_vendorarch}/EV.pm
82%{perl_vendorarch}/EV
83%{perl_vendorarch}/EV/*.h
84%{_mandir}/man3/*.3*
85
86
87%changelog
88* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
89- initial build for Vine Linux
90
91* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.03-8
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
93
94* Thu Dec 01 2011 Petr Pisar <ppisar@redhat.com> - 4.03-7
95- Build-require exact or higher version of libev-source (bug #759021)
96
97* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.03-6
98- Perl mass rebuild
99
100* Tue Apr 12 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-5
101- Add the correct Obsoletes/Provides to avoid broken deps from the -devel
102  subpackage removal.
103
104* Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-4
105- Readded the header file to the main package, as per guidelines:
106      -> http://fedoraproject.org/wiki/Packaging/Perl#.h_files_in_module_packages
107
108* Tue Mar 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-3
109- Some more fixes as part of the review process:
110  - Fix the license tag to be only the license of perl-EV, and add a note about
111    the included libev sources.
112- Removed manual cleaning of the buildroot since it has been useless since
113  Fedora 10 and even EPEL (>=6) doesn't need it now.
114
115* Wed Feb 23 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-2
116- Fixes asked during the review process:
117  - Filter the private shared EV.so out of the automatic Provides
118  - Put the header files in a -devel package
119- Removed the Buildroot line since it's useless for newer versions of Fedora
120  and this package can only go in Fedora >= 15 due to its libev dependency)
121
122* Mon Jan 24 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-1
123- Update to 4.03.
124- Use the system libev instead of the bundled one.
125
126* Sun Nov  8 2009 kwizart < kwizart at gmail.com > - 3.8-1
127- Update to 3.8
128
129* Tue Apr 28 2009 kwizart < kwizart at gmail.com > - 3.6-1
130- Update to 3.6
131
132* Mon Mar  2 2009 kwizart < kwizart at gmail.com > - 3.53-1
133- Update to 3.53
134
135* Tue Feb  3 2009 kwizart < kwizart at gmail.com > - 3.52-1
136- Update to 3.52
137
138* Tue Oct 14 2008 kwizart < kwizart at gmail.com > - 3.44-1
139- Update to 3.44
140- WIP conditional --with systemlibev
141
142* Wed Jul 15 2008 kwizart < kwizart at gmail.com > - 3.431-1
143- Update to 3.431
144- Update License to (GPL+ or Artistic) and (BSD or GPLv2+)
145- Add libev README and LICENSE
146
147* Wed Jul  8 2008 kwizart < kwizart at gmail.com > - 3.43-1
148- Update to 3.43
149
150* Mon Jun  9 2008 kwizart < kwizart at gmail.com > - 3.42-2
151- Disable filter AnyEvent
152
153* Tue May 27 2008 kwizart < kwizart at gmail.com > - 3.42-1
154- Update to 3.42
155
156* Wed Apr 30 2008 kwizart < kwizart at gmail.com > - 3.31-1
157- Initial package for Fedora
158
Note: See TracBrowser for help on using the repository browser.