source: projects/specs/trunk/p/perl-EV/perl-EV-vl.spec @ 12120

Revision 12120, 5.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-EV
2Version:        4.25
3Release:        1%{?_dist_release}
4Summary:        Wrapper for the libev high-performance event loop library
5Summary(ja):    高性能イベントループライブラリ libev の Perl ラッパー
6
7Group:          Development/Libraries
8# Note: The source archive includes a libev/ folder which contents are licensed
9#       as "BSD or GPLv2+". However, those are removed at build-time and
10#       perl-EV is instead built against the system-provided libev.
11License:        GPL+ or Artistic
12URL:            http://search.cpan.org/dist/EV/
13Source0:        http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/EV-%{version}.tar.gz
14Patch0:         perl-EV-4.03-Don-t-ask-questions-at-build-time.patch
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19BuildRequires:  perl(ExtUtils::MakeMaker)
20BuildRequires:  perl(common::sense)
21BuildRequires:  gdbm-devel
22BuildRequires:  libxcrypt-devel
23BuildRequires:  libev-source >= %{version}
24BuildRequires:  perl(AnyEvent)
25BuildRequires:  perl(Canary::Stability)
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27
28# As per review, a perl-EV-devel subpackage had at first been pushed to the
29# repositories. It now has broken deps if it's not properly obsoleted/provided.
30# TODO: Remove those two lines during the Fedora 17 development cycle.
31Provides:       %{name}-devel = %{version}-%{release}
32Obsoletes:      %{name}-devel < 4.03-5
33
34%{?perl_default_filter}
35
36
37%description
38This module provides an interface to libev
39(<http://software.schmorp.de/pkg/libev.html>). While the included documentation
40is comprehensive, one might also consult the documentation of libev itself
41(<http://cvs.schmorp.de/libev/ev.html>) for more subtle details on watcher
42semantics or some discussion on the available backends, or how to force a
43specific backend with "LIBEV_FLAGS", or just about in any case because it has
44much more detailed information.
45
46
47%prep
48%setup -q -n EV-%{version}
49
50# no questins during build
51%patch0 -p1
52
53# remove all traces of the bundled libev
54rm -fr libev/*
55
56# use the sources from the system libev
57mkdir -p ./libev
58cp -r /usr/share/libev-source/* ./libev/
59
60
61%build
62echo "y" | %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
63make %{?_smp_mflags}
64
65
66%install
67make pure_install PERL_INSTALL_ROOT=%{buildroot}
68find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
69find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
70find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
71chmod -R u+w %{buildroot}/*
72
73
74%check
75make test
76
77
78%clean
79rm -rf %{buildroot}
80
81
82%files
83%defattr(-,root,root,-)
84%license COPYING
85%doc Changes README
86%{perl_vendorarch}/auto/*
87%{perl_vendorarch}/EV.pm
88%{perl_vendorarch}/EV
89%{perl_vendorarch}/EV/*.h
90%{_mandir}/man3/*.3*
91
92
93%changelog
94* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.25-1
95- new upstream release.
96- rebuilt with perl-5.26.
97- added BR:libxcrypt-devel.
98
99* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.03-2
100- build with Perl 5.16
101
102* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
103- initial build for Vine Linux
104
105* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.03-8
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
107
108* Thu Dec 01 2011 Petr Pisar <ppisar@redhat.com> - 4.03-7
109- Build-require exact or higher version of libev-source (bug #759021)
110
111* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.03-6
112- Perl mass rebuild
113
114* Tue Apr 12 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-5
115- Add the correct Obsoletes/Provides to avoid broken deps from the -devel
116  subpackage removal.
117
118* Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-4
119- Readded the header file to the main package, as per guidelines:
120      -> http://fedoraproject.org/wiki/Packaging/Perl#.h_files_in_module_packages
121
122* Tue Mar 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-3
123- Some more fixes as part of the review process:
124  - Fix the license tag to be only the license of perl-EV, and add a note about
125    the included libev sources.
126- Removed manual cleaning of the buildroot since it has been useless since
127  Fedora 10 and even EPEL (>=6) doesn't need it now.
128
129* Wed Feb 23 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-2
130- Fixes asked during the review process:
131  - Filter the private shared EV.so out of the automatic Provides
132  - Put the header files in a -devel package
133- Removed the Buildroot line since it's useless for newer versions of Fedora
134  and this package can only go in Fedora >= 15 due to its libev dependency)
135
136* Mon Jan 24 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-1
137- Update to 4.03.
138- Use the system libev instead of the bundled one.
139
140* Sun Nov  8 2009 kwizart < kwizart at gmail.com > - 3.8-1
141- Update to 3.8
142
143* Tue Apr 28 2009 kwizart < kwizart at gmail.com > - 3.6-1
144- Update to 3.6
145
146* Mon Mar  2 2009 kwizart < kwizart at gmail.com > - 3.53-1
147- Update to 3.53
148
149* Tue Feb  3 2009 kwizart < kwizart at gmail.com > - 3.52-1
150- Update to 3.52
151
152* Tue Oct 14 2008 kwizart < kwizart at gmail.com > - 3.44-1
153- Update to 3.44
154- WIP conditional --with systemlibev
155
156* Tue Jul 15 2008 kwizart < kwizart at gmail.com > - 3.431-1
157- Update to 3.431
158- Update License to (GPL+ or Artistic) and (BSD or GPLv2+)
159- Add libev README and LICENSE
160
161* Tue Jul  8 2008 kwizart < kwizart at gmail.com > - 3.43-1
162- Update to 3.43
163
164* Mon Jun  9 2008 kwizart < kwizart at gmail.com > - 3.42-2
165- Disable filter AnyEvent
166
167* Tue May 27 2008 kwizart < kwizart at gmail.com > - 3.42-1
168- Update to 3.42
169
170* Wed Apr 30 2008 kwizart < kwizart at gmail.com > - 3.31-1
171- Initial package for Fedora
172
Note: See TracBrowser for help on using the repository browser.