source: projects/specs/trunk/p/perl-Devel-GlobalDestruction/perl-Devel-GlobalDestruction-vl.spec @ 5844

Revision 5844, 4.5 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1# Package is noarch from perl 5.13.7
2%global noarch_package %(perl -e 'print (($] >= 5.013007) ? 1 : 0);')
3
4Name:           perl-Devel-GlobalDestruction
5Version:        0.04
6Release:        1%{?_dist_release}
7License:        GPL+ or Artistic
8Group:          Development/Libraries
9Summary:        Expose PL_dirty, the flag that marks global destruction
10Url:            http://search.cpan.org/dist/Devel-GlobalDestruction
11Source:         http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Devel-GlobalDestruction-%{version}.tar.gz
12%if %{noarch_package}
13BuildArch:      noarch
14%endif
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(Sub::Exporter)
18BuildRequires:  perl(XSLoader)
19Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
20
21# Don't "provide" private Perl libs
22%{?perl_default_filter}
23
24%description
25Perl's global destruction is a little tricky to deal with with respect to
26finalizers because it's not ordered and objects can sometimes disappear.
27
28Writing defensive destructors is hard and annoying, and usually if global
29destruction is happening you only need the destructors that free up non
30process local resources to actually execute.
31
32For these constructors you can avoid the mess by simply bailing out if
33global destruction is in effect.
34
35%prep
36%setup -q -n Devel-GlobalDestruction-%{version}
37
38%build
39perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
40make %{?_smp_mflags}
41
42%install
43rm -rf %{buildroot}
44make pure_install DESTDIR=%{buildroot}
45find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
46find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
47find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
48%{_fixperms} %{buildroot}
49
50%check
51make test
52
53%clean
54rm -rf %{buildroot}
55
56%files
57%defattr(-,root,root,-)
58%doc Changes t/
59%if %{noarch_package}
60%{perl_vendorlib}/Devel/
61%else
62%{perl_vendorarch}/auto/Devel/
63%{perl_vendorarch}/Devel/
64%endif
65%{_mandir}/man3/Devel::GlobalDestruction.3pm*
66
67%changelog
68* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.04-1
69- initial build for Vine Linux
70
71* Fri Jan 13 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
72- Update to 0.04
73  - To detect a perl with ${^GLOBAL_PHASE}, check for the feature itself
74    instead of a specific perl version
75  - Update the documentation to reflect the use of ${^GLOBAL_PHASE} if available
76  - Stop depending on Scope::Guard for the tests
77  - Upgrade ppport.h from version 3.13 to 3.19
78- Drop no-longer-necessary buildreq perl(Scope::Guard)
79- Use DESTDIR rather than PERL_INSTALL_ROOT
80- BR: perl(XSLoader)
81
82* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
83- Fedora 17 mass rebuild
84
85* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-2
86- Perl mass rebuild
87
88* Fri Jun 24 2011 Paul Howarth <paul@city-fan.org> - 0.03-1
89- Update to 0.03
90  - Drop the XS code on perl versions recent enough to have ${^GLOBAL_PHASE}
91    (5.13.7 onwards)
92  - Require at least Perl 5.6
93    - Use XSLoader without a fallback to DynaLoader
94    - Use our instead of use vars
95- This release by FLORA -> update source URL
96- Package is noarch from perl 5.13.7
97- Package Changes file
98- Use %%{?perl_default_filter}
99
100* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-12
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
102
103* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-11
104- Rebuild to fix problems with vendorarch/lib (#661697)
105
106* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-10
107- Mass rebuild with perl-5.12.0
108
109* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-9
110- Mass rebuild with perl-5.12.0
111
112* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.02-8
113- rebuild against perl 5.10.1
114
115* Sun Aug 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.02-7
116- bump
117
118* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-6
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-5
122- Stripping bad provides of private Perl extension libs
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-4
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Mon Nov 03 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-3
128- bump
129
130* Sat Nov 01 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-2
131- tweak summary
132
133* Sun Oct 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-1
134- clean up for review submission
135
136* Sun Oct 19 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-0.1
137- initial RPM packaging
138- generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)
139
Note: See TracBrowser for help on using the repository browser.