source: projects/specs/trunk/p/perl-Devel-GlobalDestruction/perl-Devel-GlobalDestruction-vl.spec @ 9187

Revision 9187, 4.7 KB checked in by inagaki, 9 years ago (diff)

2014-12-23 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-FormBuilder?, perl-Devel-{EnforceEncapsulation?, GlobalDestruction?}, perl-Moose, perl-Net-{Pcap, Radius, Telnet, Write}, perl-Template-Toolkit, perl-Text-Unidecode, perl-XML-RSS: updated
  • perl-CGI-SSI, perl-Geography-Countries, perl-MIME-Lite-TT, perl-MP3-Info, perl-Text-Glob: rebuilt
  • perl-Sub-Exporter-Progressive: new


Line 
1# Package is noarch from perl 5.13.7
2%global noarch_package %(perl -e 'print (($] >= 5.013007) ? 1 : 0);')
3
4Summary:        Expose PL_dirty, the flag that marks global destruction
5Name:           perl-Devel-GlobalDestruction
6Version:        0.13
7Release:        1%{?_dist_release}
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/Devel-GlobalDestruction
11
12Source:         http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Devel-GlobalDestruction-%{version}.tar.gz
13
14%if %{noarch_package}
15BuildArch:      noarch
16%endif
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires:  perl(ExtUtils::CBuilder) >= 0.27
19BuildRequires:  perl(ExtUtils::MakeMaker)
20BuildRequires:  perl(Sub::Exporter::Progressive) >= 0.001011
21BuildRequires:  perl(XSLoader)
22Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
23
24# Don't "provide" private Perl libs
25%{?perl_default_filter}
26
27%description
28Perl's global destruction is a little tricky to deal with with respect to
29finalizers because it's not ordered and objects can sometimes disappear.
30
31Writing defensive destructors is hard and annoying, and usually if global
32destruction is happening you only need the destructors that free up non
33process local resources to actually execute.
34
35For these constructors you can avoid the mess by simply bailing out if
36global destruction is in effect.
37
38%prep
39%setup -q -n Devel-GlobalDestruction-%{version}
40
41%build
42perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
43make %{?_smp_mflags}
44
45%install
46rm -rf %{buildroot}
47make pure_install DESTDIR=%{buildroot}
48find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
49find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
50find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
51%{_fixperms} %{buildroot}
52
53%check
54make test
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root,-)
61%doc Changes t/
62%if %{noarch_package}
63%{perl_vendorlib}/Devel/
64%else
65%{perl_vendorarch}/auto/Devel/
66%{perl_vendorarch}/Devel/
67%endif
68%{_mandir}/man3/Devel::GlobalDestruction.3pm*
69
70%changelog
71* Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.13-1
72- updated to 0.13
73- built with perl 5.16.3
74
75* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.04-1
76- initial build for Vine Linux
77
78* Fri Jan 13 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
79- Update to 0.04
80  - To detect a perl with ${^GLOBAL_PHASE}, check for the feature itself
81    instead of a specific perl version
82  - Update the documentation to reflect the use of ${^GLOBAL_PHASE} if available
83  - Stop depending on Scope::Guard for the tests
84  - Upgrade ppport.h from version 3.13 to 3.19
85- Drop no-longer-necessary buildreq perl(Scope::Guard)
86- Use DESTDIR rather than PERL_INSTALL_ROOT
87- BR: perl(XSLoader)
88
89* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
90- Fedora 17 mass rebuild
91
92* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-2
93- Perl mass rebuild
94
95* Fri Jun 24 2011 Paul Howarth <paul@city-fan.org> - 0.03-1
96- Update to 0.03
97  - Drop the XS code on perl versions recent enough to have ${^GLOBAL_PHASE}
98    (5.13.7 onwards)
99  - Require at least Perl 5.6
100    - Use XSLoader without a fallback to DynaLoader
101    - Use our instead of use vars
102- This release by FLORA -> update source URL
103- Package is noarch from perl 5.13.7
104- Package Changes file
105- Use %%{?perl_default_filter}
106
107* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-12
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-11
111- Rebuild to fix problems with vendorarch/lib (#661697)
112
113* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-10
114- Mass rebuild with perl-5.12.0
115
116* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-9
117- Mass rebuild with perl-5.12.0
118
119* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.02-8
120- rebuild against perl 5.10.1
121
122* Sun Aug 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.02-7
123- bump
124
125* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-6
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
127
128* Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-5
129- Stripping bad provides of private Perl extension libs
130
131* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-4
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
133
134* Mon Nov 03 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-3
135- bump
136
137* Sat Nov 01 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-2
138- tweak summary
139
140* Sun Oct 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-1
141- clean up for review submission
142
143* Sun Oct 19 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-0.1
144- initial RPM packaging
145- generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)
146
Note: See TracBrowser for help on using the repository browser.