source: projects/specs/trunk/p/perl-DBI/perl-DBI-vl.spec @ 12120

Revision 12120, 6.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define version 1.642
2%define release 1
3
4Summary: A database access API for perl
5Summary(ja): perl 用データベース接続 API
6Name: perl-DBI
7Version: %{version}
8Release: %{release}%{?_dist_release}
9License: GPL or Artistic
10Group: Development/Libraries
11URL:            http://dbi.perl.org/
12Source0:        http://www.cpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  libxcrypt-devel
19BuildRequires:  perl(ExtUtils::MakeMaker)
20# Run-time
21BuildRequires:  perl(base)
22BuildRequires:  perl(constant)
23BuildRequires:  perl(Carp)
24# Clone is optional
25BuildRequires:  perl(Clone)
26BuildRequires:  perl(Coro)
27BuildRequires:  perl(Coro::Handle)
28BuildRequires:  perl(Coro::Select)
29BuildRequires:  perl(Cwd)
30BuildRequires:  perl(Data::Dumper)
31# DB_File is optional
32BuildRequires:  perl(DB_File)
33BuildRequires:  perl(DynaLoader)
34BuildRequires:  perl(Errno)
35BuildRequires:  perl(Exporter)
36BuildRequires:  perl(Fcntl)
37BuildRequires:  perl(File::Basename)
38BuildRequires:  perl(File::Spec)
39BuildRequires:  perl(Getopt::Long)
40BuildRequires:  perl(IO::File)
41BuildRequires:  perl(IO::Select)
42BuildRequires:  perl(IPC::Open3)
43BuildRequires:  perl(Math::BigInt)
44# MLDBM is optional
45##BuildRequires:  perl(MLDBM)
46# RPC::PlClient is optional
47##BuildRequires:  perl(RPC::PlClient) >= 0.2000
48# RPC::PlServer is optional
49##BuildRequires:  perl(RPC::PlServer)
50BuildRequires:  perl(Scalar::Util)
51# SQL::Statement is optional
52BuildRequires:  perl(SQL::Statement)
53BuildRequires:  perl(Storable)
54BuildRequires:  perl(Symbol)
55BuildRequires:  perl(threads)
56BuildRequires:  perl(Tie::Hash)
57BuildRequires:  perl(UNIVERSAL)
58# Tests
59BuildRequires:  perl(Encode)
60BuildRequires:  perl(File::Path)
61BuildRequires:  perl(lib)
62BuildRequires:  perl(Net::Daemon::Test)
63BuildRequires:  perl(Test::More)
64BuildRequires:  perl(Test::Simple)
65# Optional tests
66BuildRequires:  perl(Test::Pod)
67BuildRequires:  perl(Test::Pod::Coverage)
68Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
69Requires:       perl(Math::BigInt)
70
71
72%description 
73DBI is a database access Application Programming Interface (API) for
74the Perl Language. The DBI API Specification defines a set of
75functions, variables and conventions that provide a consistent
76database interface independent of the actual database being used.
77
78%description -l ja
79DBI  Perl でデータベースにアクセスするための API です.
80DBI API では,実際に使われるデータベースに依存しない様に,
81関数,変数などの取り決めが定義されています.
82
83
84%prep
85%setup -q -n DBI-%{version} 
86iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
87  mv lib/DBD/Gofer.pm{.new,}
88chmod 644 ex/*
89chmod 744 dbixs_rev.pl
90sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
91
92
93%build
94perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
95make %{?_smp_mflags}
96
97%install
98[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
99make pure_install PERL_INSTALL_ROOT=%{buildroot}
100find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
101find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
102find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
103chmod -R u+w %{buildroot}/*
104# Remove Win32 specific files and man pages to avoid unwanted dependencies
105rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
106    %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
107perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
108    %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
109
110%clean
111[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
112
113%check
114make test
115
116%files 
117%defattr(-,root,root)
118%doc Changes README.md  ex/
119%{perl_vendorarch}/*.p*
120%{perl_vendorarch}/Bundle/
121%{perl_vendorarch}/DBD/
122%{perl_vendorarch}/DBI/
123%{perl_vendorarch}/auto/DBI/
124%{_bindir}/*
125%{_mandir}/*/*
126
127%changelog
128* Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.642-1
129- updated to 1.642.
130- rebuilt with perl-5.26.
131- added BR:libxcrypt-devel.
132
133* Fri Dec  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.632-1
134- updated to 1.632
135
136* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
137- build with Perl 5.16
138
139* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
140- updated to 1.618; spec revamped
141
142* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
143- rebuild with perl 5.12.3
144- using __perl_requires macro for VineSeed (vl6)
145
146* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
147- spec in utf-8
148
149* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
150- rebuilt with perl-5.10.0.
151
152* Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
153- new upstream release
154
155* Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
156- new upstream release
157
158* Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
159- new upstream release
160
161* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
162- new upstream release
163- changed Group to Development/Libraries
164- installed module files to vendor_perl
165
166* Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
167- use filter-requires-dbi.sh instead of find-requires.perl
168
169* Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
170- new upstream version
171- build on perl-5.8.6-0vl1
172
173* Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
174- new upstream version
175
176* Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
177- update 1.37
178- build with perl-5.8.0
179- add make test
180
181* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
182- updated 1.21
183
184* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
185- updated 1.20
186
187* Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
188- the spec was in Shift-JIS. Fixed.
189
190* Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
191- updated 1.19
192
193* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
194- rebuild on perl-5.6.0
195- changed mandir to /usr/share/man
196- removed version in Requires perl
197
198* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
199- updated perl-DBL-1.15
200
201* Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
202- fixed Vine Linux
203
204* Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
205- Cleanups
206
207* Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
208- build for main distribution
209- use %%{_tmppath}
210- change name of specfile
211- don't use a find script to generate file lists
212- general cleanup
213- add descriptive summary and description
214
215
216* Mon Aug 14 2000 Tim Powers <timp@redhat.com>
217- Spec file was autogenerated. 
Note: See TracBrowser for help on using the repository browser.