source: projects/specs/trunk/p/perl-DBI/perl-DBI-vl.spec @ 12496

Revision 12496, 6.5 KB checked in by tomop, 3 years ago (diff)

updated 6 packages

gnutls-3.6.15-2

grub2-2.04-4

kernel-5.4.66-1

libX11-1.6.12-1

perl-DBI-1.643-1

rsyslog-8.2008.0-2

Line 
1Summary:        A database access API for perl
2Summary(ja):    perl 用データベース接続 API
3Name:           perl-DBI
4Version:        1.643
5Release:        1%{?_dist_release}
6Group:          programming
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        GPL or Artistic
11URL:            https://dbi.perl.org/
12Source0:        https://cpan.metacpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  libxcrypt-devel
16BuildRequires:  perl(ExtUtils::MakeMaker)
17# Run-time
18BuildRequires:  perl(base)
19BuildRequires:  perl(constant)
20BuildRequires:  perl(Carp)
21# Clone is optional
22BuildRequires:  perl(Clone)
23BuildRequires:  perl(Coro)
24BuildRequires:  perl(Coro::Handle)
25BuildRequires:  perl(Coro::Select)
26BuildRequires:  perl(Cwd)
27BuildRequires:  perl(Data::Dumper)
28# DB_File is optional
29BuildRequires:  perl(DB_File)
30BuildRequires:  perl(DynaLoader)
31BuildRequires:  perl(Errno)
32BuildRequires:  perl(Exporter)
33BuildRequires:  perl(Fcntl)
34BuildRequires:  perl(File::Basename)
35BuildRequires:  perl(File::Spec)
36BuildRequires:  perl(Getopt::Long)
37BuildRequires:  perl(IO::File)
38BuildRequires:  perl(IO::Select)
39BuildRequires:  perl(IPC::Open3)
40BuildRequires:  perl(Math::BigInt)
41# MLDBM is optional
42##BuildRequires:  perl(MLDBM)
43# RPC::PlClient is optional
44##BuildRequires:  perl(RPC::PlClient) >= 0.2000
45# RPC::PlServer is optional
46##BuildRequires:  perl(RPC::PlServer)
47BuildRequires:  perl(Scalar::Util)
48# SQL::Statement is optional
49BuildRequires:  perl(SQL::Statement)
50BuildRequires:  perl(Storable)
51BuildRequires:  perl(Symbol)
52BuildRequires:  perl(threads)
53BuildRequires:  perl(Tie::Hash)
54BuildRequires:  perl(UNIVERSAL)
55# Tests
56BuildRequires:  perl(Encode)
57BuildRequires:  perl(File::Path)
58BuildRequires:  perl(lib)
59BuildRequires:  perl(Net::Daemon::Test)
60BuildRequires:  perl(Test::More)
61BuildRequires:  perl(Test::Simple)
62# Optional tests
63BuildRequires:  perl(Test::Pod)
64BuildRequires:  perl(Test::Pod::Coverage)
65Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
66Requires:       perl(Math::BigInt)
67
68%description 
69DBI is a database access Application Programming Interface (API) for
70the Perl Language. The DBI API Specification defines a set of
71functions, variables and conventions that provide a consistent
72database interface independent of the actual database being used.
73
74%description -l ja
75DBI  Perl でデータベースにアクセスするための API です.
76DBI API では,実際に使われるデータベースに依存しない様に,
77関数,変数などの取り決めが定義されています.
78
79
80%debug_package
81
82
83%prep
84%setup -q -n DBI-%{version} 
85iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
86  mv lib/DBD/Gofer.pm{.new,}
87chmod 644 ex/*
88chmod 744 dbixs_rev.pl
89sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
90
91
92%build
93perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
94make %{?_smp_mflags}
95
96
97%install
98[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
99make pure_install PERL_INSTALL_ROOT=%{buildroot}
100find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
101find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
102find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
103chmod -R u+w %{buildroot}/*
104# Remove Win32 specific files and man pages to avoid unwanted dependencies
105rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
106    %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
107perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
108    %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
109
110
111%check
112make test
113
114
115%clean
116[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
117
118
119%files 
120%defattr(-,root,root)
121%doc Changes README.md  ex/
122%{perl_vendorarch}/*.p*
123%{perl_vendorarch}/Bundle/
124%{perl_vendorarch}/DBD/
125%{perl_vendorarch}/DBI/
126%{perl_vendorarch}/auto/DBI/
127%{_bindir}/*
128%{_mandir}/*/*
129
130
131%changelog
132* Sat Sep 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.643-1
133- updated to 1.642.
134
135* Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.642-1
136- updated to 1.642.
137- rebuilt with perl-5.26.
138- added BR:libxcrypt-devel.
139
140* Fri Dec  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.632-1
141- updated to 1.632
142
143* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
144- build with Perl 5.16
145
146* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
147- updated to 1.618; spec revamped
148
149* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
150- rebuild with perl 5.12.3
151- using __perl_requires macro for VineSeed (vl6)
152
153* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
154- spec in utf-8
155
156* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
157- rebuilt with perl-5.10.0.
158
159* Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
160- new upstream release
161
162* Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
163- new upstream release
164
165* Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
166- new upstream release
167
168* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
169- new upstream release
170- changed Group to Development/Libraries
171- installed module files to vendor_perl
172
173* Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
174- use filter-requires-dbi.sh instead of find-requires.perl
175
176* Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
177- new upstream version
178- build on perl-5.8.6-0vl1
179
180* Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
181- new upstream version
182
183* Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
184- update 1.37
185- build with perl-5.8.0
186- add make test
187
188* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
189- updated 1.21
190
191* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
192- updated 1.20
193
194* Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
195- the spec was in Shift-JIS. Fixed.
196
197* Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
198- updated 1.19
199
200* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
201- rebuild on perl-5.6.0
202- changed mandir to /usr/share/man
203- removed version in Requires perl
204
205* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
206- updated perl-DBL-1.15
207
208* Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
209- fixed Vine Linux
210
211* Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
212- Cleanups
213
214* Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
215- build for main distribution
216- use %%{_tmppath}
217- change name of specfile
218- don't use a find script to generate file lists
219- general cleanup
220- add descriptive summary and description
221
222
223* Mon Aug 14 2000 Tim Powers <timp@redhat.com>
224- Spec file was autogenerated. 
Note: See TracBrowser for help on using the repository browser.