source: projects/specs/trunk/p/perl-DBD-SQLite/perl-DBD-SQLite-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define module  DBD-SQLite
2%define name    perl-%{module}
3%define version 1.14
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Self Contained RDBMS in a DBI Driver
10License:        GPL
11URL:            http://search.cpan.org/dist/%{module}/
12Source:         ftp://ftp.perl.org/pub/CPAN/modules/by-module/DBD/%{module}-%{version}.tar.gz
13Group:          Development/Languages
14Requires:       perl(DBI) >= 1.03
15
16BuildRequires:  perl(DBI) >= 1.03
17BuildRequires:  sqlite3-devel   
18Buildroot:      %{_tmppath}/%{name}-%{version}
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%description
24SQLite is a small fast embedded SQL database engine.
25
26DBD::SQLite embeds that database engine into a DBD driver, so
27if you want a relational database for your project, but don't
28want to install a large RDBMS system like MySQL or PostgreSQL,
29then DBD::SQLite may be just what you need.
30
31It supports quite a lot of features, such as transactions (atomic
32commit and rollback), indexes, DBA-free operation, a large subset
33of SQL92 supported, and more.
34
35#'
36%prep
37%setup -q -n %{module}-%{version}
38
39%build
40CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
41%{__make}
42
43# %check
44# %{__make} test
45
46%install
47rm -rf %{buildroot}
48%makeinstall
49rm -f %{buildroot}%{perl_vendorarch}/auto/*/*/.packlist
50
51%clean
52rm -rf %{buildroot}
53
54%files
55%defattr(-,root,root)
56%doc README* Changes
57%{perl_vendorarch}/DBD
58%{perl_vendorarch}/auto/DBD
59%{_mandir}/*/*
60
61%changelog
62* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-1vl5
63- rebuild with perl 5.10
64- new versioning policy
65
66* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl1
67- rebuild for VineSeed
68- disable test
69
70* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.43
71- add Requires: perl(DBI) >= 1.03
72
73* Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.42
74- new upstream release
75- built for Vine 4.2 testing
76
77* Sun Dec 17 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-2mdv2007.0
78+ Revision: 98263
79- fix build dependencies
80
81* Sat Dec 16 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-1mdv2007.1
82+ Revision: 98198
83- new version
84
85* Mon Aug 07 2006 Olivier Thauvin <nanardon@mandriva.org> 1.12-2mdv2007.0
86+ Revision: 53730
87- rebuild
88- Import perl-DBD-SQLite
89
90
91* Thu Apr 13 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.12-1mdk
92- New release 1.12
93- better source URL
94- better buildrequires syntax
95
96* Tue Dec 20 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.11-1mdk
97- new version
98- fix directory ownership
99
100* Mon Sep 26 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.09-2mdk
101- rebuild to link against external library
102- spec cleanup
103- %%mkrel
104
105* Tue Jun 21 2005 Rafael Garcia-Suarez <rgarciasuarez@mandriva.com> 1.09-1mdk
106- 1.09
107- spec cleanups
108
109* Mon Mar 14 2005 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.08-1mdk
110- new veresion 1.08
111
112* Mon Nov 15 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-2mdk
113- rebuild for new perl
114- remove README.urpmi
115
116* Thu Oct 14 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-1mdk
117- 1.07.
118
119* Tue Aug 10 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.03-1mdk
120- 1.03.
121- Remove patch 1.
122
123* Wed Jul 28 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.00-1mdk
124- 1.00, incompatible format with previous versions.
125- Remove MANIFEST, add README.update.urpmi.
126- Patch to prevent interactivity in Makefile.PL
127
128* Mon May 17 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-2mdk
129- Fix compile FLAGS
130
131* Fri Nov 01 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-1mdk
132- first version of rpm.
Note: See TracBrowser for help on using the repository browser.