source: projects/specs/trunk/p/perl-Clone/perl-Clone-vl.spec @ 5744

Revision 5744, 4.5 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Clone
2Version:        0.31
3Release:        1%{?_dist_release}
4Summary:        Recursively copy perl datatypes
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Clone
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RD/RDF/Clone-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11BuildRequires:  perl(ExtUtils::ParseXS), perl(Taint::Runtime), perl(Test::More)
12Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
13
14# don't "provide" private Perl libs
15%global _use_internal_dependency_generator 0
16%global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u
17%global __find_provides /bin/sh -c "%{__grep} -v '%_docdir' | %{__grep} -v '%{perl_vendorarch}/.*\\.so$' | %{__deploop P}"
18%global __find_requires /bin/sh -c "%{__grep} -v '%_docdir' | %{__deploop R}"
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       shaolin
23
24%description
25This module provides a clone() method which makes recursive
26copies of nested hash, array, scalar and reference types,
27including tied variables and objects.
28
29clone() takes a scalar argument and an optional parameter that
30can be used to limit the depth of the copy. To duplicate lists,
31arrays or hashes, pass them in by reference.
32
33%prep
34%setup -q -n Clone-%{version}
35find . -type f -exec chmod -c -x {} ';'
36
37%build
38%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
39make %{?_smp_mflags}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
44find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
45find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
46find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
47chmod -R u+w $RPM_BUILD_ROOT/*
48
49%check
50make test
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root,-)
57%doc Changes
58%{perl_vendorarch}/auto/Clone/
59%{perl_vendorarch}/Clone.pm
60%{_mandir}/man3/*.3*
61
62
63%changelog
64* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.31-1
65- initial build for Vine Linux
66
67* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-9
68- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
69
70* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.31-8
71- Perl mass rebuild
72
73* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-7
74- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
75
76* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-6
77- 661697 rebuild for fixing problems with vendorach/lib
78
79* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-5
80- Mass rebuild with perl-5.12.0
81
82* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.31-4
83- rebuild against perl 5.10.1
84
85* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-3
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
87
88* Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.31-2
89- filter private Perl solibs from provides
90- remove some executable bits -- keep rpmlint happy
91
92* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.31-1
93- update to 0.31
94
95* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
97
98* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.28-4
99- Rebuild for perl 5.10 (again)
100
101* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.28-3
102- Autorebuild for GCC 4.3
103
104* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-2
105- rebuild for new perl
106
107* Wed Nov 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-1
108- bump to 0.28
109
110* Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-2
111- license fix
112
113* Fri Jul 27 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-1
114- bump to 0.27
115
116* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.22-1
117- bump to 0.22
118
119* Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-2
120- bump for fc6
121
122* Fri Mar 31 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-1
123- bump to 0.20
124- new BR: perl-Taint-Runtime
125
126* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-3
127- bump for FC-5
128
129* Fri Jan  6 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-2
130- don't pass optflags twice
131- remove .bs files
132
133* Thu Jan  5 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-1
134- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.