source: projects/specs/trunk/p/perl-Clone/perl-Clone-vl.spec @ 12120

Revision 12120, 4.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Clone
2Version:        0.41
3Release:        1%{?_dist_release}
4Summary:        Recursively copy perl datatypes
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Clone
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RD/RDF/Clone-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires:  libxcrypt-devel
12BuildRequires:  perl(ExtUtils::ParseXS)
13BuildRequires:  perl(Taint::Runtime)
14BuildRequires:  perl(Test::More)
15Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
16
17# don't "provide" private Perl libs
18%global _use_internal_dependency_generator 0
19%global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u
20%global __find_provides /bin/sh -c "%{__grep} -v '%_docdir' | %{__grep} -v '%{perl_vendorarch}/.*\\.so$' | %{__deploop P}"
21%global __find_requires /bin/sh -c "%{__grep} -v '%_docdir' | %{__deploop R}"
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       shaolin
26
27%description
28This module provides a clone() method which makes recursive
29copies of nested hash, array, scalar and reference types,
30including tied variables and objects.
31
32clone() takes a scalar argument and an optional parameter that
33can be used to limit the depth of the copy. To duplicate lists,
34arrays or hashes, pass them in by reference.
35
36%prep
37%setup -q -n Clone-%{version}
38find . -type f -exec chmod -c -x {} ';'
39
40%build
41%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
42make %{?_smp_mflags}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
47find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
48find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
49find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
50chmod -R u+w $RPM_BUILD_ROOT/*
51
52%check
53make test
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(-,root,root,-)
60%doc Changes
61%{perl_vendorarch}/auto/Clone/
62%{perl_vendorarch}/Clone.pm
63%{_mandir}/man3/*.3*
64
65
66%changelog
67* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.41-1
68- new upstream release.
69- rebuilt with perl-5.26.
70- added BR:libxcrypt-devel.
71
72* Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.38-1
73- new upstream release
74
75* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.31-2
76- build with Perl 5.16
77
78* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.31-1
79- initial build for Vine Linux
80
81* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-9
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
83
84* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.31-8
85- Perl mass rebuild
86
87* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-7
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
89
90* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-6
91- 661697 rebuild for fixing problems with vendorach/lib
92
93* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-5
94- Mass rebuild with perl-5.12.0
95
96* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.31-4
97- rebuild against perl 5.10.1
98
99* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-3
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.31-2
103- filter private Perl solibs from provides
104- remove some executable bits -- keep rpmlint happy
105
106* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.31-1
107- update to 0.31
108
109* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
111
112* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.28-4
113- Rebuild for perl 5.10 (again)
114
115* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.28-3
116- Autorebuild for GCC 4.3
117
118* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-2
119- rebuild for new perl
120
121* Wed Nov 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-1
122- bump to 0.28
123
124* Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-2
125- license fix
126
127* Fri Jul 27 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-1
128- bump to 0.27
129
130* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.22-1
131- bump to 0.22
132
133* Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-2
134- bump for fc6
135
136* Fri Mar 31 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-1
137- bump to 0.20
138- new BR: perl-Taint-Runtime
139
140* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-3
141- bump for FC-5
142
143* Fri Jan  6 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-2
144- don't pass optflags twice
145- remove .bs files
146
147* Thu Jan  5 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-1
148- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.