source: projects/specs/trunk/p/perl-Bit-Vector/perl-Bit-Vector-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Efficient bit vector, set of integers and "big int" math library
2Name: perl-Bit-Vector
3Version: 6.4
4Release: 1%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7URL: http://search.cpan.org/~stbey/Bit-Vector/
8Source0: http://www.cpan.org/authors/id/STBEY/Bit-Vector-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: perl >= 0:5.00503
12BuildRequires: perl-Carp-Clan >= 5.3
13Requires: perl
14Requires: perl-Carp-Clan >= 5.3
15Conflicts: perl-Date-Calc < 5.0
16
17%description
18Bit::Vector is an efficient C library which allows you to handle
19bit vectors, sets (of integers), "big integer arithmetic" and
20boolean matrices, all of arbitrary sizes.
21
22The library is efficient (in terms of algorithmical complexity)
23and therefore fast (in terms of execution speed) for instance
24through the widespread use of divide-and-conquer algorithms.
25
26The package also includes an object-oriented Perl module for
27accessing the C library from Perl, and optionally features
28overloaded operators for maximum ease of use.
29
30The C library can nevertheless be used stand-alone, without Perl.
31
32%prep
33%setup -q -n Bit-Vector-%{version}
34
35%build
36CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41make DESTDIR=$RPM_BUILD_ROOT pure_install
42
43find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
44        sed "s@^$RPM_BUILD_ROOT@@g" | \
45        grep -v perllocal.pod | \
46        grep -v %{_mandir} | \
47        grep -v "\.packlist" > Bit-Vector-%{version}-filelist
48if [ "$(cat Bit-Vector-%{version}-filelist)X" = "X" ] ; then
49    echo "ERROR: EMPTY FILE LIST"
50    exit -1
51fi
52install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
53find examples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
54
55%check
56make test
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files -f Bit-Vector-%{version}-filelist
62%defattr(-,root,root)
63%doc CHANGES.txt CREDITS.txt README.txt examples Artistic.txt GNU_GPL.txt GNU_LGPL.txt
64%dir %{perl_vendorarch}/auto/Bit
65%dir %{perl_vendorarch}/auto/Bit/Vector
66%dir %{perl_vendorarch}/Bit
67%dir %{perl_vendorarch}/Bit/Vector
68%{_mandir}/man3/*3pm*
69
70%changelog
71* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4-1
72- new upstream release
73- built with perl-5.10.0
74
75* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 6.4-0vl1
76- new upstream release
77- update Summary and description
78- add Requires: perl-Carp-Clan >= 5.3
79- add some license documents
80
81* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 6.3-0vl1
82- version up to 6.3
83- add directories in %%files section
84- add some documents
85- add Conflicts: perl-Date-Calc < 5.0
86
87* Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 6.1-12vl1
88- build Rawhide-6.1-12 for Vine Linux
89
90* Wed Jan 30 2002 cturner@redhat.com
91- Specfile autogenerated
92
Note: See TracBrowser for help on using the repository browser.