source: projects/specs/trunk/p/perl-Bit-Vector/perl-Bit-Vector-vl.spec @ 12310

Revision 12310, 3.3 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

Line 
1Summary:        Efficient bit vector, set of integers and "big int" math library
2Name:           perl-Bit-Vector
3Version:        7.4
4Release:        1%{?_dist_release}
5Group:          Development/Libraries
6
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        distributable
11URL:            https://metacpan.org/pod/distribution/Bit-Vector/Vector.pod
12Source0:        https://cpan.metacpan.org/authors/id/S/ST/STBEY/Bit-Vector-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  perl
16BuildRequires:  perl(Carp::Clan) >= 5.3
17Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18Requires:       perl(Carp::Clan) >= 5.3
19Conflicts:      perl-Date-Calc < 5.0
20
21%description
22Bit::Vector is an efficient C library which allows you to handle
23bit vectors, sets (of integers), "big integer arithmetic" and
24boolean matrices, all of arbitrary sizes.
25
26The library is efficient (in terms of algorithmical complexity)
27and therefore fast (in terms of execution speed) for instance
28through the widespread use of divide-and-conquer algorithms.
29
30The package also includes an object-oriented Perl module for
31accessing the C library from Perl, and optionally features
32overloaded operators for maximum ease of use.
33
34The C library can nevertheless be used stand-alone, without Perl.
35
36%prep
37%setup -q -n Bit-Vector-%{version}
38
39%build
40CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
41make
42
43%install
44rm -rf $RPM_BUILD_ROOT
45make DESTDIR=$RPM_BUILD_ROOT pure_install
46
47find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
48        sed "s@^$RPM_BUILD_ROOT@@g" | \
49        grep -v perllocal.pod | \
50        grep -v %{_mandir} | \
51        grep -v "\.packlist" > Bit-Vector-%{version}-filelist
52if [ "$(cat Bit-Vector-%{version}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
57find examples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
58
59rm -f %{buildroot}%{perl_vendorarch}/auto/Bit/Vector/.packlist
60
61%check
62make test
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files -f Bit-Vector-%{version}-filelist
68%defattr(-,root,root)
69%license Artistic.txt GNU_GPL.txt GNU_LGPL.txt
70%doc CHANGES.txt CREDITS.txt README.txt examples
71%dir %{perl_vendorarch}/auto/Bit
72%dir %{perl_vendorarch}/auto/Bit/Vector
73%dir %{perl_vendorarch}/Bit
74%dir %{perl_vendorarch}/Bit/Vector
75%{_mandir}/man3/*3pm*
76
77%changelog
78* Thu Oct 31 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4-1
79- new upstream release.
80
81* Sun Jul  6 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 7.3-1
82- build with Perl 5.16
83- update Requires and BuildRequires
84
85* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 7.1-1
86- new upstream release
87- add Vendor and Distribution tags
88
89* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4-1
90- new upstream release
91- built with perl-5.10.0
92
93* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 6.4-0vl1
94- new upstream release
95- update Summary and description
96- add Requires: perl-Carp-Clan >= 5.3
97- add some license documents
98
99* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 6.3-0vl1
100- version up to 6.3
101- add directories in %%files section
102- add some documents
103- add Conflicts: perl-Date-Calc < 5.0
104
105* Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 6.1-12vl1
106- build Rawhide-6.1-12 for Vine Linux
107
108* Wed Jan 30 2002 cturner@redhat.com
109- Specfile autogenerated
110
Note: See TracBrowser for help on using the repository browser.