source: projects/specs/trunk/p/peco/peco-vl.spec @ 11109

Revision 11109, 2.4 KB checked in by iwaim, 7 years ago (diff)

peco 0.5.1-1

RevLine 
[10132]1%define pkg_name    peco
[11109]2%define pkg_version 0.5.1
[10278]3%define pkg_release 1%{?_dist_release}
[9983]4
[9998]5%global gopath %{_datadir}/gocode
6
[10132]7Summary:     Simplistic interactive filtering tool
8Summary(ja): シンプルな対話式フィルタリングツール
9Name:        %{pkg_name}
10Version:     %{pkg_version}
11Release:     %{pkg_release}
[9983]12
[10132]13License: MIT License
14Group:   Applications/Text
15URL:     https://github.com/peco/peco
16Source:  https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
[9983]17
[9989]18BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
19BuildRequires: golang
[9990]20BuildRequires: golang(github.com/google/btree)
21BuildRequires: golang(github.com/mattn/go-runewidth)
22BuildRequires: golang(github.com/jessevdk/go-flags)
23BuildRequires: golang(github.com/nsf/termbox-go)
[11109]24BuildRequires: golang(github.com/pkg/errors)
25BuildRequires: golang(github.com/lestrrat/go-pdebug)
[9989]26
[9983]27Vendor: Project Vine
28Distribution: Vine Linux
[10132]29Packager: ara_t
[9983]30
[10132]31
[9983]32%description
[9989]33peco is a simplistic interactive filtering tool
34based on a python tool, percol, and written in Go.
[9983]35
[9989]36%description -l ja
37pecoはシンプルな対話式フィルタリングツールであり、
38Pyhon製のpercolをGo言語で実装したプログラムです。
39
40
[9983]41%prep
[9989]42%{__rm} -rf ${RPM_BUILD_ROOT}
[9983]43
[9989]44%setup -q
45
[9983]46%build
[9990]47export BUILD_DIR=$(pwd)/.build
48export GOPATH=$BUILD_DIR:%{gopath}
[9983]49
[9990]50%{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
51%{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
[11109]52cd $BUILD_DIR/src/github.com/peco/peco
[9989]53go build cmd/peco/peco.go
54
[9983]55%install
[10132]56%{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
[11109]57export BUILD_DIR=$(pwd)/.build
58cd $BUILD_DIR/src/github.com/peco/peco
[9989]59%{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
[9983]60
[9989]61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
[9983]63
[9989]64
[9983]65%files
[9989]66%defattr(-, root, root)
[9990]67%doc LICENSE
68%doc README.md Changes
[9989]69%{_bindir}/
[9983]70
[9989]71
[9983]72%changelog
[11109]73* Wed Jun 07 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.5.1-1
74- update to 0.5.1
75- update BuildRequires
76
[10278]77* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 0.3.6-1
78- update to 0.3.6
79
[10132]80* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-5
81- correct SPEC file
82
[9998]83* Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
84- defile %%{gopath}
85
[9990]86* Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
87- using golang-* RPM packages for BuildRequires
88 - stop 'go get' in build section
89- update build section
90- add LICENSE, README.md and Changes
91
[9989]92* Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
93- build with Go
94- change spec file
[9983]95
[9989]96* Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
97- new package
98
Note: See TracBrowser for help on using the repository browser.