source: projects/specs/trunk/p/pcsc-lite/pcsc-lite-vl.spec @ 9543

Revision 9543, 10.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Summary:        PC/SC Lite smart card framework and applications
2Summary(ja):    PC/SC Lite スマートカードフレームワークおよびアプリケーション
3
4Name:           pcsc-lite
5Version:        1.8.13
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Daemons
9License:        BSD
10URL:            http://pcsclite.alioth.debian.org/
11Source0:        https://alioth.debian.org/frs/download.php/file/4126/%{name}-%{version}.tar.bz2
12Source1:        org.debian.pcsc-lite.policy
13Patch0:         pcsc-lite-1.8.13-docinst.patch
14Patch1:         pcsc-lite-1.8.13-etc.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18BuildRequires:  eudev-libudev-devel
19BuildRequires:  polkit-devel
20BuildRequires:  doxygen
21BuildRequires:  flex
22Requires(post): initscripts
23Requires(post): /sbin/chkconfig
24Requires(preun): /sbin/chkconfig
25Requires(preun): initscripts
26Requires(postun): initscripts
27Requires:       pcsc-ifd-handler
28# 390 does not have libusb or smartCards
29ExcludeArch: s390 s390x
30
31%description
32The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
33in a very small form factor for communicating to smartcards and
34readers.  PC/SC Lite uses the same winscard API as used under
35Windows(R).  This package includes the PC/SC Lite daemon, a resource
36manager that coordinates communications with smart card readers and
37smart cards that are connected to the system, as well as other command
38line tools.
39
40%package        libs
41Summary:        PC/SC Lite libraries
42Summary(ja):        PC/SC Lite libraries
43Group:          System Environment/Libraries
44Provides:       libpcsc-lite = %{version}-%{release}
45
46%description    libs
47PC/SC Lite libraries.
48
49%package        devel
50Summary:        PC/SC Lite development files
51Summary(ja):        PC/SC Lite development files
52Group:          Development/Libraries
53Requires:       %{name}-libs = %{version}-%{release}
54Requires:       pkgconfig
55Provides:       libpcsc-lite-devel = %{version}-%{release}
56
57%description    devel
58PC/SC Lite development files.
59
60%package        spy
61Summary:        PC/SC API spy
62Summary(ja):        PC/SC API spy
63Group:          Development/Tools
64Requires:       %{name}-libs = %{version}-%{release}
65
66%description    spy
67The purpose of pcsc-spy is to spy all the calls between the PC/SC client
68and the PC/SC library.
69
70%package        doc
71Summary:        PC/SC Lite developer documentation
72Summary(ja):        PC/SC Lite developer documentation
73Group:          Documentation
74
75%description    doc
76%{summary}.
77
78
79%prep
80%setup -q
81%patch0 -p1 -b .docinst
82%patch1 -p1 -b .etc
83
84%build
85autoreconf -if
86%configure \
87  --disable-dependency-tracking \
88  --disable-static \
89  --enable-polkit \
90  --enable-runpid=%{_localstatedir}/run/pcscd.pid \
91  --enable-ipcdir=%{_localstatedir}/run \
92  --enable-usbdropdir=%{_libdir}/pcsc/drivers
93make %{?_smp_mflags}
94doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make install DESTDIR=$RPM_BUILD_ROOT
100rm -f $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/org.debian.pcsc-lite.policy
101
102mkdir -p $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
103install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
104
105install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
106
107install -Dpm 755 etc/pcscd.init $RPM_BUILD_ROOT%{_initrddir}/pcscd
108
109mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
110
111rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
112rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
113
114# formaticc doesn't exist any more, don't include the man page
115rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120
121%post
122/sbin/chkconfig --add pcscd
123
124%preun
125if [ $1 = 0 ] ; then
126  /sbin/service pcscd stop >/dev/null 2>&1 || :
127  /sbin/chkconfig --del pcscd
128fi
129
130%postun
131if [ "$1" -ge "1" ]; then
132  /sbin/service pcscd condrestart >/dev/null 2>&1 || :
133fi
134
135%post libs -p /sbin/ldconfig
136
137%postun libs -p /sbin/ldconfig
138
139
140%files
141%defattr(-,root,root,-)
142%doc AUTHORS ChangeLog* COPYING DRIVERS HELP README SECURITY TODO READ
143%dir %{_sysconfdir}/reader.conf.d/
144%{_initrddir}/pcscd
145%{_sbindir}/pcscd
146%{_libdir}/pcsc/
147%{_datadir}/polkit-1/actions/org.debian.%{name}.policy
148%{_mandir}/man5/reader.conf.5*
149%{_mandir}/man8/pcscd.8*
150
151%files libs
152%defattr(-,root,root,-)
153%{_libdir}/libpcsclite.so.*
154%{_libdir}/libpcscspy.so.*
155
156%files devel
157%defattr(-,root,root,-)
158%{_includedir}/PCSC/
159%{_libdir}/libpcsclite.so
160%{_libdir}/libpcscspy.so
161%{_libdir}/pkgconfig/libpcsclite.pc
162
163%files spy
164%defattr(-,root,root,-)
165%{_bindir}/pcsc-spy
166%{_mandir}/man1/pcsc-spy.1.gz
167
168%files doc
169%defattr(-,root,root,-)
170%doc doc/api/ doc/example/pcsc_demo.c
171%{_docdir}/pcsc-lite/README.polkit
172
173
174%changelog
175* Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.13-1
176- new upstream release
177- updata Patch0 (pcsc-lite-1.8.13-docinst.patch)
178- updata Patch1 (pcsc-lite-1.8.13-etc.patch)
179- add Source1 from fedora
180- add BuildRequires: polkit-devel
181
182* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-2
183- change BuildRequires: eudev-libudev-devel instead of libudev-devel
184
185* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
186- new upstream release
187- add Patch1 (pcsc-lite-1.8.3-etc.patch)
188- create -spy sub package
189
190* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
191- fix Patch1
192
193* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
194- new upstream release
195- remove BuildRequires: hal-devel, libusb-devel
196- add BuildRequires: libudev-devel, flex
197- add Patch1 (pcsc-lite-1.8.1-etc.patch)
198
199* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
200- rebuilt with rpm-4.8.1 for pkg-config
201
202* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
203- new upstream release
204
205* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
206- initial build for Vine Linux
207
208* Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
209- bump tag becaue the build system can't deal with mistakes.
210
211* Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
212- mock build changes
213
214* Sun Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
215- Pick up 1.4.102
216
217* Tue May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
218- Pick up 1.4.101
219
220* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
221- Autorebuild for GCC 4.3
222
223* Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
224- Silence libpcsc-lite even when the daemon isn't running.
225- fix typo in init file which prevents the config file from being read.
226
227* Thu Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
228- Pick up 1.4.4
229
230* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
231- Pick up 1.3.3
232
233* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
234- Pick up 1.3.2
235
236* Thu Sep 14 2006  Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
237- Incorporate patch from Ludovic to stop the pcsc daemon from
238  unnecessarily waking up.
239
240* Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
241- follow packaging guidelines for setting up init service
242  (bug 200778)
243
244* Mon Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
245- start pcscd when pcsc-lite is installed
246
247* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
248- fix excludearch line
249
250* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
251- rebuild
252
253* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
254- remove s390 from the build
255
256* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
257- Move to Fedora Core.
258- Remove dependency on graphviz.
259- Removed %%{_dist}
260
261* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
262- 1.3.1.
263
264* Sun Mar  5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
265- 1.3.0, init script and reader.conf updater included upstream.
266- Split developer docs into a -doc subpackage, include API docs.
267- libmusclecard no longer included, split into separate package upstream.
268
269* Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
270- Avoid standard rpaths on multilib archs.
271- Fine tune dependencies.
272
273* Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
274- Don't ship static libraries.
275- Don't mark the init script as a config file.
276- Use rm instead of %%exclude.
277- Specfile cleanups.
278
279* Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
280- Rebuild.
281
282* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
283- rebuilt
284
285* Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
286- Disable dependency tracking to speed up the build.
287- Drop reader.conf patch, it's not needed any more.
288- Rename update-reader-conf to update-reader.conf for consistency with Debian,
289  and improve it a bit.
290
291* Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
292- Add update-reader-conf, thanks to Fritz Elfert.
293
294* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
295- Own the %%{_libdir}/pcsc hierarchy.
296
297* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
298- Make main package require pcsc-ifd-handler (idea from Debian).
299
300* Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
301- Improve package summary.
302- Improvements based on suggestions from Ludovic Rousseau:
303  - Don't install pcsc_demo but do include its source in -devel.
304  - Sync reader.conf with current upstream CVS HEAD (better docs, less
305    intrusive in USB-only setups where it's not needed).
306
307* Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
308- Move PDF API docs to -devel.
309- Improve main package and init script descriptions.
310
311* Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
312- Init script fine tuning.
313
314* Fri Jan  9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
315- BuildRequires libusb-devel 0.1.6 or newer.
316
317* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
318- s/pkgconfi/pkgconfig/ in -devel requirements.
319
320* Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
321- Update to 1.2.0.
322- Add libpcsc-lite and libmusclecard provides to -libs and -devel.
323
324* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
325- Update to 1.2.0-rc3.
326- Trivial init script improvements.
327- Enable %%{_smp_mflags}.
328- Don't bother trying to enable SCF.
329
330* Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
331- Specfile cleanups.
332
333* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
334- Update to 1.2.0-rc2.
335
336* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
337- Update to 1.2.0-rc1.
338
339* Sun Jun  1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
340- Update to 1.1.2beta5.
341
342* Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
343- First build, based on PLD's 1.1.1-2.
Note: See TracBrowser for help on using the repository browser.