source: projects/specs/trunk/p/pcsc-lite/pcsc-lite-vl.spec @ 12522

Revision 12522, 11.9 KB checked in by tomop, 3 years ago (diff)

updated 16 packages

SDL2-2.0.14-1

gmp-6.2.1-1

gnupg2-2.2.27-1

gnutls-3.7.0-1

golang-1.15.7-1

iputils-20210202-1

libassuan-2.5.4-1

libgcrypt-1.9.1-1

libgpg-error-1.41-1

libksba-1.5.0-1

libusb1-1.0.24-1

nettle-3.7-1

npth-1.6-2

pcsc-lite-1.9.0-1

python3-3.8.7-1

tcpdump-4.9.3-2

Line 
1%bcond_with systemd
2
3Summary:        PC/SC Lite smart card framework and applications
4Summary(ja):    PC/SC Lite スマートカードフレームワークおよびアプリケーション
5
6Name:           pcsc-lite
7Version:        1.9.0
8Release:        1%{?_dist_release}%{?with_systemd:.systemd}
9Group:          system
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        BSD
14URL:            https://pcsclite.apdu.fr/
15Source0:        https://pcsclite.apdu.fr/files/%{name}-%{version}.tar.bz2
16Source1:        org.debian.pcsc-lite.policy
17Source2:        pcscd.init
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires:  polkit-devel
22BuildRequires:  doxygen
23BuildRequires:  flex
24BuildRequires:  python3
25BuildRequires:  python3-rpm-macros
26Requires:       pcsc-ifd-handler
27%if %{with systemd}
28BuildRequires:  systemd-devel
29%{?systemd_requires}
30%else
31BuildRequires:  eudev-libudev-devel
32Requires(post): initscripts
33Requires(post): /sbin/chkconfig
34Requires(preun): /sbin/chkconfig
35Requires(preun): initscripts
36Requires(postun): initscripts
37%endif
38# 390 does not have libusb or smartCards
39ExcludeArch: s390 s390x
40
41%description
42The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
43in a very small form factor for communicating to smartcards and
44readers.  PC/SC Lite uses the same winscard API as used under
45Windows(R).  This package includes the PC/SC Lite daemon, a resource
46manager that coordinates communications with smart card readers and
47smart cards that are connected to the system, as well as other command
48line tools.
49
50
51%package        libs
52Summary:        PC/SC Lite libraries
53Summary(ja):    PC/SC Lite libraries
54Group:          system
55Provides:       libpcsc-lite = %{version}-%{release}
56
57%description    libs
58PC/SC Lite libraries.
59
60
61%package        devel
62Summary:        PC/SC Lite development files
63Summary(ja):    PC/SC Lite development files
64Group:          programming
65Requires:       %{name}-libs = %{version}-%{release}
66Requires:       pkgconfig
67Provides:       libpcsc-lite-devel = %{version}-%{release}
68
69%description    devel
70PC/SC Lite development files.
71
72
73%package        spy
74Summary:        PC/SC API spy
75Summary(ja):    PC/SC API spy
76Group:          programming
77Requires:       %{name}-libs = %{version}-%{release}
78Requires:       python3
79
80%description    spy
81The purpose of pcsc-spy is to spy all the calls between the PC/SC client
82and the PC/SC library.
83
84
85%package        doc
86Summary:        PC/SC Lite developer documentation
87Summary(ja):    PC/SC Lite developer documentation
88Group:          documentation
89
90%description    doc
91%{summary}.
92
93
94%debug_package
95
96
97%prep
98%setup -q
99
100# Convert to utf-8
101for file in ChangeLog; do
102    iconv -f ISO-8859-1 -t UTF-8 -o $file.new $file && \
103    touch -r $file $file.new && \
104    mv $file.new $file
105done
106
107
108%build
109#autoreconf -if
110%configure \
111  --disable-dependency-tracking \
112  --disable-static \
113%if !%{with systemd}
114  --disable-libsystemd \
115%endif
116  --enable-polkit \
117  --enable-runpid=%{_localstatedir}/run/pcscd.pid \
118  --enable-ipcdir=%{_localstatedir}/run \
119  --enable-usbdropdir=%{_libdir}/pcsc/drivers
120make %{?_smp_mflags}
121doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
122
123%{_libdir}/python%{python3_version}/Tools/scripts/pathfix.py -i "%{__python3} %{py3_shbang_opts}" -p src/spy/pcsc-spy
124
125
126%install
127rm -rf $RPM_BUILD_ROOT
128make install DESTDIR=$RPM_BUILD_ROOT
129rm -f $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/org.debian.pcsc-lite.policy
130
131mkdir -p $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
132install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
133
134install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
135
136%if !%{with systemd}
137install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/pcscd
138%endif
139
140mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
141
142rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
143rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
144
145# formaticc doesn't exist any more, don't include the man page
146#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151
152%post
153%if %{with systemd}
154%systemd_post pcscd.socket pcscd.service
155# If install, test if pcscd socket is enabled.
156# If enabled, then attempt to start it. This will silently fail
157# in chroots or other environments where services aren't expected
158# to be started.
159if [ $1 -eq 1 ] ; then
160   if systemctl -q is-enabled pcscd.socket > /dev/null 2>&1 ; then
161      systemctl start pcscd.socket > /dev/null 2>&1 || :
162   fi
163fi
164%else
165/sbin/chkconfig --add pcscd
166%endif
167
168%preun
169%if %{with systemd}
170%systemd_preun pcscd.socket pcscd.service
171%else
172if [ $1 = 0 -o -x /bin/systemctl ] ; then
173  /sbin/service pcscd stop >/dev/null 2>&1 || :
174  /sbin/chkconfig --del pcscd
175fi
176%endif
177
178%postun
179%if %{with systemd}
180%systemd_postun_with_restart pcscd.socket pcscd.service
181%else
182if [ "$1" -ge "1" ]; then
183  /sbin/service pcscd condrestart >/dev/null 2>&1 || :
184fi
185%endif
186
187%post libs -p /sbin/ldconfig
188%postun libs -p /sbin/ldconfig
189
190
191%files
192%defattr(-,root,root,-)
193%license COPYING
194%doc AUTHORS ChangeLog HELP README SECURITY TODO
195%dir %{_sysconfdir}/reader.conf.d/
196%if %{with systemd}
197%{_unitdir}/pcscd.service
198%{_unitdir}/pcscd.socket
199%{_sbindir}/pcscd
200%else
201%{_initrddir}/pcscd
202%endif
203%{_sbindir}/pcscd
204%{_libdir}/pcsc/
205%{_datadir}/polkit-1/actions/org.debian.%{name}.policy
206%{_mandir}/man5/reader.conf.5*
207%{_mandir}/man8/pcscd.8*
208
209%files libs
210%defattr(-,root,root,-)
211%license COPYING
212%{_libdir}/libpcsclite.so.*
213%{_libdir}/libpcscspy.so.*
214
215%files devel
216%defattr(-,root,root,-)
217%{_includedir}/PCSC/
218%{_libdir}/libpcsclite.so
219%{_libdir}/libpcscspy.so
220%{_libdir}/pkgconfig/libpcsclite.pc
221
222%files spy
223%defattr(-,root,root,-)
224%{_bindir}/pcsc-spy
225%{_mandir}/man1/pcsc-spy.1*
226
227%files doc
228%defattr(-,root,root,-)
229%doc doc/api/ doc/example/pcsc_demo.c
230%{_docdir}/pcsc-lite/README.polkit
231
232
233%changelog
234* Tue Feb 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.0-1
235- new upstream release.
236- added systemd support (disabled as default).
237
238* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.25-1
239- new upstream release.
240
241* Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.13-1
242- new upstream release
243- updata Patch0 (pcsc-lite-1.8.13-docinst.patch)
244- updata Patch1 (pcsc-lite-1.8.13-etc.patch)
245- add Source1 from fedora
246- add BuildRequires: polkit-devel
247
248* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-2
249- change BuildRequires: eudev-libudev-devel instead of libudev-devel
250
251* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
252- new upstream release
253- add Patch1 (pcsc-lite-1.8.3-etc.patch)
254- create -spy sub package
255
256* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
257- fix Patch1
258
259* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
260- new upstream release
261- remove BuildRequires: hal-devel, libusb-devel
262- add BuildRequires: libudev-devel, flex
263- add Patch1 (pcsc-lite-1.8.1-etc.patch)
264
265* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
266- rebuilt with rpm-4.8.1 for pkg-config
267
268* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
269- new upstream release
270
271* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
272- initial build for Vine Linux
273
274* Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
275- bump tag becaue the build system can't deal with mistakes.
276
277* Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
278- mock build changes
279
280* Sun Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
281- Pick up 1.4.102
282
283* Tue May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
284- Pick up 1.4.101
285
286* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
287- Autorebuild for GCC 4.3
288
289* Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
290- Silence libpcsc-lite even when the daemon isn't running.
291- fix typo in init file which prevents the config file from being read.
292
293* Thu Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
294- Pick up 1.4.4
295
296* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
297- Pick up 1.3.3
298
299* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
300- Pick up 1.3.2
301
302* Thu Sep 14 2006  Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
303- Incorporate patch from Ludovic to stop the pcsc daemon from
304  unnecessarily waking up.
305
306* Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
307- follow packaging guidelines for setting up init service
308  (bug 200778)
309
310* Mon Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
311- start pcscd when pcsc-lite is installed
312
313* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
314- fix excludearch line
315
316* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
317- rebuild
318
319* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
320- remove s390 from the build
321
322* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
323- Move to Fedora Core.
324- Remove dependency on graphviz.
325- Removed %%{_dist}
326
327* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
328- 1.3.1.
329
330* Sun Mar  5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
331- 1.3.0, init script and reader.conf updater included upstream.
332- Split developer docs into a -doc subpackage, include API docs.
333- libmusclecard no longer included, split into separate package upstream.
334
335* Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
336- Avoid standard rpaths on multilib archs.
337- Fine tune dependencies.
338
339* Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
340- Don't ship static libraries.
341- Don't mark the init script as a config file.
342- Use rm instead of %%exclude.
343- Specfile cleanups.
344
345* Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
346- Rebuild.
347
348* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
349- rebuilt
350
351* Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
352- Disable dependency tracking to speed up the build.
353- Drop reader.conf patch, it's not needed any more.
354- Rename update-reader-conf to update-reader.conf for consistency with Debian,
355  and improve it a bit.
356
357* Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
358- Add update-reader-conf, thanks to Fritz Elfert.
359
360* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
361- Own the %%{_libdir}/pcsc hierarchy.
362
363* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
364- Make main package require pcsc-ifd-handler (idea from Debian).
365
366* Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
367- Improve package summary.
368- Improvements based on suggestions from Ludovic Rousseau:
369  - Don't install pcsc_demo but do include its source in -devel.
370  - Sync reader.conf with current upstream CVS HEAD (better docs, less
371    intrusive in USB-only setups where it's not needed).
372
373* Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
374- Move PDF API docs to -devel.
375- Improve main package and init script descriptions.
376
377* Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
378- Init script fine tuning.
379
380* Fri Jan  9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
381- BuildRequires libusb-devel 0.1.6 or newer.
382
383* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
384- s/pkgconfi/pkgconfig/ in -devel requirements.
385
386* Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
387- Update to 1.2.0.
388- Add libpcsc-lite and libmusclecard provides to -libs and -devel.
389
390* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
391- Update to 1.2.0-rc3.
392- Trivial init script improvements.
393- Enable %%{_smp_mflags}.
394- Don't bother trying to enable SCF.
395
396* Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
397- Specfile cleanups.
398
399* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
400- Update to 1.2.0-rc2.
401
402* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
403- Update to 1.2.0-rc1.
404
405* Sun Jun  1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
406- Update to 1.1.2beta5.
407
408* Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
409- First build, based on PLD's 1.1.1-2.
Note: See TracBrowser for help on using the repository browser.