source: projects/specs/trunk/p/pcsc-lite/pcsc-lite-vl.spec @ 6424

Revision 6424, 9.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Summary:        PC/SC Lite smart card framework and applications
2Summary(ja):    PC/SC Lite スマートカードフレームワークおよびアプリケーション
3
4Name:           pcsc-lite
5Version:        1.8.3
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Daemons
9License:        BSD
10URL:            http://pcsclite.alioth.debian.org/
11Source0:        http://alioth.debian.org/download.php/2106/%{name}-%{version}.tar.bz2
12Patch0:         %{name}-1.4-docinst.patch
13Patch1:         pcsc-lite-1.8.3-etc.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  libudev-devel
18BuildRequires:  doxygen
19BuildRequires:  flex
20Requires(post): initscripts
21Requires(post): /sbin/chkconfig
22Requires(preun): /sbin/chkconfig
23Requires(preun): initscripts
24Requires(postun): initscripts
25Requires:       pcsc-ifd-handler
26# 390 does not have libusb or smartCards
27ExcludeArch: s390 s390x
28
29%description
30The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
31in a very small form factor for communicating to smartcards and
32readers.  PC/SC Lite uses the same winscard API as used under
33Windows(R).  This package includes the PC/SC Lite daemon, a resource
34manager that coordinates communications with smart card readers and
35smart cards that are connected to the system, as well as other command
36line tools.
37
38%package        libs
39Summary:        PC/SC Lite libraries
40Summary(ja):        PC/SC Lite libraries
41Group:          System Environment/Libraries
42Provides:       libpcsc-lite = %{version}-%{release}
43
44%description    libs
45PC/SC Lite libraries.
46
47%package        devel
48Summary:        PC/SC Lite development files
49Summary(ja):        PC/SC Lite development files
50Group:          Development/Libraries
51Requires:       %{name}-libs = %{version}-%{release}
52Requires:       pkgconfig
53Provides:       libpcsc-lite-devel = %{version}-%{release}
54
55%description    devel
56PC/SC Lite development files.
57
58%package        spy
59Summary:        PC/SC API spy
60Summary(ja):        PC/SC API spy
61Group:          Development/Tools
62Requires:       %{name}-libs = %{version}-%{release}
63
64%description    spy
65The purpose of pcsc-spy is to spy all the calls between the PC/SC client
66and the PC/SC library.
67
68%package        doc
69Summary:        PC/SC Lite developer documentation
70Summary(ja):        PC/SC Lite developer documentation
71Group:          Documentation
72
73%description    doc
74%{summary}.
75
76
77%prep
78%setup -q
79%patch0 -p0 -b .docinst
80%patch1 -p1 -b .etc
81
82%build
83autoreconf -if
84%configure \
85  --disable-dependency-tracking \
86  --disable-static \
87  --enable-runpid=%{_localstatedir}/run/pcscd.pid \
88  --enable-ipcdir=%{_localstatedir}/run \
89  --enable-usbdropdir=%{_libdir}/pcsc/drivers
90make %{?_smp_mflags}
91doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96make install DESTDIR=$RPM_BUILD_ROOT
97
98install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
99
100install -Dpm 755 etc/pcscd.init $RPM_BUILD_ROOT%{_initrddir}/pcscd
101
102mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
103
104rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
105rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
106
107# formaticc doesn't exist any more, don't include the man page
108rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%post
115/sbin/chkconfig --add pcscd
116
117%preun
118if [ $1 = 0 ] ; then
119  /sbin/service pcscd stop >/dev/null 2>&1 || :
120  /sbin/chkconfig --del pcscd
121fi
122
123%postun
124if [ "$1" -ge "1" ]; then
125  /sbin/service pcscd condrestart >/dev/null 2>&1 || :
126fi
127
128%post libs -p /sbin/ldconfig
129
130%postun libs -p /sbin/ldconfig
131
132
133%files
134%defattr(-,root,root,-)
135%doc AUTHORS ChangeLog* COPYING DRIVERS HELP README SECURITY TODO
136%dir %{_sysconfdir}/reader.conf.d/
137%{_initrddir}/pcscd
138%{_sbindir}/pcscd
139%{_libdir}/pcsc/
140%{_mandir}/man5/reader.conf.5*
141%{_mandir}/man8/pcscd.8*
142
143%files libs
144%defattr(-,root,root,-)
145%{_libdir}/libpcsclite.so.*
146%{_libdir}/libpcscspy.so.*
147
148%files devel
149%defattr(-,root,root,-)
150%{_includedir}/PCSC/
151%{_libdir}/libpcsclite.so
152%{_libdir}/libpcscspy.so
153%{_libdir}/pkgconfig/libpcsclite.pc
154
155%files spy
156%defattr(-,root,root,-)
157%{_bindir}/pcsc-spy
158%{_mandir}/man1/pcsc-spy.1.gz
159
160%files doc
161%defattr(-,root,root,-)
162%doc doc/api/ doc/example/pcsc_demo.c
163
164
165%changelog
166* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
167- new upstream release
168- add Patch1 (pcsc-lite-1.8.3-etc.patch)
169- create -spy sub package
170
171* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
172- fix Patch1
173
174* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
175- new upstream release
176- remove BuildRequires: hal-devel, libusb-devel
177- add BuildRequires: libudev-devel, flex
178- add Patch1 (pcsc-lite-1.8.1-etc.patch)
179
180* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
181- rebuilt with rpm-4.8.1 for pkg-config
182
183* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
184- new upstream release
185
186* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
187- initial build for Vine Linux
188
189* Thu Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
190- bump tag becaue the build system can't deal with mistakes.
191
192* Thu Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
193- mock build changes
194
195* Wed Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
196- Pick up 1.4.102
197
198* Wed May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
199- Pick up 1.4.101
200
201* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
202- Autorebuild for GCC 4.3
203
204* Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
205- Silence libpcsc-lite even when the daemon isn't running.
206- fix typo in init file which prevents the config file from being read.
207
208* Tue Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
209- Pick up 1.4.4
210
211* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
212- Pick up 1.3.3
213
214* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
215- Pick up 1.3.2
216
217* Thu Sep 14 2006  Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
218- Incorporate patch from Ludovic to stop the pcsc daemon from
219  unnecessarily waking up.
220
221* Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
222- follow packaging guidelines for setting up init service
223  (bug 200778)
224
225* Sun Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
226- start pcscd when pcsc-lite is installed
227
228* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
229- fix excludearch line
230
231* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
232- rebuild
233
234* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
235- remove s390 from the build
236
237* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
238- Move to Fedora Core.
239- Remove dependency on graphviz.
240- Removed %%{_dist}
241
242* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
243- 1.3.1.
244
245* Sun Mar  5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
246- 1.3.0, init script and reader.conf updater included upstream.
247- Split developer docs into a -doc subpackage, include API docs.
248- libmusclecard no longer included, split into separate package upstream.
249
250* Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
251- Avoid standard rpaths on multilib archs.
252- Fine tune dependencies.
253
254* Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
255- Don't ship static libraries.
256- Don't mark the init script as a config file.
257- Use rm instead of %%exclude.
258- Specfile cleanups.
259
260* Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
261- Rebuild.
262
263* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
264- rebuilt
265
266* Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
267- Disable dependency tracking to speed up the build.
268- Drop reader.conf patch, it's not needed any more.
269- Rename update-reader-conf to update-reader.conf for consistency with Debian,
270  and improve it a bit.
271
272* Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
273- Add update-reader-conf, thanks to Fritz Elfert.
274
275* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
276- Own the %%{_libdir}/pcsc hierarchy.
277
278* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
279- Make main package require pcsc-ifd-handler (idea from Debian).
280
281* Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
282- Improve package summary.
283- Improvements based on suggestions from Ludovic Rousseau:
284  - Don't install pcsc_demo but do include its source in -devel.
285  - Sync reader.conf with current upstream CVS HEAD (better docs, less
286    intrusive in USB-only setups where it's not needed).
287
288* Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
289- Move PDF API docs to -devel.
290- Improve main package and init script descriptions.
291
292* Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
293- Init script fine tuning.
294
295* Fri Jan  9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
296- BuildRequires libusb-devel 0.1.6 or newer.
297
298* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
299- s/pkgconfi/pkgconfig/ in -devel requirements.
300
301* Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
302- Update to 1.2.0.
303- Add libpcsc-lite and libmusclecard provides to -libs and -devel.
304
305* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
306- Update to 1.2.0-rc3.
307- Trivial init script improvements.
308- Enable %%{_smp_mflags}.
309- Don't bother trying to enable SCF.
310
311* Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
312- Specfile cleanups.
313
314* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
315- Update to 1.2.0-rc2.
316
317* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
318- Update to 1.2.0-rc1.
319
320* Sun Jun  1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
321- Update to 1.1.2beta5.
322
323* Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
324- First build, based on PLD's 1.1.1-2.
Note: See TracBrowser for help on using the repository browser.