source: projects/specs/trunk/p/pcsc-lite/pcsc-lite-vl.spec @ 5362

Revision 5362, 9.2 KB checked in by Takemikaduchi, 12 years ago (diff)

fix patch

Line 
1Summary:        PC/SC Lite smart card framework and applications
2Summary(ja):    PC/SC Lite スマートカードフレームワークおよびアプリケーション
3
4Name:           pcsc-lite
5Version:        1.8.1
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Daemons
9License:        BSD
10URL:            http://pcsclite.alioth.debian.org/
11Source0:        http://alioth.debian.org/download.php/2106/%{name}-%{version}.tar.bz2
12Patch0:         %{name}-1.4-docinst.patch
13Patch1:         pcsc-lite-1.8.1-etc.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  libudev-devel
18BuildRequires:  doxygen
19BuildRequires:  flex
20Requires(post): initscripts
21Requires(post): /sbin/chkconfig
22Requires(preun): /sbin/chkconfig
23Requires(preun): initscripts
24Requires(postun): initscripts
25Requires:       pcsc-ifd-handler
26# 390 does not have libusb or smartCards
27ExcludeArch: s390 s390x
28
29%description
30The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
31in a very small form factor for communicating to smartcards and
32readers.  PC/SC Lite uses the same winscard API as used under
33Windows(R).  This package includes the PC/SC Lite daemon, a resource
34manager that coordinates communications with smart card readers and
35smart cards that are connected to the system, as well as other command
36line tools.
37
38%package        libs
39Summary:        PC/SC Lite libraries
40Summary(ja):        PC/SC Lite libraries
41Group:          System Environment/Libraries
42Provides:       libpcsc-lite = %{version}-%{release}
43
44%description    libs
45PC/SC Lite libraries.
46
47%package        devel
48Summary:        PC/SC Lite development files
49Summary(ja):        PC/SC Lite development files
50Group:          Development/Libraries
51Requires:       %{name}-libs = %{version}-%{release}
52Requires:       pkgconfig
53Provides:       libpcsc-lite-devel = %{version}-%{release}
54
55%description    devel
56PC/SC Lite development files.
57
58%package        doc
59Summary:        PC/SC Lite developer documentation
60Summary(ja):        PC/SC Lite developer documentation
61Group:          Documentation
62
63%description    doc
64%{summary}.
65
66
67%prep
68%setup -q
69%patch0 -p0 -b .docinst
70%patch1 -p1 -b .etc
71
72%build
73autoreconf -if
74%configure \
75  --disable-dependency-tracking \
76  --disable-static \
77  --enable-runpid=%{_localstatedir}/run/pcscd.pid \
78  --enable-ipcdir=%{_localstatedir}/run \
79  --enable-usbdropdir=%{_libdir}/pcsc/drivers
80make %{?_smp_mflags}
81doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
82
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87
88install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
89
90install -Dpm 755 etc/pcscd.init $RPM_BUILD_ROOT%{_initrddir}/pcscd
91
92mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
93
94rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
95rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
96
97# formaticc doesn't exist any more, don't include the man page
98rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103
104%post
105/sbin/chkconfig --add pcscd
106
107%preun
108if [ $1 = 0 ] ; then
109  /sbin/service pcscd stop >/dev/null 2>&1 || :
110  /sbin/chkconfig --del pcscd
111fi
112
113%postun
114if [ "$1" -ge "1" ]; then
115  /sbin/service pcscd condrestart >/dev/null 2>&1 || :
116fi
117
118%post libs -p /sbin/ldconfig
119
120%postun libs -p /sbin/ldconfig
121
122
123%files
124%defattr(-,root,root,-)
125%doc AUTHORS ChangeLog* COPYING DRIVERS HELP README SECURITY TODO
126%dir %{_sysconfdir}/reader.conf.d/
127%{_initrddir}/pcscd
128%{_sbindir}/pcscd
129%{_libdir}/pcsc/
130%{_mandir}/man5/reader.conf.5*
131%{_mandir}/man8/pcscd.8*
132
133%files libs
134%defattr(-,root,root,-)
135%{_libdir}/libpcsclite.so.*
136%{_libdir}/libpcscspy.so.*
137
138%files devel
139%defattr(-,root,root,-)
140%{_includedir}/PCSC/
141%{_libdir}/libpcsclite.so
142%{_libdir}/libpcscspy.so
143%{_libdir}/pkgconfig/libpcsclite.pc
144
145%files doc
146%defattr(-,root,root,-)
147%doc doc/api/ doc/example/pcsc_demo.c
148
149
150%changelog
151* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
152- fix Patch1
153
154* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
155- new upstream release
156- remove BuildRequires: hal-devel, libusb-devel
157- add BuildRequires: libudev-devel, flex
158- add Patch1 (pcsc-lite-1.8.1-etc.patch)
159
160* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
161- rebuilt with rpm-4.8.1 for pkg-config
162
163* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
164- new upstream release
165
166* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
167- initial build for Vine Linux
168
169* Thu Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
170- bump tag becaue the build system can't deal with mistakes.
171
172* Thu Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
173- mock build changes
174
175* Wed Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
176- Pick up 1.4.102
177
178* Wed May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
179- Pick up 1.4.101
180
181* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
182- Autorebuild for GCC 4.3
183
184* Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
185- Silence libpcsc-lite even when the daemon isn't running.
186- fix typo in init file which prevents the config file from being read.
187
188* Tue Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
189- Pick up 1.4.4
190
191* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
192- Pick up 1.3.3
193
194* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
195- Pick up 1.3.2
196
197* Thu Sep 14 2006  Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
198- Incorporate patch from Ludovic to stop the pcsc daemon from
199  unnecessarily waking up.
200
201* Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
202- follow packaging guidelines for setting up init service
203  (bug 200778)
204
205* Sun Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
206- start pcscd when pcsc-lite is installed
207
208* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
209- fix excludearch line
210
211* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
212- rebuild
213
214* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
215- remove s390 from the build
216
217* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
218- Move to Fedora Core.
219- Remove dependency on graphviz.
220- Removed %%{_dist}
221
222* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
223- 1.3.1.
224
225* Sun Mar  5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
226- 1.3.0, init script and reader.conf updater included upstream.
227- Split developer docs into a -doc subpackage, include API docs.
228- libmusclecard no longer included, split into separate package upstream.
229
230* Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
231- Avoid standard rpaths on multilib archs.
232- Fine tune dependencies.
233
234* Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
235- Don't ship static libraries.
236- Don't mark the init script as a config file.
237- Use rm instead of %%exclude.
238- Specfile cleanups.
239
240* Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
241- Rebuild.
242
243* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
244- rebuilt
245
246* Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
247- Disable dependency tracking to speed up the build.
248- Drop reader.conf patch, it's not needed any more.
249- Rename update-reader-conf to update-reader.conf for consistency with Debian,
250  and improve it a bit.
251
252* Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
253- Add update-reader-conf, thanks to Fritz Elfert.
254
255* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
256- Own the %%{_libdir}/pcsc hierarchy.
257
258* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
259- Make main package require pcsc-ifd-handler (idea from Debian).
260
261* Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
262- Improve package summary.
263- Improvements based on suggestions from Ludovic Rousseau:
264  - Don't install pcsc_demo but do include its source in -devel.
265  - Sync reader.conf with current upstream CVS HEAD (better docs, less
266    intrusive in USB-only setups where it's not needed).
267
268* Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
269- Move PDF API docs to -devel.
270- Improve main package and init script descriptions.
271
272* Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
273- Init script fine tuning.
274
275* Fri Jan  9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
276- BuildRequires libusb-devel 0.1.6 or newer.
277
278* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
279- s/pkgconfi/pkgconfig/ in -devel requirements.
280
281* Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
282- Update to 1.2.0.
283- Add libpcsc-lite and libmusclecard provides to -libs and -devel.
284
285* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
286- Update to 1.2.0-rc3.
287- Trivial init script improvements.
288- Enable %%{_smp_mflags}.
289- Don't bother trying to enable SCF.
290
291* Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
292- Specfile cleanups.
293
294* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
295- Update to 1.2.0-rc2.
296
297* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
298- Update to 1.2.0-rc1.
299
300* Sun Jun  1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
301- Update to 1.1.2beta5.
302
303* Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
304- First build, based on PLD's 1.1.1-2.
Note: See TracBrowser for help on using the repository browser.