source: projects/specs/trunk/p/pcsc-lite/pcsc-lite-vl.spec @ 521

Revision 521, 9.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        PC/SC Lite smart card framework and applications
2Summary(ja):    PC/SC Lite スマートカードフレームワークおよびアプリケーション
3
4Name:           pcsc-lite
5Version:        1.5.5
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Daemons
9License:        BSD
10URL:            http://pcsclite.alioth.debian.org/
11Source0:        http://alioth.debian.org/download.php/2106/%{name}-%{version}.tar.bz2
12Patch0:         %{name}-1.4-docinst.patch
13Patch1:         %{name}-1.5.5-rpath64.patch
14Patch2:         %{name}-close_on_exec.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18BuildRequires:  libusb-devel >= 0.1.7
19BuildRequires:  hal-devel
20BuildRequires:  doxygen
21Requires(post): initscripts
22Requires(post): /sbin/chkconfig
23Requires(preun): /sbin/chkconfig
24Requires(preun): initscripts
25Requires(postun): initscripts
26Requires:       pcsc-ifd-handler
27# 390 does not have libusb or smartCards
28ExcludeArch: s390 s390x
29
30%description
31The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
32in a very small form factor for communicating to smartcards and
33readers.  PC/SC Lite uses the same winscard API as used under
34Windows(R).  This package includes the PC/SC Lite daemon, a resource
35manager that coordinates communications with smart card readers and
36smart cards that are connected to the system, as well as other command
37line tools.
38
39%package        libs
40Summary:        PC/SC Lite libraries
41Summary(ja):        PC/SC Lite libraries
42Group:          System Environment/Libraries
43Provides:       libpcsc-lite = %{version}-%{release}
44
45%description    libs
46PC/SC Lite libraries.
47
48%package        devel
49Summary:        PC/SC Lite development files
50Summary(ja):        PC/SC Lite development files
51Group:          Development/Libraries
52Requires:       %{name}-libs = %{version}-%{release}
53Requires:       pkgconfig
54Provides:       libpcsc-lite-devel = %{version}-%{release}
55
56%description    devel
57PC/SC Lite development files.
58
59%package        doc
60Summary:        PC/SC Lite developer documentation
61Summary(ja):        PC/SC Lite developer documentation
62Group:          Documentation
63
64%description    doc
65%{summary}.
66
67
68%prep
69%setup -q
70%patch0 -p0 -b .docinst
71%patch1 -p1 -b .rpath64
72%patch2 -p1 -b .close_on_exec
73
74%build
75%configure \
76  --disable-dependency-tracking \
77  --disable-static \
78  --enable-runpid=%{_localstatedir}/run/pcscd.pid \
79  --enable-confdir=%{_sysconfdir} \
80  --enable-ipcdir=%{_localstatedir}/run \
81  --enable-usbdropdir=%{_libdir}/pcsc/drivers
82make %{?_smp_mflags}
83doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
84
85
86%install
87rm -rf $RPM_BUILD_ROOT
88make install DESTDIR=$RPM_BUILD_ROOT
89
90install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
91
92install -Dpm 755 etc/pcscd.init $RPM_BUILD_ROOT%{_initrddir}/pcscd
93
94cat <<EOF > $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d/README
95All *.conf files in this directory are merged into %{_sysconfdir}/reader.conf
96by %{_sbindir}/update-reader.conf.
97EOF
98
99rm $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
100touch $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf
101
102# formaticc doesn't exist any more, don't include the man page
103rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
104
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109
110%post
111/sbin/chkconfig --add pcscd
112
113%preun
114if [ $1 = 0 ] ; then
115  /sbin/service pcscd stop >/dev/null 2>&1 || :
116  /sbin/chkconfig --del pcscd
117fi
118
119%postun
120if [ "$1" -ge "1" ]; then
121  /sbin/service pcscd condrestart >/dev/null 2>&1 || :
122fi
123
124%post libs -p /sbin/ldconfig
125
126%postun libs -p /sbin/ldconfig
127
128
129%files
130%defattr(-,root,root,-)
131%doc AUTHORS ChangeLog* COPYING DRIVERS HELP README SECURITY TODO
132%dir %{_sysconfdir}/reader.conf.d/
133%doc %{_sysconfdir}/reader.conf.d/README
134%ghost %config %{_sysconfdir}/reader.conf
135%{_initrddir}/pcscd
136%{_sbindir}/pcscd
137%{_sbindir}/update-reader.conf
138%{_libdir}/pcsc/
139%{_mandir}/man5/reader.conf.5*
140%{_mandir}/man8/pcscd.8*
141%{_mandir}/man8/update-reader.conf.8*
142
143%files libs
144%defattr(-,root,root,-)
145%{_libdir}/libpcsclite.so.*
146
147%files devel
148%defattr(-,root,root,-)
149%{_includedir}/PCSC/
150%{_libdir}/libpcsclite.so
151%{_libdir}/pkgconfig/libpcsclite.pc
152
153%files doc
154%defattr(-,root,root,-)
155%doc doc/api/ doc/example/pcsc_demo.c
156
157
158%changelog
159* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
160- new upstream release
161
162* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
163- initial build for Vine Linux
164
165* Thu Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
166- bump tag becaue the build system can't deal with mistakes.
167
168* Thu Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
169- mock build changes
170
171* Wed Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
172- Pick up 1.4.102
173
174* Wed May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
175- Pick up 1.4.101
176
177* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
178- Autorebuild for GCC 4.3
179
180* Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
181- Silence libpcsc-lite even when the daemon isn't running.
182- fix typo in init file which prevents the config file from being read.
183
184* Tue Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
185- Pick up 1.4.4
186
187* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
188- Pick up 1.3.3
189
190* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
191- Pick up 1.3.2
192
193* Thu Sep 14 2006  Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
194- Incorporate patch from Ludovic to stop the pcsc daemon from
195  unnecessarily waking up.
196
197* Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
198- follow packaging guidelines for setting up init service
199  (bug 200778)
200
201* Sun Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
202- start pcscd when pcsc-lite is installed
203
204* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
205- fix excludearch line
206
207* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
208- rebuild
209
210* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
211- remove s390 from the build
212
213* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
214- Move to Fedora Core.
215- Remove dependency on graphviz.
216- Removed %%{_dist}
217
218* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
219- 1.3.1.
220
221* Sun Mar  5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
222- 1.3.0, init script and reader.conf updater included upstream.
223- Split developer docs into a -doc subpackage, include API docs.
224- libmusclecard no longer included, split into separate package upstream.
225
226* Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
227- Avoid standard rpaths on multilib archs.
228- Fine tune dependencies.
229
230* Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
231- Don't ship static libraries.
232- Don't mark the init script as a config file.
233- Use rm instead of %%exclude.
234- Specfile cleanups.
235
236* Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
237- Rebuild.
238
239* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
240- rebuilt
241
242* Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
243- Disable dependency tracking to speed up the build.
244- Drop reader.conf patch, it's not needed any more.
245- Rename update-reader-conf to update-reader.conf for consistency with Debian,
246  and improve it a bit.
247
248* Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
249- Add update-reader-conf, thanks to Fritz Elfert.
250
251* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
252- Own the %%{_libdir}/pcsc hierarchy.
253
254* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
255- Make main package require pcsc-ifd-handler (idea from Debian).
256
257* Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
258- Improve package summary.
259- Improvements based on suggestions from Ludovic Rousseau:
260  - Don't install pcsc_demo but do include its source in -devel.
261  - Sync reader.conf with current upstream CVS HEAD (better docs, less
262    intrusive in USB-only setups where it's not needed).
263
264* Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
265- Move PDF API docs to -devel.
266- Improve main package and init script descriptions.
267
268* Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
269- Init script fine tuning.
270
271* Fri Jan  9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
272- BuildRequires libusb-devel 0.1.6 or newer.
273
274* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
275- s/pkgconfi/pkgconfig/ in -devel requirements.
276
277* Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
278- Update to 1.2.0.
279- Add libpcsc-lite and libmusclecard provides to -libs and -devel.
280
281* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
282- Update to 1.2.0-rc3.
283- Trivial init script improvements.
284- Enable %%{_smp_mflags}.
285- Don't bother trying to enable SCF.
286
287* Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
288- Specfile cleanups.
289
290* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
291- Update to 1.2.0-rc2.
292
293* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
294- Update to 1.2.0-rc1.
295
296* Sun Jun  1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
297- Update to 1.1.2beta5.
298
299* Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
300- First build, based on PLD's 1.1.1-2.
Note: See TracBrowser for help on using the repository browser.