source: projects/specs/trunk/p/pcsc-lite/pcsc-lite-vl.spec @ 12299

Revision 12299, 10.9 KB checked in by tomop, 5 years ago (diff)

updated 15 packages

ant-1.9.14-1

ccid-1.4.31-1

extra-cmake-modules-5.63.0-1

file-5.37-2

iputils-20190709-1

libarchive-3.4.0-1

libidn2-2.2.0-1

libmodsecurity-3.0.3-4

libxslt-1.1.33-2

ncurses-6.1-3

pcsc-lite-1.8.25-1

polkit-qt-0.112.0-3

qca2-2.2.1-1

rdesktop-1.9.0-1

util-linux-2.34-1

Line 
1Summary:        PC/SC Lite smart card framework and applications
2Summary(ja):    PC/SC Lite スマートカードフレームワークおよびアプリケーション
3
4Name:           pcsc-lite
5Version:        1.8.25
6Release:        1%{?_dist_release}
7Group:          System Environment/Daemons
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        BSD
13URL:            https://pcsclite.apdu.fr/
14Source0:        https://pcsclite.apdu.fr/files/%{name}-%{version}.tar.bz2
15Source1:        org.debian.pcsc-lite.policy
16Source2:        pcscd.init
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19
20BuildRequires:  eudev-libudev-devel
21BuildRequires:  polkit-devel
22BuildRequires:  doxygen
23BuildRequires:  flex
24BuildRequires:  python3
25BuildRequires:  python3-rpm-macros
26Requires(post): initscripts
27Requires(post): /sbin/chkconfig
28Requires(preun): /sbin/chkconfig
29Requires(preun): initscripts
30Requires(postun): initscripts
31Requires:       pcsc-ifd-handler
32# 390 does not have libusb or smartCards
33ExcludeArch: s390 s390x
34
35%description
36The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
37in a very small form factor for communicating to smartcards and
38readers.  PC/SC Lite uses the same winscard API as used under
39Windows(R).  This package includes the PC/SC Lite daemon, a resource
40manager that coordinates communications with smart card readers and
41smart cards that are connected to the system, as well as other command
42line tools.
43
44%package        libs
45Summary:        PC/SC Lite libraries
46Summary(ja):        PC/SC Lite libraries
47Group:          System Environment/Libraries
48Provides:       libpcsc-lite = %{version}-%{release}
49
50%description    libs
51PC/SC Lite libraries.
52
53%package        devel
54Summary:        PC/SC Lite development files
55Summary(ja):        PC/SC Lite development files
56Group:          Development/Libraries
57Requires:       %{name}-libs = %{version}-%{release}
58Requires:       pkgconfig
59Provides:       libpcsc-lite-devel = %{version}-%{release}
60
61%description    devel
62PC/SC Lite development files.
63
64%package        spy
65Summary:        PC/SC API spy
66Summary(ja):        PC/SC API spy
67Group:          Development/Tools
68Requires:       %{name}-libs = %{version}-%{release}
69Requires:       python3
70
71%description    spy
72The purpose of pcsc-spy is to spy all the calls between the PC/SC client
73and the PC/SC library.
74
75%package        doc
76Summary:        PC/SC Lite developer documentation
77Summary(ja):        PC/SC Lite developer documentation
78Group:          Documentation
79
80%description    doc
81%{summary}.
82
83
84%prep
85%setup -q
86
87# Convert to utf-8
88for file in ChangeLog; do
89    iconv -f ISO-8859-1 -t UTF-8 -o $file.new $file && \
90    touch -r $file $file.new && \
91    mv $file.new $file
92done
93
94
95%build
96#autoreconf -if
97%configure \
98  --disable-dependency-tracking \
99  --disable-static \
100  --disable-libsystemd \
101  --enable-polkit \
102  --enable-runpid=%{_localstatedir}/run/pcscd.pid \
103  --enable-ipcdir=%{_localstatedir}/run \
104  --enable-usbdropdir=%{_libdir}/pcsc/drivers
105make %{?_smp_mflags}
106doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
107
108%{_libdir}/python3.5/Tools/scripts/pathfix.py -i "%{__python3} %{py3_shbang_opts}" -p src/spy/pcsc-spy
109
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install DESTDIR=$RPM_BUILD_ROOT
114rm -f $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/org.debian.pcsc-lite.policy
115
116mkdir -p $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
117install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
118
119install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
120
121install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/pcscd
122
123mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
124
125rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
126rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
127
128# formaticc doesn't exist any more, don't include the man page
129#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134
135%post
136/sbin/chkconfig --add pcscd
137
138%preun
139if [ $1 = 0 ] ; then
140  /sbin/service pcscd stop >/dev/null 2>&1 || :
141  /sbin/chkconfig --del pcscd
142fi
143
144%postun
145if [ "$1" -ge "1" ]; then
146  /sbin/service pcscd condrestart >/dev/null 2>&1 || :
147fi
148
149%post libs -p /sbin/ldconfig
150
151%postun libs -p /sbin/ldconfig
152
153
154%files
155%defattr(-,root,root,-)
156%license COPYING
157%doc AUTHORS ChangeLog HELP README SECURITY TODO
158%dir %{_sysconfdir}/reader.conf.d/
159%{_initrddir}/pcscd
160%{_sbindir}/pcscd
161%{_libdir}/pcsc/
162%{_datadir}/polkit-1/actions/org.debian.%{name}.policy
163%{_mandir}/man5/reader.conf.5*
164%{_mandir}/man8/pcscd.8*
165
166%files libs
167%defattr(-,root,root,-)
168%license COPYING
169%{_libdir}/libpcsclite.so.*
170%{_libdir}/libpcscspy.so.*
171
172%files devel
173%defattr(-,root,root,-)
174%{_includedir}/PCSC/
175%{_libdir}/libpcsclite.so
176%{_libdir}/libpcscspy.so
177%{_libdir}/pkgconfig/libpcsclite.pc
178
179%files spy
180%defattr(-,root,root,-)
181%{_bindir}/pcsc-spy
182%{_mandir}/man1/pcsc-spy.1*
183
184%files doc
185%defattr(-,root,root,-)
186%doc doc/api/ doc/example/pcsc_demo.c
187%{_docdir}/pcsc-lite/README.polkit
188
189
190%changelog
191* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.25-1
192- new upstream release.
193
194* Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.13-1
195- new upstream release
196- updata Patch0 (pcsc-lite-1.8.13-docinst.patch)
197- updata Patch1 (pcsc-lite-1.8.13-etc.patch)
198- add Source1 from fedora
199- add BuildRequires: polkit-devel
200
201* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-2
202- change BuildRequires: eudev-libudev-devel instead of libudev-devel
203
204* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
205- new upstream release
206- add Patch1 (pcsc-lite-1.8.3-etc.patch)
207- create -spy sub package
208
209* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
210- fix Patch1
211
212* Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
213- new upstream release
214- remove BuildRequires: hal-devel, libusb-devel
215- add BuildRequires: libudev-devel, flex
216- add Patch1 (pcsc-lite-1.8.1-etc.patch)
217
218* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
219- rebuilt with rpm-4.8.1 for pkg-config
220
221* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
222- new upstream release
223
224* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
225- initial build for Vine Linux
226
227* Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
228- bump tag becaue the build system can't deal with mistakes.
229
230* Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
231- mock build changes
232
233* Sun Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
234- Pick up 1.4.102
235
236* Tue May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
237- Pick up 1.4.101
238
239* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
240- Autorebuild for GCC 4.3
241
242* Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
243- Silence libpcsc-lite even when the daemon isn't running.
244- fix typo in init file which prevents the config file from being read.
245
246* Thu Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
247- Pick up 1.4.4
248
249* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
250- Pick up 1.3.3
251
252* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
253- Pick up 1.3.2
254
255* Thu Sep 14 2006  Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
256- Incorporate patch from Ludovic to stop the pcsc daemon from
257  unnecessarily waking up.
258
259* Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
260- follow packaging guidelines for setting up init service
261  (bug 200778)
262
263* Mon Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
264- start pcscd when pcsc-lite is installed
265
266* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
267- fix excludearch line
268
269* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
270- rebuild
271
272* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
273- remove s390 from the build
274
275* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
276- Move to Fedora Core.
277- Remove dependency on graphviz.
278- Removed %%{_dist}
279
280* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
281- 1.3.1.
282
283* Sun Mar  5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
284- 1.3.0, init script and reader.conf updater included upstream.
285- Split developer docs into a -doc subpackage, include API docs.
286- libmusclecard no longer included, split into separate package upstream.
287
288* Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
289- Avoid standard rpaths on multilib archs.
290- Fine tune dependencies.
291
292* Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
293- Don't ship static libraries.
294- Don't mark the init script as a config file.
295- Use rm instead of %%exclude.
296- Specfile cleanups.
297
298* Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
299- Rebuild.
300
301* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
302- rebuilt
303
304* Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
305- Disable dependency tracking to speed up the build.
306- Drop reader.conf patch, it's not needed any more.
307- Rename update-reader-conf to update-reader.conf for consistency with Debian,
308  and improve it a bit.
309
310* Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
311- Add update-reader-conf, thanks to Fritz Elfert.
312
313* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
314- Own the %%{_libdir}/pcsc hierarchy.
315
316* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
317- Make main package require pcsc-ifd-handler (idea from Debian).
318
319* Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
320- Improve package summary.
321- Improvements based on suggestions from Ludovic Rousseau:
322  - Don't install pcsc_demo but do include its source in -devel.
323  - Sync reader.conf with current upstream CVS HEAD (better docs, less
324    intrusive in USB-only setups where it's not needed).
325
326* Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
327- Move PDF API docs to -devel.
328- Improve main package and init script descriptions.
329
330* Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
331- Init script fine tuning.
332
333* Fri Jan  9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
334- BuildRequires libusb-devel 0.1.6 or newer.
335
336* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
337- s/pkgconfi/pkgconfig/ in -devel requirements.
338
339* Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
340- Update to 1.2.0.
341- Add libpcsc-lite and libmusclecard provides to -libs and -devel.
342
343* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
344- Update to 1.2.0-rc3.
345- Trivial init script improvements.
346- Enable %%{_smp_mflags}.
347- Don't bother trying to enable SCF.
348
349* Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
350- Specfile cleanups.
351
352* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
353- Update to 1.2.0-rc2.
354
355* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
356- Update to 1.2.0-rc1.
357
358* Sun Jun  1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
359- Update to 1.1.2beta5.
360
361* Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
362- First build, based on PLD's 1.1.1-2.
Note: See TracBrowser for help on using the repository browser.