source: projects/specs/trunk/p/pciutils/pciutils-vl.spec @ 8243

Revision 8243, 10.6 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        PCI bus related utilities.
3Summary(ja):    Linux PCI ユーティリティ
4Name:           pciutils
5Version:        3.2.1
6Release:        1%{?_dist_release}
7License:        GPLv2+
8URL:            http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
9Group:          Applications/System
10
11Source:         %{name}-%{version}.tar.gz
12Patch2:         pciutils-2.1.10-scan.patch
13Patch3:         pciutils-havepread.patch
14Patch6:         pciutils-2.2.1-idpath.patch
15Patch8:         pciutils-3.0.2-multilib.patch
16Patch9:         pciutils-dir-d.patch
17Patch10:        pciutils-2.2.10-sparc-support.patch
18Patch11:        pciutils-3.0.1-superh-support.patch
19
20Buildroot:      %{_tmppath}/%{name}-%{version}-root
21ExclusiveOS:    Linux
22BuildRequires:  sed
23Requires:       hwdata
24Requires:       %{name}-libs = %{version}-%{release}
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The pciutils package contains various utilities for inspecting and
31setting devices connected to the PCI bus. The utilities provided
32require kernel version 2.1.82 or newer (which support the
33/proc/bus/pci interface).
34
35%description -l ja
36このパッケージには PCI バスに接続された各種デバイスの状態を見たり
37設定したりする為のユーティリティが収められています.
38このパッケージに収められたユーティリティはカーネル 2.1.82 以降
39(/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
40
41%package devel
42Summary: Linux PCI development library.
43Summary(ja):    Linux PCI 開発ライブラリ
44Group: Development/Libraries
45Requires: %{name}-libs = %{version}-%{release}
46
47%description devel
48This package contains a library for inspecting and setting
49devices connected to the PCI bus.
50
51%description devel -l ja
52このパッケージには PCI バスに接続された各種デバイスの状態を見たり
53設定したりするのに必要なライブラリが収められています.
54
55%package libs
56Summary: Linux PCI library
57Summary(ja): Linux PCI ライブラリ
58Group: System Environment/Libraries
59
60%description libs
61This package contains a library for inspecting and setting
62devices connected to the PCI bus.
63
64%package static
65Summary: Linux PCI satic library
66Summary(ja): Linux PCI スタッティックライブラリ
67Group: System Environment/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71This package contains a library for inspecting and setting
72devices connected to the PCI bus.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}-libs
76Summary: Linux PCI library.
77Group: Development/Libraries
78Requires: compat32-%{name}-devel = %{version}-%{release}
79%description -n compat32-%{name}-libs
80This package contains a library for inspecting and setting
81devices connected to the PCI bus.
82
83%package -n compat32-%{name}-devel
84Summary: Linux PCI development library.
85Group: Development/Libraries
86%description -n compat32-%{name}-devel
87This package contains a library for inspecting and setting
88devices connected to the PCI bus.
89
90%prep
91%setup -q -n pciutils-%{version}
92%patch2 -p1 -b .scan
93%patch3 -p1 -b .pread
94%patch6 -p1 -b .idpath
95%patch8 -p1 -b .multilib
96%patch9 -p1 -b .dird
97%patch10 -p1 -b .sparc
98%patch11 -p1 -b .superh
99
100sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
101
102%build
103make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
104mv lib/libpci.a lib/libpci.a.toinstall
105
106make clean
107
108make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
109
110#fix lib vs. lib64 in libpci.pc (static Makefile is used)
111sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
112
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
118
119install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
120install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
121install -p  lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
122ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
123
124mv lib/libpci.a.toinstall lib/libpci.a
125install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
126/sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
127install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
128install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
129install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
130install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
131install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
132
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138%post -n compat32-%{name}-libs -p /sbin/ldconfig
139
140%postun -n compat32-%{name}-libs -p /sbin/ldconfig
141
142
143%files
144%defattr(0644, root, root, 0755)
145%{_mandir}/man8/*
146%attr(0755, root, root) /sbin/*
147%doc README ChangeLog pciutils.lsm
148
149%files devel
150%defattr(0644, root, root, 0755)
151%{_libdir}/libpci.so
152%{_libdir}/pkgconfig/libpci.pc
153%{_includedir}/pci
154
155%files libs
156%defattr(0644, root, root, 0755)
157%{_libdir}/libpci.so.*
158
159%files static
160%defattr(0644, root, root, 0755)
161%{_libdir}/libpci.a
162
163%if %{build_compat32}
164%files -n compat32-%{name}-devel
165%defattr(0644, root, root, 0755)
166%{_libdir}/libpci.so
167%{_libdir}/pkgconfig/libpci.pc
168%{_includedir}/pci
169
170%files -n compat32-%{name}-libs
171%defattr(0644, root, root, 0755)
172%{_libdir}/libpci.so.*
173%endif
174
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179
180%changelog
181* Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
182- new upstream release
183
184* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
185- new upstream release
186
187* Sun Oct 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.8-1
188- new upstream release
189- remove Patch1 (pciutils-2.2.4-buf.patch)
190
191* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
192- rebuilt with rpm-4.8.1 for pkg-config
193
194* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-3
195- add Requires: %{name}-libs = %{version}-%{release} (devel package)
196
197* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
198- removed %%if !%%{build_compat32} case condition
199
200* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
201- new upstream release
202- add shared library
203- split shared library to -libs
204- split static library to -static
205
206* Fri Nov  7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
207- new upstream release
208
209* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
210- new upstream release
211
212* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
213- applied new versioning policy, spec in utf-8
214
215* Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
216- new upstream release
217
218* Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
219- rebuilt for x86_64 architecture support
220- added compat32-* packages for x86_64 architecture support
221
222* Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
223- updated to 2.2.1 based on fedora package
224  * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
225  - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
226  * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
227  - remove explicit kernel dep (#146153)
228
229* Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
230- use hwdata for pci.ids database.
231- merged with rawhide package.
232  - update to 2.1.10
233  - fix dir perms on /usr/include/pci
234  - don't forcibly strip binaries
235  - require hwdata now that pci.ids is there
236  - man page is now owned by root
237
238* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
239- based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
240
241* Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
242- dump all the patches, ship pci.ids direct out of sourceforge CVS
243
244* Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
245- broadcom bcm5820 id (#53592)
246
247* Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
248- more ids
249
250* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
251- add newline in printf in PCI-X patch (#49277)
252
253* Mon Jul  9 2001 Bill Nottingham <notting@redhat.com>
254- update broadcom patch
255- add new ids from 2.4.6
256
257* Mon May 28 2001 Bill Nottingham <notting@redhat.com>
258- add a couple of e1000 ids
259
260* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
261- another megaraid id
262
263* Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
264- another megaraid id
265
266* Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
267- LSI SCSI PCI id
268
269* Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
270- fix formatting problems
271
272* Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
273- add IBM ServeRAID entries
274
275* Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
276- i860 entries.
277
278* Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
279- added various pci ids
280
281* Fri Feb  2 2001 Bill Nottingham <notting@redhat.com>
282- fix mishap in fixing mishap
283
284* Thu Feb  1 2001 Bill Nottingham <notting@redhat.com>
285- fix apparent mishap in pci.ids update from kernel (#25520)
286
287* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
288- pci.ids updates
289
290* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
291- big pile of pci.ids updates
292
293* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
294- clean up patches to not generate badly-formatted files
295
296* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
297- Vortex fixes laroche originally applied on kudzu moved here.
298
299* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
300- pci ids for i815, new ati hardware
301
302* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
303- automatic rebuild
304
305* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
306- yet more IDs
307- PCI-X support from Matt Domsch
308
309* Fri Jul  7 2000 Bill Nottingham <notting@redhat.com>
310- some more QLogic ids
311
312* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
313- more IDs from Dell
314
315* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
316- update to 2.1.8
317
318* Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
319- update to 2.1.7
320
321* Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
322- update to 2.1.6
323
324* Fri Mar  3 2000 Bill Nottingham <notting@redhat.com>
325- add a couple of ids
326
327* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
328- update to 2.1.5
329
330* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
331- handle compressed man pages
332
333* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
334- update to 2.1.4
335
336* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
337- update to 2.1.3
338
339* Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
340- update to 2.1.2
341
342* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
343- add -devel package
344
345* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
346- update to 2.0
347
348* Mon Apr 19 1999 Jakub Jelinek  <jj@ultra.linux.cz>
349- update to 1.99.5
350- fix sparc64 operation
351
352* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
353- auto rebuild in the new build environment (release 2)
354
355* Thu Feb  4 1999 Bill Nottingham <notting@redhat.com>
356- initial build
Note: See TracBrowser for help on using the repository browser.