source: projects/specs/trunk/p/pciutils/pciutils-vl.spec @ 12370

Revision 12370, 11.2 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

dosfstools-4.1-1

fontconfig-2.13.1-1

gd-2.3.0-1

itstool-2.0.6-1

logrotate-3.16.0-1

ntfs-3g-2017.3.23-1

pciutils-3.6.4-1

redis-5.0.8-1

shared-mime-info-1.15-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        PCI bus related utilities.
3Summary(ja):    Linux PCI ユーティリティ
4Name:           pciutils
5Version:        3.6.4
6Release:        1%{?_dist_release}
7Group:          Applications/System
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        GPLv2+
12URL:            http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
13Source:         https://mirrors.edge.kernel.org/pub/software/utils/pciutils/pciutils-%{version}.tar.xz
14
15#change pci.ids directory to hwdata, fedora/rhel specific
16Patch1:         pciutils-2.2.1-idpath.patch
17
18#add support for directory with another pci.ids, rejected by upstream, rhbz#195327
19Patch2:         pciutils-dir-d.patch
20
21Buildroot:      %{_tmppath}/%{name}-%{version}-root
22ExclusiveOS:    Linux
23BuildRequires:  sed
24Requires:       hwdata
25Requires:       %{name}-libs = %{version}-%{release}
26
27%global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
28
29%description
30The pciutils package contains various utilities for inspecting and
31setting devices connected to the PCI bus. The utilities provided
32require kernel version 2.1.82 or newer (which support the
33/proc/bus/pci interface).
34
35%description -l ja
36このパッケージには PCI バスに接続された各種デバイスの状態を見たり
37設定したりする為のユーティリティが収められています.
38このパッケージに収められたユーティリティはカーネル 2.1.82 以降
39(/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
40
41%package devel
42Summary: Linux PCI development library.
43Summary(ja):    Linux PCI 開発ライブラリ
44Group: Development/Libraries
45Requires: %{name}-libs = %{version}-%{release}
46Provides: pkgconfig(libpci) = %{version}
47
48%description devel
49This package contains a library for inspecting and setting
50devices connected to the PCI bus.
51
52%description devel -l ja
53このパッケージには PCI バスに接続された各種デバイスの状態を見たり
54設定したりするのに必要なライブラリが収められています.
55
56%package libs
57Summary: Linux PCI library
58Summary(ja): Linux PCI ライブラリ
59Group: System Environment/Libraries
60
61%description libs
62This package contains a library for inspecting and setting
63devices connected to the PCI bus.
64
65%package static
66Summary: Linux PCI satic library
67Summary(ja): Linux PCI スタッティックライブラリ
68Group: System Environment/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72This package contains a library for inspecting and setting
73devices connected to the PCI bus.
74
75## to build compat32 for x86_64 architecture support
76%package -n compat32-%{name}-libs
77Summary: Linux PCI library.
78Group: Development/Libraries
79Requires: compat32-%{name}-devel = %{version}-%{release}
80%description -n compat32-%{name}-libs
81This package contains a library for inspecting and setting
82devices connected to the PCI bus.
83
84%package -n compat32-%{name}-devel
85Summary: Linux PCI development library.
86Group: Development/Libraries
87%description -n compat32-%{name}-devel
88This package contains a library for inspecting and setting
89devices connected to the PCI bus.
90
91%prep
92%setup -q -n pciutils-%{version}
93%autopatch -p1
94
95sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
96
97%build
98make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
99mv lib/libpci.a lib/libpci.a.toinstall
100
101make clean
102
103make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
104
105#fix lib vs. lib64 in libpci.pc (static Makefile is used)
106sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
107
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
113
114install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
115install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
116install -p  lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
117ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
118
119mv lib/libpci.a.toinstall lib/libpci.a
120install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
121/sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
122install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
123install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
124install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
125install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
126install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
127
128
129%post libs -p /sbin/ldconfig
130
131%postun libs -p /sbin/ldconfig
132
133%post -n compat32-%{name}-libs -p /sbin/ldconfig
134
135%postun -n compat32-%{name}-libs -p /sbin/ldconfig
136
137
138%files
139%defattr(-,root,root,-)
140%{_mandir}/man8/*
141%attr(0755, root, root) /sbin/*
142%license COPYING
143%doc README ChangeLog pciutils.lsm
144
145%files devel
146%defattr(-,root,root,-)
147%{_libdir}/libpci.so
148%{_libdir}/pkgconfig/libpci.pc
149%{_includedir}/pci
150
151%files libs
152%defattr(-,root,root,-)
153%{_libdir}/libpci.so.*
154
155%files static
156%defattr(-,root,root,-)
157%{_libdir}/libpci.a
158
159%if %{build_compat32}
160%files -n compat32-%{name}-devel
161%defattr(-,root,root,-)
162%{_libdir}/libpci.so
163%{_libdir}/pkgconfig/libpci.pc
164%{_includedir}/pci
165
166%files -n compat32-%{name}-libs
167%defattr(-,root,root,-)
168%{_libdir}/libpci.so.*
169%endif
170
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175
176%changelog
177* Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
178- new upstream release.
179- dropped all patches.
180- imported Patch0-2 from rawhide.
181
182* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
183- new upstream release
184
185* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
186- new upstream release
187
188* Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
189- new upstream release
190- update Patch3 (pciutils-havepread.patch)
191
192* Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
193- new upstream release
194- update Patch8 (pciutils-3.3.0-multilib.patch)
195
196* Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
197- new upstream release
198
199* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
200- new upstream release
201
202* Sun Oct 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.8-1
203- new upstream release
204- remove Patch1 (pciutils-2.2.4-buf.patch)
205
206* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
207- rebuilt with rpm-4.8.1 for pkg-config
208
209* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-3
210- add Requires: %{name}-libs = %{version}-%{release} (devel package)
211
212* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
213- removed %%if !%%{build_compat32} case condition
214
215* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
216- new upstream release
217- add shared library
218- split shared library to -libs
219- split static library to -static
220
221* Fri Nov  7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
222- new upstream release
223
224* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
225- new upstream release
226
227* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
228- applied new versioning policy, spec in utf-8
229
230* Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
231- new upstream release
232
233* Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
234- rebuilt for x86_64 architecture support
235- added compat32-* packages for x86_64 architecture support
236
237* Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
238- updated to 2.2.1 based on fedora package
239  * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
240  - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
241  * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
242  - remove explicit kernel dep (#146153)
243
244* Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
245- use hwdata for pci.ids database.
246- merged with rawhide package.
247  - update to 2.1.10
248  - fix dir perms on /usr/include/pci
249  - don't forcibly strip binaries
250  - require hwdata now that pci.ids is there
251  - man page is now owned by root
252
253* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
254- based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
255
256* Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
257- dump all the patches, ship pci.ids direct out of sourceforge CVS
258
259* Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
260- broadcom bcm5820 id (#53592)
261
262* Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
263- more ids
264
265* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
266- add newline in printf in PCI-X patch (#49277)
267
268* Mon Jul  9 2001 Bill Nottingham <notting@redhat.com>
269- update broadcom patch
270- add new ids from 2.4.6
271
272* Mon May 28 2001 Bill Nottingham <notting@redhat.com>
273- add a couple of e1000 ids
274
275* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
276- another megaraid id
277
278* Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
279- another megaraid id
280
281* Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
282- LSI SCSI PCI id
283
284* Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
285- fix formatting problems
286
287* Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
288- add IBM ServeRAID entries
289
290* Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
291- i860 entries.
292
293* Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
294- added various pci ids
295
296* Fri Feb  2 2001 Bill Nottingham <notting@redhat.com>
297- fix mishap in fixing mishap
298
299* Thu Feb  1 2001 Bill Nottingham <notting@redhat.com>
300- fix apparent mishap in pci.ids update from kernel (#25520)
301
302* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
303- pci.ids updates
304
305* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
306- big pile of pci.ids updates
307
308* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
309- clean up patches to not generate badly-formatted files
310
311* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
312- Vortex fixes laroche originally applied on kudzu moved here.
313
314* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
315- pci ids for i815, new ati hardware
316
317* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
318- automatic rebuild
319
320* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
321- yet more IDs
322- PCI-X support from Matt Domsch
323
324* Fri Jul  7 2000 Bill Nottingham <notting@redhat.com>
325- some more QLogic ids
326
327* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
328- more IDs from Dell
329
330* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
331- update to 2.1.8
332
333* Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
334- update to 2.1.7
335
336* Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
337- update to 2.1.6
338
339* Fri Mar  3 2000 Bill Nottingham <notting@redhat.com>
340- add a couple of ids
341
342* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
343- update to 2.1.5
344
345* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
346- handle compressed man pages
347
348* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
349- update to 2.1.4
350
351* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
352- update to 2.1.3
353
354* Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
355- update to 2.1.2
356
357* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
358- add -devel package
359
360* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
361- update to 2.0
362
363* Mon Apr 19 1999 Jakub Jelinek  <jj@ultra.linux.cz>
364- update to 1.99.5
365- fix sparc64 operation
366
367* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
368- auto rebuild in the new build environment (release 2)
369
370* Thu Feb  4 1999 Bill Nottingham <notting@redhat.com>
371- initial build
Note: See TracBrowser for help on using the repository browser.