source: projects/specs/trunk/p/pciutils/pciutils-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        PCI bus related utilities.
3Summary(ja):    Linux PCI ユーティリティ
4Name:           pciutils
5Version:        3.1.2
6Release:        2%{?_dist_release}
7License:        GPLv2+
8URL:            http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
9Group:          Applications/System
10
11Source:         %{name}-%{version}.tar.gz
12Patch1:         pciutils-2.2.4-buf.patch
13Patch2:         pciutils-2.1.10-scan.patch
14Patch3:         pciutils-havepread.patch
15Patch6:         pciutils-2.2.1-idpath.patch
16Patch8:         pciutils-3.0.2-multilib.patch
17Patch9:         pciutils-dir-d.patch
18Patch10:        pciutils-2.2.10-sparc-support.patch
19Patch11:        pciutils-3.0.1-superh-support.patch
20
21Buildroot:      %{_tmppath}/%{name}-%{version}-root
22ExclusiveOS:    Linux
23BuildRequires:  sed
24Requires:       hwdata
25Requires:       %{name}-libs = %{version}
26
27
28%description
29The pciutils package contains various utilities for inspecting and
30setting devices connected to the PCI bus. The utilities provided
31require kernel version 2.1.82 or newer (which support the
32/proc/bus/pci interface).
33
34%description -l ja
35このパッケージには PCI バスに接続された各種デバイスの状態を見たり
36設定したりする為のユーティリティが収められています.
37このパッケージに収められたユーティリティはカーネル 2.1.82 以降
38(/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
39
40%package devel
41Summary: Linux PCI development library.
42Summary(ja):    Linux PCI 開発ライブラリ
43Group: Development/Libraries
44
45%description devel
46This package contains a library for inspecting and setting
47devices connected to the PCI bus.
48
49%description devel -l ja
50このパッケージには PCI バスに接続された各種デバイスの状態を見たり
51設定したりするのに必要なライブラリが収められています.
52
53%package libs
54Summary: Linux PCI library
55Summary(ja): Linux PCI ライブラリ
56Group: System Environment/Libraries
57
58%description libs
59This package contains a library for inspecting and setting
60devices connected to the PCI bus.
61
62%package static
63Summary: Linux PCI satic library
64Summary(ja): Linux PCI スタッティックライブラリ
65Group: System Environment/Libraries
66Requires: %{name}-devel = %{version}
67
68%description static
69This package contains a library for inspecting and setting
70devices connected to the PCI bus.
71
72## to build compat32 for x86_64 architecture support
73%package -n compat32-%{name}-libs
74Summary: Linux PCI library.
75Group: Development/Libraries
76Requires: compat32-%{name}-devel = %{version}
77%description -n compat32-%{name}-libs
78This package contains a library for inspecting and setting
79devices connected to the PCI bus.
80
81%package -n compat32-%{name}-devel
82Summary: Linux PCI development library.
83Group: Development/Libraries
84%description -n compat32-%{name}-devel
85This package contains a library for inspecting and setting
86devices connected to the PCI bus.
87
88%prep
89%setup -q -n pciutils-%{version}
90%patch1 -p1 -b .buf
91%patch2 -p1 -b .scan
92%patch3 -p1 -b .pread
93%patch6 -p1 -b .idpath
94%patch8 -p1 -b .multilib
95%patch9 -p1 -b .dird
96%patch10 -p1 -b .sparc
97%patch11 -p1 -b .superh
98
99sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
100
101%build
102make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
103mv lib/libpci.a lib/libpci.a.toinstall
104
105make clean
106
107make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
108
109#fix lib vs. lib64 in libpci.pc (static Makefile is used)
110sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
111
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
117
118install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
119install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
120install -p  lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
121ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
122
123mv lib/libpci.a.toinstall lib/libpci.a
124install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
125/sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
126install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
127install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
128install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
129install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
130install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
131
132
133%post libs -p /sbin/ldconfig
134
135%postun libs -p /sbin/ldconfig
136
137%post -n compat32-%{name}-libs -p /sbin/ldconfig
138
139%postun -n compat32-%{name}-libs -p /sbin/ldconfig
140
141
142%files
143%defattr(0644, root, root, 0755)
144%{_mandir}/man8/*
145%attr(0755, root, root) /sbin/*
146%doc README ChangeLog pciutils.lsm
147
148%files devel
149%defattr(0644, root, root, 0755)
150%{_libdir}/libpci.so
151%{_libdir}/pkgconfig/libpci.pc
152%{_includedir}/pci
153
154%files libs
155%defattr(0644, root, root, 0755)
156%{_libdir}/libpci.so.*
157
158%files static
159%defattr(0644, root, root, 0755)
160%{_libdir}/libpci.a
161
162%if %{build_compat32}
163%files -n compat32-%{name}-devel
164%defattr(0644, root, root, 0755)
165%{_libdir}/libpci.so
166%{_libdir}/pkgconfig/libpci.pc
167%{_includedir}/pci
168
169%files -n compat32-%{name}-libs
170%defattr(0644, root, root, 0755)
171%{_libdir}/libpci.so.*
172%endif
173
174
175%clean
176rm -rf $RPM_BUILD_ROOT
177
178
179%changelog
180* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
181- removed %%if !%%{build_compat32} case condition
182
183* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
184- new upstream release
185- add shared library
186- split shared library to -libs
187- split static library to -static
188
189* Fri Nov  7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
190- new upstream release
191
192* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
193- new upstream release
194
195* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
196- applied new versioning policy, spec in utf-8
197
198* Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
199- new upstream release
200
201* Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
202- rebuilt for x86_64 architecture support
203- added compat32-* packages for x86_64 architecture support
204
205* Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
206- updated to 2.2.1 based on fedora package
207  * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
208  - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
209  * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
210  - remove explicit kernel dep (#146153)
211
212* Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
213- use hwdata for pci.ids database.
214- merged with rawhide package.
215  - update to 2.1.10
216  - fix dir perms on /usr/include/pci
217  - don't forcibly strip binaries
218  - require hwdata now that pci.ids is there
219  - man page is now owned by root
220
221* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
222- based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
223
224* Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
225- dump all the patches, ship pci.ids direct out of sourceforge CVS
226
227* Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
228- broadcom bcm5820 id (#53592)
229
230* Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
231- more ids
232
233* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
234- add newline in printf in PCI-X patch (#49277)
235
236* Mon Jul  9 2001 Bill Nottingham <notting@redhat.com>
237- update broadcom patch
238- add new ids from 2.4.6
239
240* Mon May 28 2001 Bill Nottingham <notting@redhat.com>
241- add a couple of e1000 ids
242
243* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
244- another megaraid id
245
246* Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
247- another megaraid id
248
249* Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
250- LSI SCSI PCI id
251
252* Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
253- fix formatting problems
254
255* Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
256- add IBM ServeRAID entries
257
258* Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
259- i860 entries.
260
261* Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
262- added various pci ids
263
264* Fri Feb  2 2001 Bill Nottingham <notting@redhat.com>
265- fix mishap in fixing mishap
266
267* Thu Feb  1 2001 Bill Nottingham <notting@redhat.com>
268- fix apparent mishap in pci.ids update from kernel (#25520)
269
270* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
271- pci.ids updates
272
273* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
274- big pile of pci.ids updates
275
276* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
277- clean up patches to not generate badly-formatted files
278
279* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
280- Vortex fixes laroche originally applied on kudzu moved here.
281
282* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
283- pci ids for i815, new ati hardware
284
285* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
286- automatic rebuild
287
288* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
289- yet more IDs
290- PCI-X support from Matt Domsch
291
292* Fri Jul  7 2000 Bill Nottingham <notting@redhat.com>
293- some more QLogic ids
294
295* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
296- more IDs from Dell
297
298* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
299- update to 2.1.8
300
301* Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
302- update to 2.1.7
303
304* Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
305- update to 2.1.6
306
307* Fri Mar  3 2000 Bill Nottingham <notting@redhat.com>
308- add a couple of ids
309
310* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
311- update to 2.1.5
312
313* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
314- handle compressed man pages
315
316* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
317- update to 2.1.4
318
319* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
320- update to 2.1.3
321
322* Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
323- update to 2.1.2
324
325* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
326- add -devel package
327
328* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
329- update to 2.0
330
331* Mon Apr 19 1999 Jakub Jelinek  <jj@ultra.linux.cz>
332- update to 1.99.5
333- fix sparc64 operation
334
335* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
336- auto rebuild in the new build environment (release 2)
337
338* Thu Feb  4 1999 Bill Nottingham <notting@redhat.com>
339- initial build
Note: See TracBrowser for help on using the repository browser.