source: projects/specs/trunk/p/pciutils/pciutils-vl.spec @ 4881

Revision 4881, 10.4 KB checked in by Takemikaduchi, 13 years ago (diff)

NEW: ETL, synfig, synfigstudio
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        PCI bus related utilities.
3Summary(ja):    Linux PCI ユーティリティ
4Name:           pciutils
5Version:        3.1.8
6Release:        1%{?_dist_release}
7License:        GPLv2+
8URL:            http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
9Group:          Applications/System
10
11Source:         %{name}-%{version}.tar.gz
12Patch2:         pciutils-2.1.10-scan.patch
13Patch3:         pciutils-havepread.patch
14Patch6:         pciutils-2.2.1-idpath.patch
15Patch8:         pciutils-3.0.2-multilib.patch
16Patch9:         pciutils-dir-d.patch
17Patch10:        pciutils-2.2.10-sparc-support.patch
18Patch11:        pciutils-3.0.1-superh-support.patch
19
20Buildroot:      %{_tmppath}/%{name}-%{version}-root
21ExclusiveOS:    Linux
22BuildRequires:  sed
23Requires:       hwdata
24Requires:       %{name}-libs = %{version}-%{release}
25
26
27%description
28The pciutils package contains various utilities for inspecting and
29setting devices connected to the PCI bus. The utilities provided
30require kernel version 2.1.82 or newer (which support the
31/proc/bus/pci interface).
32
33%description -l ja
34このパッケージには PCI バスに接続された各種デバイスの状態を見たり
35設定したりする為のユーティリティが収められています.
36このパッケージに収められたユーティリティはカーネル 2.1.82 以降
37(/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
38
39%package devel
40Summary: Linux PCI development library.
41Summary(ja):    Linux PCI 開発ライブラリ
42Group: Development/Libraries
43Requires: %{name}-libs = %{version}-%{release}
44
45%description devel
46This package contains a library for inspecting and setting
47devices connected to the PCI bus.
48
49%description devel -l ja
50このパッケージには PCI バスに接続された各種デバイスの状態を見たり
51設定したりするのに必要なライブラリが収められています.
52
53%package libs
54Summary: Linux PCI library
55Summary(ja): Linux PCI ライブラリ
56Group: System Environment/Libraries
57
58%description libs
59This package contains a library for inspecting and setting
60devices connected to the PCI bus.
61
62%package static
63Summary: Linux PCI satic library
64Summary(ja): Linux PCI スタッティックライブラリ
65Group: System Environment/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67
68%description static
69This package contains a library for inspecting and setting
70devices connected to the PCI bus.
71
72## to build compat32 for x86_64 architecture support
73%package -n compat32-%{name}-libs
74Summary: Linux PCI library.
75Group: Development/Libraries
76Requires: compat32-%{name}-devel = %{version}-%{release}
77%description -n compat32-%{name}-libs
78This package contains a library for inspecting and setting
79devices connected to the PCI bus.
80
81%package -n compat32-%{name}-devel
82Summary: Linux PCI development library.
83Group: Development/Libraries
84%description -n compat32-%{name}-devel
85This package contains a library for inspecting and setting
86devices connected to the PCI bus.
87
88%prep
89%setup -q -n pciutils-%{version}
90%patch2 -p1 -b .scan
91%patch3 -p1 -b .pread
92%patch6 -p1 -b .idpath
93%patch8 -p1 -b .multilib
94%patch9 -p1 -b .dird
95%patch10 -p1 -b .sparc
96%patch11 -p1 -b .superh
97
98sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
99
100%build
101make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
102mv lib/libpci.a lib/libpci.a.toinstall
103
104make clean
105
106make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
107
108#fix lib vs. lib64 in libpci.pc (static Makefile is used)
109sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
110
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
116
117install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
118install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
119install -p  lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
120ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
121
122mv lib/libpci.a.toinstall lib/libpci.a
123install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
124/sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
125install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
126install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
127install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
128install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
129install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
130
131
132%post libs -p /sbin/ldconfig
133
134%postun libs -p /sbin/ldconfig
135
136%post -n compat32-%{name}-libs -p /sbin/ldconfig
137
138%postun -n compat32-%{name}-libs -p /sbin/ldconfig
139
140
141%files
142%defattr(0644, root, root, 0755)
143%{_mandir}/man8/*
144%attr(0755, root, root) /sbin/*
145%doc README ChangeLog pciutils.lsm
146
147%files devel
148%defattr(0644, root, root, 0755)
149%{_libdir}/libpci.so
150%{_libdir}/pkgconfig/libpci.pc
151%{_includedir}/pci
152
153%files libs
154%defattr(0644, root, root, 0755)
155%{_libdir}/libpci.so.*
156
157%files static
158%defattr(0644, root, root, 0755)
159%{_libdir}/libpci.a
160
161%if %{build_compat32}
162%files -n compat32-%{name}-devel
163%defattr(0644, root, root, 0755)
164%{_libdir}/libpci.so
165%{_libdir}/pkgconfig/libpci.pc
166%{_includedir}/pci
167
168%files -n compat32-%{name}-libs
169%defattr(0644, root, root, 0755)
170%{_libdir}/libpci.so.*
171%endif
172
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177
178%changelog
179* Sun Oct 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.8-1
180- new upstream release
181- remove Patch1 (pciutils-2.2.4-buf.patch)
182
183* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
184- rebuilt with rpm-4.8.1 for pkg-config
185
186* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-3
187- add Requires: %{name}-libs = %{version}-%{release} (devel package)
188
189* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
190- removed %%if !%%{build_compat32} case condition
191
192* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
193- new upstream release
194- add shared library
195- split shared library to -libs
196- split static library to -static
197
198* Fri Nov  7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
199- new upstream release
200
201* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
202- new upstream release
203
204* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
205- applied new versioning policy, spec in utf-8
206
207* Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
208- new upstream release
209
210* Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
211- rebuilt for x86_64 architecture support
212- added compat32-* packages for x86_64 architecture support
213
214* Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
215- updated to 2.2.1 based on fedora package
216  * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
217  - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
218  * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
219  - remove explicit kernel dep (#146153)
220
221* Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
222- use hwdata for pci.ids database.
223- merged with rawhide package.
224  - update to 2.1.10
225  - fix dir perms on /usr/include/pci
226  - don't forcibly strip binaries
227  - require hwdata now that pci.ids is there
228  - man page is now owned by root
229
230* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
231- based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
232
233* Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
234- dump all the patches, ship pci.ids direct out of sourceforge CVS
235
236* Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
237- broadcom bcm5820 id (#53592)
238
239* Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
240- more ids
241
242* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
243- add newline in printf in PCI-X patch (#49277)
244
245* Mon Jul  9 2001 Bill Nottingham <notting@redhat.com>
246- update broadcom patch
247- add new ids from 2.4.6
248
249* Mon May 28 2001 Bill Nottingham <notting@redhat.com>
250- add a couple of e1000 ids
251
252* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
253- another megaraid id
254
255* Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
256- another megaraid id
257
258* Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
259- LSI SCSI PCI id
260
261* Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
262- fix formatting problems
263
264* Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
265- add IBM ServeRAID entries
266
267* Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
268- i860 entries.
269
270* Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
271- added various pci ids
272
273* Fri Feb  2 2001 Bill Nottingham <notting@redhat.com>
274- fix mishap in fixing mishap
275
276* Thu Feb  1 2001 Bill Nottingham <notting@redhat.com>
277- fix apparent mishap in pci.ids update from kernel (#25520)
278
279* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
280- pci.ids updates
281
282* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
283- big pile of pci.ids updates
284
285* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
286- clean up patches to not generate badly-formatted files
287
288* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
289- Vortex fixes laroche originally applied on kudzu moved here.
290
291* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
292- pci ids for i815, new ati hardware
293
294* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
295- automatic rebuild
296
297* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
298- yet more IDs
299- PCI-X support from Matt Domsch
300
301* Fri Jul  7 2000 Bill Nottingham <notting@redhat.com>
302- some more QLogic ids
303
304* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
305- more IDs from Dell
306
307* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
308- update to 2.1.8
309
310* Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
311- update to 2.1.7
312
313* Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
314- update to 2.1.6
315
316* Fri Mar  3 2000 Bill Nottingham <notting@redhat.com>
317- add a couple of ids
318
319* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
320- update to 2.1.5
321
322* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
323- handle compressed man pages
324
325* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
326- update to 2.1.4
327
328* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
329- update to 2.1.3
330
331* Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
332- update to 2.1.2
333
334* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
335- add -devel package
336
337* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
338- update to 2.0
339
340* Mon Apr 19 1999 Jakub Jelinek  <jj@ultra.linux.cz>
341- update to 1.99.5
342- fix sparc64 operation
343
344* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
345- auto rebuild in the new build environment (release 2)
346
347* Thu Feb  4 1999 Bill Nottingham <notting@redhat.com>
348- initial build
Note: See TracBrowser for help on using the repository browser.