source: projects/specs/trunk/p/pciutils/pciutils-vl.spec @ 10288

Revision 10288, 11.0 KB checked in by Takemikaduchi, 8 years ago (diff)

task-all-codecs: remove xine-lib-esd
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        PCI bus related utilities.
3Summary(ja):    Linux PCI ユーティリティ
4Name:           pciutils
5Version:        3.4.1
6Release:        1%{?_dist_release}
7License:        GPLv2+
8URL:            http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
9Group:          Applications/System
10
11Source:         %{name}-%{version}.tar.gz
12Patch2:         pciutils-2.1.10-scan.patch
13Patch3:         pciutils-havepread.patch
14Patch6:         pciutils-2.2.1-idpath.patch
15Patch8:         pciutils-3.3.0-multilib.patch
16Patch9:         pciutils-dir-d.patch
17Patch10:        pciutils-2.2.10-sparc-support.patch
18Patch11:        pciutils-3.0.1-superh-support.patch
19
20Buildroot:      %{_tmppath}/%{name}-%{version}-root
21ExclusiveOS:    Linux
22BuildRequires:  sed
23Requires:       hwdata
24Requires:       %{name}-libs = %{version}-%{release}
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The pciutils package contains various utilities for inspecting and
31setting devices connected to the PCI bus. The utilities provided
32require kernel version 2.1.82 or newer (which support the
33/proc/bus/pci interface).
34
35%description -l ja
36このパッケージには PCI バスに接続された各種デバイスの状態を見たり
37設定したりする為のユーティリティが収められています.
38このパッケージに収められたユーティリティはカーネル 2.1.82 以降
39(/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
40
41%package devel
42Summary: Linux PCI development library.
43Summary(ja):    Linux PCI 開発ライブラリ
44Group: Development/Libraries
45Requires: %{name}-libs = %{version}-%{release}
46
47%description devel
48This package contains a library for inspecting and setting
49devices connected to the PCI bus.
50
51%description devel -l ja
52このパッケージには PCI バスに接続された各種デバイスの状態を見たり
53設定したりするのに必要なライブラリが収められています.
54
55%package libs
56Summary: Linux PCI library
57Summary(ja): Linux PCI ライブラリ
58Group: System Environment/Libraries
59
60%description libs
61This package contains a library for inspecting and setting
62devices connected to the PCI bus.
63
64%package static
65Summary: Linux PCI satic library
66Summary(ja): Linux PCI スタッティックライブラリ
67Group: System Environment/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71This package contains a library for inspecting and setting
72devices connected to the PCI bus.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}-libs
76Summary: Linux PCI library.
77Group: Development/Libraries
78Requires: compat32-%{name}-devel = %{version}-%{release}
79%description -n compat32-%{name}-libs
80This package contains a library for inspecting and setting
81devices connected to the PCI bus.
82
83%package -n compat32-%{name}-devel
84Summary: Linux PCI development library.
85Group: Development/Libraries
86%description -n compat32-%{name}-devel
87This package contains a library for inspecting and setting
88devices connected to the PCI bus.
89
90%prep
91%setup -q -n pciutils-%{version}
92%patch2 -p1 -b .scan
93%patch3 -p1 -b .pread
94%patch6 -p1 -b .idpath
95%patch8 -p1 -b .multilib
96%patch9 -p1 -b .dird
97%patch10 -p1 -b .sparc
98%patch11 -p1 -b .superh
99
100sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
101
102%build
103make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
104mv lib/libpci.a lib/libpci.a.toinstall
105
106make clean
107
108make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
109
110#fix lib vs. lib64 in libpci.pc (static Makefile is used)
111sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
112
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
118
119install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
120install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
121install -p  lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
122ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
123
124mv lib/libpci.a.toinstall lib/libpci.a
125install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
126/sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
127install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
128install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
129install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
130install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
131install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
132
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138%post -n compat32-%{name}-libs -p /sbin/ldconfig
139
140%postun -n compat32-%{name}-libs -p /sbin/ldconfig
141
142
143%files
144%defattr(-,root,root,-)
145%{_mandir}/man8/*
146%attr(0755, root, root) /sbin/*
147%doc README ChangeLog pciutils.lsm
148
149%files devel
150%defattr(-,root,root,-)
151%{_libdir}/libpci.so
152%{_libdir}/pkgconfig/libpci.pc
153%{_includedir}/pci
154
155%files libs
156%defattr(-,root,root,-)
157%{_libdir}/libpci.so.*
158
159%files static
160%defattr(-,root,root,-)
161%{_libdir}/libpci.a
162
163%if %{build_compat32}
164%files -n compat32-%{name}-devel
165%defattr(-,root,root,-)
166%{_libdir}/libpci.so
167%{_libdir}/pkgconfig/libpci.pc
168%{_includedir}/pci
169
170%files -n compat32-%{name}-libs
171%defattr(-,root,root,-)
172%{_libdir}/libpci.so.*
173%endif
174
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179
180%changelog
181* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
182- new upstream release
183
184* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
185- new upstream release
186
187* Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
188- new upstream release
189- update Patch3 (pciutils-havepread.patch)
190
191* Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
192- new upstream release
193- update Patch8 (pciutils-3.3.0-multilib.patch)
194
195* Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
196- new upstream release
197
198* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
199- new upstream release
200
201* Sun Oct 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.8-1
202- new upstream release
203- remove Patch1 (pciutils-2.2.4-buf.patch)
204
205* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
206- rebuilt with rpm-4.8.1 for pkg-config
207
208* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-3
209- add Requires: %{name}-libs = %{version}-%{release} (devel package)
210
211* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
212- removed %%if !%%{build_compat32} case condition
213
214* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
215- new upstream release
216- add shared library
217- split shared library to -libs
218- split static library to -static
219
220* Fri Nov  7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
221- new upstream release
222
223* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
224- new upstream release
225
226* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
227- applied new versioning policy, spec in utf-8
228
229* Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
230- new upstream release
231
232* Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
233- rebuilt for x86_64 architecture support
234- added compat32-* packages for x86_64 architecture support
235
236* Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
237- updated to 2.2.1 based on fedora package
238  * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
239  - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
240  * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
241  - remove explicit kernel dep (#146153)
242
243* Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
244- use hwdata for pci.ids database.
245- merged with rawhide package.
246  - update to 2.1.10
247  - fix dir perms on /usr/include/pci
248  - don't forcibly strip binaries
249  - require hwdata now that pci.ids is there
250  - man page is now owned by root
251
252* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
253- based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
254
255* Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
256- dump all the patches, ship pci.ids direct out of sourceforge CVS
257
258* Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
259- broadcom bcm5820 id (#53592)
260
261* Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
262- more ids
263
264* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
265- add newline in printf in PCI-X patch (#49277)
266
267* Mon Jul  9 2001 Bill Nottingham <notting@redhat.com>
268- update broadcom patch
269- add new ids from 2.4.6
270
271* Mon May 28 2001 Bill Nottingham <notting@redhat.com>
272- add a couple of e1000 ids
273
274* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
275- another megaraid id
276
277* Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
278- another megaraid id
279
280* Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
281- LSI SCSI PCI id
282
283* Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
284- fix formatting problems
285
286* Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
287- add IBM ServeRAID entries
288
289* Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
290- i860 entries.
291
292* Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
293- added various pci ids
294
295* Fri Feb  2 2001 Bill Nottingham <notting@redhat.com>
296- fix mishap in fixing mishap
297
298* Thu Feb  1 2001 Bill Nottingham <notting@redhat.com>
299- fix apparent mishap in pci.ids update from kernel (#25520)
300
301* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
302- pci.ids updates
303
304* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
305- big pile of pci.ids updates
306
307* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
308- clean up patches to not generate badly-formatted files
309
310* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
311- Vortex fixes laroche originally applied on kudzu moved here.
312
313* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
314- pci ids for i815, new ati hardware
315
316* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
317- automatic rebuild
318
319* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
320- yet more IDs
321- PCI-X support from Matt Domsch
322
323* Fri Jul  7 2000 Bill Nottingham <notting@redhat.com>
324- some more QLogic ids
325
326* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
327- more IDs from Dell
328
329* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
330- update to 2.1.8
331
332* Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
333- update to 2.1.7
334
335* Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
336- update to 2.1.6
337
338* Fri Mar  3 2000 Bill Nottingham <notting@redhat.com>
339- add a couple of ids
340
341* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
342- update to 2.1.5
343
344* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
345- handle compressed man pages
346
347* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
348- update to 2.1.4
349
350* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
351- update to 2.1.3
352
353* Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
354- update to 2.1.2
355
356* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
357- add -devel package
358
359* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
360- update to 2.0
361
362* Mon Apr 19 1999 Jakub Jelinek  <jj@ultra.linux.cz>
363- update to 1.99.5
364- fix sparc64 operation
365
366* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
367- auto rebuild in the new build environment (release 2)
368
369* Thu Feb  4 1999 Bill Nottingham <notting@redhat.com>
370- initial build
Note: See TracBrowser for help on using the repository browser.