source: projects/specs/trunk/p/parole/parole-vl.spec @ 8787

Revision 8787, 6.4 KB checked in by kudoh, 10 years ago (diff)

new upstream release and initial build

Line 
1# by default don't build the browser plugin
2# use bcond_without to change the default
3#%bcond_with mozilla
4%define PAROLE_BIN %{_libexecdir}/%{name}
5
6Name:           parole
7Version:        0.5.4
8Release:        1%{?_dist_release}
9Summary:        Media player for the Xfce desktop
10Summary(ja):    Xfce デスクトップのメディアプレーヤー
11
12Group:          Applications/Multimedia
13License:        GPLv2+
14URL:            http://goodies.xfce.org/projects/applications/parole
15Source0:        http://archive.xfce.org/src/apps/parole/0.3/%{name}-%{version}.tar.bz2
16Source10:       parole.sh
17#Patch1:                parole-0.2.0.6-dsofix.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  desktop-file-utils
22BuildRequires:  gettext
23BuildRequires:  gtk-doc
24BuildRequires:  gtk2-devel >= 2.20.0
25BuildRequires:  glib2-devel >= 2.32.0
26BuildRequires:  gstreamer-devel
27BuildRequires:  gstreamer-plugins-base-devel >= 0.10.24
28BuildRequires:  dbus-devel >= 0.60
29BuildRequires:  dbus-glib-devel >= 0.70
30BuildRequires:  intltool
31BuildRequires:  libnotify-devel >= 0.4.1
32BuildRequires:  libxfcegui4-devel >= 4.8.0
33BuildRequires:  libxfce4util-devel >= 4.8.0
34BuildRequires:  libxfce4ui-devel >= 4.8.0
35BuildRequires:  xfce4-dev-tools
36BuildRequires:  taglib-devel >= 1.4
37
38#%if %{with mozilla}
39#BuildRequires:  xulrunner-devel
40#%endif
41Requires:       gstreamer-plugins-good
42
43Obsoletes: %{name}-mozplugin
44
45%description
46Parole is a modern simple media player based on the GStreamer framework and
47written to fit well in the Xfce desktop. Parole features playback of local
48media files, DVD/CD and live streams. Parole is extensible via plugins.
49
50The project still in its early developments stage, but already contains the
51following features:
52* Audio playback
53* Video playback with optional subtitle
54* Playback of live sources
55
56%description -l ja
57Parole は GStreamer フレームワークに基づき Xfce デスクトップに
58馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
59Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
60特色とします。
61Parole はプラグインを介して拡張が可能です。
62
63このプロジェクトはまだ開発の初期段階ですが、
64既に以下の機能がふくまれています。
65* オーディオの再生
66* 任意のサブタイトルがあるビデオの再生
67* ライブストリームの再生
68
69
70%package        devel
71Summary:        Development files for %{name}
72Summary(ja):    %{name} の開発ファイル
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       gtk-doc
76
77%description    devel
78The %{name}-devel package contains header files for developing plugins for
79%{name}.
80
81%description    devel -l ja
82%{name}-devel パッケージ は %{name} のプラグインを開発するための
83ヘッダファイルを含みます。
84
85%prep
86%setup -q
87#%patch1 -p1
88
89%build
90./autogen.sh
91%configure --disable-static --enable-gtk-doc
92make %{?_smp_mflags} V=1
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make install DESTDIR=$RPM_BUILD_ROOT
98find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
99
100## wrapper install
101%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
102%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
103%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
104
105
106%find_lang %{name}
107
108desktop-file-install                                    \
109  --delete-original                                     \
110  --dir=%{buildroot}%{_datadir}/applications            \
111  %{buildroot}/%{_datadir}/applications/%{name}.desktop
112
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117
118%post
119touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
120update-mime-database %{_datadir}/mime &> /dev/null || :
121
122
123%postun
124if [ $1 -eq 0 ] ; then
125  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
126  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
127fi
128update-mime-database %{_datadir}/mime &> /dev/null || :
129
130
131%posttrans
132gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
133
134
135%files -f %{name}.lang
136%defattr(-,root,root,-)
137%doc AUTHORS COPYING README TODO THANKS
138%{PAROLE_BIN}
139%{_bindir}/%{name}
140%dir %{_libdir}/%{name}-0/
141%{_libdir}/%{name}-0/*.so
142%{_datadir}/applications/%{name}.desktop
143%{_datadir}/icons/hicolor/*
144%{_datadir}/%{name}/
145
146
147%files devel
148%defattr(-,root,root,-)
149%doc %{_datadir}/gtk-doc/html/Parole-Plugins/
150%{_includedir}/%{name}/
151
152
153%changelog
154* Sat Jul 12 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
155- new upstream release
156
157* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
158- new upstream release
159
160* Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
161- new upstream release
162- deleted Patch1
163- added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
164- changed BuildRequires
165   - gtk2-devel >= 2.16.0 to 2.20.0
166   - glib2-devel >= 2.16.0  to 2.32.0
167   - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
168   - libxfcegui4-devel >= 4.6.0 to 4.8.0
169   - libxfce4util-devel >= 4.6.0 to 4.8.0
170
171* Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
172- rebuilt with new libxfce4util
173
174* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
175- added Obsoletes tag: %%{name}-mozplugin
176- added wrapper script to detect nonfree package installed
177
178* Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
179- new upstream release
180- obsoleted -mozplugin package
181
182* Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
183- new upstream release
184
185* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
186- new upstream release
187
188* Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
189- new upstream release
190- added BuildRequires:  glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
191
192* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
193- new upstream release
194- added BuildRequires: gstreamer-devel
195- splitted mozplugin package
196
197* Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
198- new upstream release
199- dropt all pathces
200
201* Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
202- initial build for VineSeed
203
204* Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
205- BuildRequire taglib-devel and fix libnotify requirement
206
207* Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
208- Update to 0.1.90
209- Loads of additional translations
210
211* Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
212- Initial package
Note: See TracBrowser for help on using the repository browser.