source: projects/specs/trunk/p/parole/parole-vl.spec @ 9400

Revision 9400, 6.6 KB checked in by inagaki, 9 years ago (diff)

2015-03-01 Ryoichi INAGAKI <ryo1@…>

  • mousepad, parole, xarchiver, xfburn, xfce4-screenshooter, xfce4-taskmanager: updated
  • orage, thunar-*-plugin, xfce4-dict, xfce4-mixer, xfce4-notifyd, xfce4-terminal: rebuilt
  • ristretto: NEW
  • xfce4-appfinder: enabled gtk3


Line 
1# by default don't build the browser plugin
2# use bcond_without to change the default
3#%bcond_with mozilla
4%define PAROLE_BIN %{_libexecdir}/%{name}
5
6Name:           parole
7Version:        0.8.0
8Release:        1%{?_dist_release}
9Summary:        Media player for the Xfce desktop
10Summary(ja):    Xfce デスクトップのメディアプレーヤー
11
12Group:          Applications/Multimedia
13License:        GPLv2+
14URL:            http://goodies.xfce.org/projects/applications/parole
15Source0:        http://archive.xfce.org/src/apps/parole/0.8/%{name}-%{version}.tar.bz2
16Source10:       parole.sh
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  clutter-devel >= 1.16.4
20BuildRequires:  clutter-gtk-devel >= 1.4.4
21BuildRequires:  dbus-devel >= 0.60
22BuildRequires:  dbus-glib-devel >= 0.70
23BuildRequires:  desktop-file-utils
24BuildRequires:  gettext
25BuildRequires:  glib2-devel >= 2.32.0
26BuildRequires:  gstreamer1-devel
27BuildRequires:  gstreamer1-plugins-base-devel
28BuildRequires:  gtk3-devel >= 3.2.0
29BuildRequires:  gtk-doc
30BuildRequires:  intltool
31BuildRequires:  libnotify-devel >= 0.4.1
32BuildRequires:  libxfce4ui-devel >= 4.11.0
33BuildRequires:  libxfce4util-devel >= 4.10.0
34BuildRequires:  taglib-devel >= 1.4
35BuildRequires:  xfce4-dev-tools
36BuildRequires:  xfconf-devel >= 4.10.0
37
38#%if %{with mozilla}
39#BuildRequires:  xulrunner-devel
40#%endif
41Requires:       gstreamer1-plugins-good
42# required by SOURCE10
43Requires:       synaptic zenity
44
45Obsoletes:      %{name}-mozplugin
46
47%description
48Parole is a modern simple media player based on the GStreamer framework and
49written to fit well in the Xfce desktop. Parole features playback of local
50media files, DVD/CD and live streams. Parole is extensible via plugins.
51
52The project still in its early developments stage, but already contains the
53following features:
54* Audio playback
55* Video playback with optional subtitle
56* Playback of live sources
57
58%description -l ja
59Parole は GStreamer フレームワークに基づき Xfce デスクトップに
60馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
61Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
62特色とします。
63Parole はプラグインを介して拡張が可能です。
64
65このプロジェクトはまだ開発の初期段階ですが、
66既に以下の機能がふくまれています。
67* オーディオの再生
68* 任意のサブタイトルがあるビデオの再生
69* ライブストリームの再生
70
71
72%package        devel
73Summary:        Development files for %{name}
74Summary(ja):    %{name} の開発ファイル
75Group:          Development/Libraries
76Requires:       %{name} = %{version}-%{release}
77
78%description    devel
79The %{name}-devel package contains header files for developing plugins for
80%{name}.
81
82%description    devel -l ja
83%{name}-devel パッケージ は %{name} のプラグインを開発するための
84ヘッダファイルを含みます。
85
86%prep
87%setup -q
88#%patch1 -p1
89
90%build
91#/autogen.sh
92%configure --disable-static --enable-gtk-doc --enable-clutter
93make %{?_smp_mflags} V=1
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
100
101## wrapper install
102mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
103mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
104install -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
105
106
107%find_lang %{name}
108
109desktop-file-install   \
110    --delete-original  \
111    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
112    $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117
118%post
119touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
120update-mime-database %{_datadir}/mime &> /dev/null || :
121
122%postun
123if [ $1 -eq 0 ] ; then
124  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
125  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
126fi
127update-mime-database %{_datadir}/mime &> /dev/null || :
128
129%posttrans
130gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
131
132
133%files -f %{name}.lang
134%defattr(-,root,root,-)
135%doc AUTHORS COPYING README TODO THANKS
136%{PAROLE_BIN}
137%{_bindir}/%{name}
138%dir %{_libdir}/%{name}-0
139%{_libdir}/%{name}-0/*.so
140%{_datadir}/appdata/%{name}.appdata.xml
141%{_datadir}/applications/%{name}.desktop
142%{_datadir}/icons/hicolor/*
143%{_datadir}/%{name}
144
145
146%files devel
147%defattr(-,root,root,-)
148%doc %{_datadir}/gtk-doc/html/Parole-Plugins/
149%{_includedir}/%{name}
150
151
152%changelog
153* Sun Mar  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-1
154- new upstream release
155- updated to SOURCE10
156- built with libxfce4util 4.12.1 and gstreamer1-plugins
157
158* Sat Jul 12 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
159- new upstream release
160
161* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
162- new upstream release
163
164* Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
165- new upstream release
166- deleted Patch1
167- added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
168- changed BuildRequires
169   - gtk2-devel >= 2.16.0 to 2.20.0
170   - glib2-devel >= 2.16.0  to 2.32.0
171   - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
172   - libxfcegui4-devel >= 4.6.0 to 4.8.0
173   - libxfce4util-devel >= 4.6.0 to 4.8.0
174
175* Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
176- rebuilt with new libxfce4util
177
178* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
179- added Obsoletes tag: %%{name}-mozplugin
180- added wrapper script to detect nonfree package installed
181
182* Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
183- new upstream release
184- obsoleted -mozplugin package
185
186* Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
187- new upstream release
188
189* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
190- new upstream release
191
192* Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
193- new upstream release
194- added BuildRequires:  glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
195
196* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
197- new upstream release
198- added BuildRequires: gstreamer-devel
199- splitted mozplugin package
200
201* Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
202- new upstream release
203- dropt all pathces
204
205* Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
206- initial build for VineSeed
207
208* Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
209- BuildRequire taglib-devel and fix libnotify requirement
210
211* Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
212- Update to 0.1.90
213- Loads of additional translations
214
215* Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
216- Initial package
Note: See TracBrowser for help on using the repository browser.