source: projects/specs/trunk/p/parole/parole-vl.spec @ 9879

Revision 9879, 6.6 KB checked in by inagaki, 8 years ago (diff)

2015-12-20 Ryoichi INAGAKI <ryo1@…>

  • libexo, parole, xfce4-pulseaudio-plugin, xfce4-weather-plugin: updated


RevLine 
[521]1# by default don't build the browser plugin
2# use bcond_without to change the default
[4852]3#%bcond_with mozilla
[6244]4%define PAROLE_BIN %{_libexecdir}/%{name}
[521]5
6Name:           parole
[9879]7Version:        0.8.1
[6752]8Release:        1%{?_dist_release}
[521]9Summary:        Media player for the Xfce desktop
10Summary(ja):    Xfce デスクトップのメディアプレーヤー
11
12Group:          Applications/Multimedia
13License:        GPLv2+
14URL:            http://goodies.xfce.org/projects/applications/parole
[9400]15Source0:        http://archive.xfce.org/src/apps/parole/0.8/%{name}-%{version}.tar.bz2
[6244]16Source10:       parole.sh
[4852]17
[521]18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[9400]19BuildRequires:  clutter-devel >= 1.16.4
20BuildRequires:  clutter-gtk-devel >= 1.4.4
21BuildRequires:  dbus-devel >= 0.60
22BuildRequires:  dbus-glib-devel >= 0.70
[6752]23BuildRequires:  desktop-file-utils
24BuildRequires:  gettext
[9400]25BuildRequires:  glib2-devel >= 2.32.0
26BuildRequires:  gstreamer1-devel
27BuildRequires:  gstreamer1-plugins-base-devel
28BuildRequires:  gtk3-devel >= 3.2.0
[6752]29BuildRequires:  gtk-doc
30BuildRequires:  intltool
[521]31BuildRequires:  libnotify-devel >= 0.4.1
[9400]32BuildRequires:  libxfce4ui-devel >= 4.11.0
33BuildRequires:  libxfce4util-devel >= 4.10.0
34BuildRequires:  taglib-devel >= 1.4
[6752]35BuildRequires:  xfce4-dev-tools
[9400]36BuildRequires:  xfconf-devel >= 4.10.0
[4852]37
38#%if %{with mozilla}
39#BuildRequires:  xulrunner-devel
40#%endif
[9400]41Requires:       gstreamer1-plugins-good
[521]42
[9400]43Obsoletes:      %{name}-mozplugin
[6244]44
[521]45%description
46Parole is a modern simple media player based on the GStreamer framework and
47written to fit well in the Xfce desktop. Parole features playback of local
48media files, DVD/CD and live streams. Parole is extensible via plugins.
49
50The project still in its early developments stage, but already contains the
51following features:
52* Audio playback
53* Video playback with optional subtitle
54* Playback of live sources
55
56%description -l ja
57Parole は GStreamer フレームワークに基づき Xfce デスクトップに
58馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
59Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
60特色とします。
61Parole はプラグインを介して拡張が可能です。
62
63このプロジェクトはまだ開発の初期段階ですが、
64既に以下の機能がふくまれています。
65* オーディオの再生
66* 任意のサブタイトルがあるビデオの再生
67* ライブストリームの再生
68
69
70%package        devel
71Summary:        Development files for %{name}
72Summary(ja):    %{name} の開発ファイル
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75
76%description    devel
77The %{name}-devel package contains header files for developing plugins for
78%{name}.
79
80%description    devel -l ja
81%{name}-devel パッケージ は %{name} のプラグインを開発するための
82ヘッダファイルを含みます。
83
84%prep
85%setup -q
86
87%build
[9400]88%configure --disable-static --enable-gtk-doc --enable-clutter
[6752]89make %{?_smp_mflags} V=1
[521]90
91
92%install
93rm -rf $RPM_BUILD_ROOT
94make install DESTDIR=$RPM_BUILD_ROOT
95find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
[4852]96
[6244]97## wrapper install
[9400]98mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
99mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
100install -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
[6244]101
102
[521]103%find_lang %{name}
104
[9400]105desktop-file-install   \
106    --delete-original  \
107    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
108    $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
[521]109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%post
115touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
116update-mime-database %{_datadir}/mime &> /dev/null || :
117
118%postun
119if [ $1 -eq 0 ] ; then
120  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
121  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
122fi
123update-mime-database %{_datadir}/mime &> /dev/null || :
124
125%posttrans
126gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
127
128
129%files -f %{name}.lang
130%defattr(-,root,root,-)
131%doc AUTHORS COPYING README TODO THANKS
[6244]132%{PAROLE_BIN}
[521]133%{_bindir}/%{name}
[9400]134%dir %{_libdir}/%{name}-0
[521]135%{_libdir}/%{name}-0/*.so
[9400]136%{_datadir}/appdata/%{name}.appdata.xml
[521]137%{_datadir}/applications/%{name}.desktop
138%{_datadir}/icons/hicolor/*
[9400]139%{_datadir}/%{name}
[521]140
141%files devel
142%defattr(-,root,root,-)
143%doc %{_datadir}/gtk-doc/html/Parole-Plugins/
[9400]144%{_includedir}/%{name}
[521]145
146
147%changelog
[9879]148* Sat Dec 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.1-1
149- new upstream release
150
[9400]151* Sun Mar  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-1
152- new upstream release
153- updated to SOURCE10
154- built with libxfce4util 4.12.1 and gstreamer1-plugins
155
[8787]156* Sat Jul 12 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
157- new upstream release
158
[8057]159* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
160- new upstream release
161
[6752]162* Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
163- new upstream release
164- deleted Patch1
165- added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
166- changed BuildRequires
167   - gtk2-devel >= 2.16.0 to 2.20.0
168   - glib2-devel >= 2.16.0  to 2.32.0
169   - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
170   - libxfcegui4-devel >= 4.6.0 to 4.8.0
171   - libxfce4util-devel >= 4.6.0 to 4.8.0
172
[6294]173* Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
174- rebuilt with new libxfce4util
175
[6244]176* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
177- added Obsoletes tag: %%{name}-mozplugin
178- added wrapper script to detect nonfree package installed
179
[4852]180* Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
181- new upstream release
182- obsoleted -mozplugin package
183
[521]184* Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
185- new upstream release
186
187* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
188- new upstream release
189
190* Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
191- new upstream release
192- added BuildRequires:  glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
193
194* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
195- new upstream release
196- added BuildRequires: gstreamer-devel
197- splitted mozplugin package
198
199* Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
200- new upstream release
201- dropt all pathces
202
203* Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
204- initial build for VineSeed
205
206* Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
207- BuildRequire taglib-devel and fix libnotify requirement
208
209* Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
210- Update to 0.1.90
211- Loads of additional translations
212
213* Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
214- Initial package
Note: See TracBrowser for help on using the repository browser.